VNCPassView

VNCPassView v1.05
Copyright (c) 2007 - 2014 Nir Sofer
Web site: http://www.nirsoft.net

Description

VNCPassView is a small utility that recover the passwords stored by the VNC tool. It can recover 2 of passwords: password stored for the current logged-on user (HKEY_CURRENT_USER in the Registry), and password stored for the all users.

Versions History

  • Version 1.05 - Added support for the password of TightVNC.
  • Version 1.02 - Added support for the latest version of UltraVNC.
  • Version 1.01 - Added support for version 3 of VNC.
  • Version 1.00 - First release.

Using VNCPassView

This utility doesn't require any installaion process or additional DLLs. Just run the executable file (VNCPassView.exe), and the VNC passwords will be displayed, if they are stored on your computer.

Translating VNCPassView to other languages

In order to translate VNCPassView to other language, follow the instructions below:
  1. Run VNCPassView with /savelangfile parameter:
    VNCPassView.exe /savelangfile
    A file named VNCPassView_lng.ini will be created in the folder of VNCPassView utility.
  2. Open the created language file in Notepad or in any other text editor.
  3. Translate all string entries to the desired language. Optionally, you can also add your name and/or a link to your Web site. (TranslatorName and TranslatorURL values) If you add this information, it'll be used in the 'About' window.
  4. After you finish the translation, Run VNCPassView, and all translated strings will be loaded from the language file.
    If you want to run VNCPassView without the translation, simply rename the language file, or move it to another folder.

License

This utility is released as freeware. You are allowed to freely distribute this utility via floppy disk, CD-ROM, Internet, or in any other way, as long as you don't charge anything for this. If you distribute this utility, you must include all files in the distribution package, without any modification !

Disclaimer

The software is provided "AS IS" without any warranty, either expressed or implied, including, but not limited to, the implied warranties of merchantability and fitness for a particular purpose. The author will not be liable for any special, incidental, consequential or indirect damages due to loss of data or any other reason.

Feedback

If you have any problem, suggestion, comment, or you found a bug in my utility, you can send a message to nirsofer@yahoo.com