KeyboardStateView

KeyboardStateView v1.00
Copyright (c) 2018 Nir Sofer
Web site: http://www.nirsoft.net

Description

KeyboardStateView is a simple tool for Windows that displays the current state and virtual key code of every key you press. It also allows you to view the current state of all keyboard keys.
For every key, the following information is displayed: Key Name (VK_XXXX ), Description, Key Code (Decimal), Key Code (Hexadecimal), Key Pressed Status, Key Toggled Status (Useful for Num Lock, Caps Lock), and last time that the key was pressed.

Start Using KeyboardStateView

KeyboardStateView doesn't require any installation process or additional DLL files. In order to start using it, simply run the executable file - KeyboardStateView.exe
After running KeyboardStateView, every key that you press on your keyboard is displayed on the main window of KeyboardStateView, even when KeyboardStateView is not in focus. If you want to view the state of all keys, simply turn off the 'Show Only Keys Pressed In Last seconds' option (Under the Options menu)

Translating KeyboardStateView to other languages

In order to translate KeyboardStateView to other language, follow the instructions below:
  1. Run KeyboardStateView with /savelangfile parameter:
    KeyboardStateView.exe /savelangfile
    A file named KeyboardStateView_lng.ini will be created in the folder of KeyboardStateView utility.
  2. Open the created language file in Notepad or in any other text editor.
  3. Translate all string entries to the desired language. Optionally, you can also add your name and/or a link to your Web site. (TranslatorName and TranslatorURL values) If you add this information, it'll be used in the 'About' window.
  4. After you finish the translation, Run KeyboardStateView, and all translated strings will be loaded from the language file.
    If you want to run KeyboardStateView without the translation, simply rename the language file, or move it to another folder.

License

This utility is released as freeware. You are allowed to freely distribute this utility via floppy disk, CD-ROM, Internet, or in any other way, as long as you don't charge anything for this and you don't sell it or distribute it as a part of commercial product. If you distribute this utility, you must include all files in the distribution package, without any modification !

Disclaimer

The software is provided "AS IS" without any warranty, either expressed or implied, including, but not limited to, the implied warranties of merchantability and fitness for a particular purpose. The author will not be liable for any special, incidental, consequential or indirect damages due to loss of data or any other reason.

Feedback

If you have any problem, suggestion, comment, or you found a bug in my utility, you can send a message to nirsofer@yahoo.com