HtmlDocEdit

HtmlDocEdit v1.02
Copyright (c) 2008 Nir Sofer
Web site: http://www.nirsoft.net

Description

HtmlDocEdit is a simple HTML designer/editor based on the Internet Explorer browser, that allows you to easily edit HTML files without any knowledge in HTML. with HtmlDocEdit you can change the font/color of selected text, add images, add links, add ordered and unordered lists, and more...

System Requirements

This utility works on Windows 2000, Windows XP, Windows Server 2003, and Windows Vista.

Versions History

  • Version 1.02:
    • Added /open command-line option to open html file from command-line
    • The opened filename is now displayed in the window title.
    • Fixed bug: The main window lost the focus when the user switched to another application and then returned back to HtmlDocEdit.
  • Version 1.01 - Fixed bug: HtmlDocEdit crashed when opening HTML file.
  • Version 1.00 - First release.

Using HtmlDocEdit

HtmlDocEdit doesn't require any installation process or additional DLL files. In order to start using it, simply run the executable file - HtmlDocEdit.exe
After running HtmlDocEdit, you'll get a new and empty HTML document. If you want to edit existing HTML file, you can use the 'Open' command in the File menu.

You can also start HtmlDocEdit with the desired HTML file by using /open command-line option, for example:
HtmlDocEdit.exe /open c:\temp\myfile.html

Translating HtmlDocEdit to other languages

In order to translate HtmlDocEdit to other language, follow the instructions below:
  1. Run HtmlDocEdit with /savelangfile parameter:
    HtmlDocEdit.exe /savelangfile
    A file named HtmlDocEdit_lng.ini will be created in the folder of HtmlDocEdit utility.
  2. Open the created language file in Notepad or in any other text editor.
  3. Translate all string entries to the desired language. Optionally, you can also add your name and/or a link to your Web site. (TranslatorName and TranslatorURL values) If you add this information, it'll be used in the 'About' window.
  4. After you finish the translation, Run HtmlDocEdit, and all translated strings will be loaded from the language file.
    If you want to run HtmlDocEdit without the translation, simply rename the language file, or move it to another folder.

License

This utility is released as freeware. You are allowed to freely distribute this utility via floppy disk, CD-ROM, Internet, or in any other way, as long as you don't charge anything for this. If you distribute this utility, you must include all files in the distribution package, without any modification !

Disclaimer

The software is provided "AS IS" without any warranty, either expressed or implied, including, but not limited to, the implied warranties of merchantability and fitness for a particular purpose. The author will not be liable for any special, incidental, consequential or indirect damages due to loss of data or any other reason.

Feedback

If you have any problem, suggestion, comment, or you found a bug in my utility, you can send a message to nirsofer@yahoo.com