FirmwareTablesView

FirmwareTablesView v1.02
Copyright (c) 2015 - 2022 Nir Sofer
Web site: https://www.nirsoft.net

Description

FirmwareTablesView is a simple tool for Windows that displays a list of firmware tables (ACPI, SMBIOS) stored on your system. You can view the content of these tables in Hex-dump format and export them to a binary file.

System Requirements

This utility works on Windows 11/10/8/7/Vista/2008. On Windows XP, this tool works partially, displaying only a few ACPI tables.

Versions History

  • Version 1.02:
    • Updated to work properly in high DPI mode.
  • Version 1.01:
    • Added 64-bit version.
  • Version 1.00 - First release.

Start Using FirmwareTablesView

FirmwareTablesView doesn't require any installation process or additional dll files. In order to start using it, simply run the executable file - FirmwareTablesView.exe
After running FirmwareTablesView, it lists the firmware tables on your system in the upper pane. When selecting a firmware table in the upper pane, the lower pane displays the content of the selected firmware table in Hex-dump format. You can also export the content of the firmware table into a file by using the 'Export To Binary File' option (Ctrl+E)

Translating FirmwareTablesView to other languages

In order to translate FirmwareTablesView to other language, follow the instructions below:
  1. Run FirmwareTablesView with /savelangfile parameter:
    FirmwareTablesView.exe /savelangfile
    A file named FirmwareTablesView_lng.ini will be created in the folder of FirmwareTablesView utility.
  2. Open the created language file in Notepad or in any other text editor.
  3. Translate all string entries to the desired language. Optionally, you can also add your name and/or a link to your Web site. (TranslatorName and TranslatorURL values) If you add this information, it'll be used in the 'About' window.
  4. After you finish the translation, Run FirmwareTablesView, and all translated strings will be loaded from the language file.
    If you want to run FirmwareTablesView without the translation, simply rename the language file, or move it to another folder.

License

This utility is released as freeware. You are allowed to freely distribute this utility via floppy disk, CD-ROM, Internet, or in any other way, as long as you don't charge anything for this and you don't sell it or distribute it as a part of commercial product. If you distribute this utility, you must include all files in the distribution package, without any modification !

Disclaimer

The software is provided "AS IS" without any warranty, either expressed or implied, including, but not limited to, the implied warranties of merchantability and fitness for a particular purpose. The author will not be liable for any special, incidental, consequential or indirect damages due to loss of data or any other reason.

Feedback

If you have any problem, suggestion, comment, or you found a bug in my utility, you can send a message to nirsofer@yahoo.com