AllThreadsView

AllThreadsView v1.00
Copyright (c) 2018 Nir Sofer
Web site: http://www.nirsoft.net

Description

AllThreadsView is a simple tool for Windows that displays a list of all running threads from all processes on your system in one table. For every thread, the following information is displayed: Thread ID, Creation Time, Kernel Time, User Time, Duration, Start Address, Priority, Base Priority, Context Switch Count, Context Switch Change (Since the last refresh), Wait Reason, Process ID, Process Path.

System Requirements

This tool works on any version of Windows, starting from Windows XP and up to Windows 10. Both 32-bit and 64-bit versions of Windows are supported. On Windows Vista and later, if you want to view the full path of system processes , you have to run AllThreadsView as Administrator.

Start Using AllThreadsView

This utility doesn't require any installation process or additional DLL files. In order to start using it, simply run the executable file - AllThreadsView.exe
After running AllThreadsView, the main window displays the list of all threads running on your system and the list is automatically refreshed. If you want to view only the active threads (Threads with change in the Context Switch Count), simply turn on the 'Show Only Active Threads' option.

Command-Line Options

/stext <Filename> | Save the threads list into a simple text file.
/stab <Filename> | Save the threads list into a tab-delimited text file.
/scomma <Filename> | Save the threads list into a comma-delimited text file (csv).
/shtml <Filename> | Save the threads list into HTML file (Horizontal).
/sverhtml <Filename> | Save the threads list into HTML file (Vertical).
/sxml <Filename> | Save the threads list into XML file.
/sjson <Filename> | Save the threads list into JSON file.

Translating AllThreadsView to other languages

In order to translate AllThreadsView to other language, follow the instructions below:
  1. Run AllThreadsView with /savelangfile parameter:
    AllThreadsView.exe /savelangfile
    A file named AllThreadsView_lng.ini will be created in the folder of AllThreadsView utility.
  2. Open the created language file in Notepad or in any other text editor.
  3. Translate all string entries to the desired language. Optionally, you can also add your name and/or a link to your Web site. (TranslatorName and TranslatorURL values) If you add this information, it'll be used in the 'About' window.
  4. After you finish the translation, Run AllThreadsView, and all translated strings will be loaded from the language file.
    If you want to run AllThreadsView without the translation, simply rename the language file, or move it to another folder.

License

This utility is released as freeware. You are allowed to freely distribute this utility via floppy disk, CD-ROM, Internet, or in any other way, as long as you don't charge anything for this and you don't sell it or distribute it as a part of commercial product. If you distribute this utility, you must include all files in the distribution package, without any modification !

Disclaimer

The software is provided "AS IS" without any warranty, either expressed or implied, including, but not limited to, the implied warranties of merchantability and fitness for a particular purpose. The author will not be liable for any special, incidental, consequential or indirect damages due to loss of data or any other reason.

Feedback

If you have any problem, suggestion, comment, or you found a bug in my utility, you can send a message to nirsofer@yahoo.com