Антивирусный продукт Dr.Web®

Благодарим вас за выбор продуктов компании «Доктор Веб»!

Каждое из антивирусных решений Dr.Web для операционных систем семейства Microsoft® Windows® включает в состав соответствующий набор из следующих компонентов:

Компонент

Продукт

Описание

Сканер Dr.Web®

Любой

Aнтивирусный сканер с графическим интерфейсом, который запускается по запросу пользователя или по расписанию и производит антивирусную проверку компьютера.

Консольные сканеры Dr.Web®

Любой

Версии Сканера Dr.Web с интерфейсом командной строки.

SpIDer Guard®

Любой

Антивирусный сторож, который постоянно находится в оперативной памяти, осуществляя проверку файлов и памяти «на лету», а также обнаруживая проявления вирусной активности.

SpIDer Mail®

Только для рабочих станций, то есть не включается в состав Антивируса Dr.Web для серверов Windows

Почтовый антивирусный сторож для рабочих станций, который перехватывает обращения любых почтовых клиентов, работающих на компьютере, к почтовым серверам, обнаруживает и обезвреживает почтовые вирусы до получения писем почтовым клиентом с сервера или до отправки письма на почтовый сервер.

Для Dr.Web Security Space почтовый сторож также может осуществлять проверку корреспонденции на спам с помощью Антиспама Dr.Web.

Dr.Web для Outlook

Только для рабочих станций, то есть не включается в состав Антивируса Dr.Web для серверов Windows

Подключаемый модуль, который проверяет почтовые ящики Microsoft Outlook на вирусы.

Для Dr.Web Security Space модуль также может осуществлять проверку корреспонденции на спам.

SpIDer Gate™

Только Dr.Web Security Space

Модуль антивирусной проверки HTTP-трафика. При настройках по умолчанию веб-антивирус SpIDer Gate автоматически проверяет входящий HTTP-трафик и блокирует передачу объектов, содержащих вирусы и другие вредоносные программы.

Родительский контроль

Только Dr.Web Security Space

Ограничивает доступ пользователя к ресурсам, содержащимся как локально, на самом компьютере, так и в сети.

Dr. Web® Брандмауэр

Только для рабочих станций, то есть не включается в состав Антивируса Dr.Web для серверов Windows

Персональный межсетевой экран, предназначенный для защиты вашего компьютера от несанкционированного доступа извне и предотвращения утечки важных данных по сети.

Link Checker

Только Dr.Web Security Space

Плагины для веб-браузеров, которые позволяют проверять веб-страницы до открытия и файлы до загрузки из сети Интернет.

Модуль обновления

Любой

Позволяет зарегистрированным пользователям получать обновления вирусных баз и других файлов Dr.Web, а также производит их автоматическую установку; незарегистрированным пользователям дает возможность зарегистрироваться или получить демонстрационный ключ.

SpIDer Agent

Любой

Модуль, с помощью которого осуществляется настройка и управление работой компонентов продукта.


Системные требования

Примечание

Перед установкой Dr.Web следует:

· удалить с компьютера другие антивирусные пакеты для предотвращения возможной несовместимости их резидентных компонентов с резидентными компонентами Dr.Web;
· установить все рекомендуемые компанией Microsoft критические обновления; если поддержка операционной системы производителем прекращена, рекомендуется перейти на более современную версию операционной системы.

В случае установки Брандмауэра необходимо также удалить с компьютера другие межсетевые экраны.

Использование Dr.Web возможно на компьютерах, удовлетворяющем следующим требованиям:

Компонент

Требование

Процессор

Полная поддержка системы команд i686.

Оперативная память

Не менее 512 МБ.

Место на жестком диске

Не менее 380 МБ свободного дискового пространства для установки всех компонентов Dr.Web, из них:

· до 110 МБ занимает установочный файл;
· до 135 МБ занимают временные файлы, которые будут автоматически удалены после завершения установки.

Операционная система

Для Dr.Web Security Space и Антивируса Dr.Web для рабочих станций Windows одна из следующих операционных систем:

· Microsoft® Windows® 2000 Workstation с пакетом обновлений SP4 и Update Rollup 1;
· Windows® XP с пакетом обновлений SP2;
· Windows Vista®;
· Microsoft® Windows® 7.

Для Антивируса Dr.Web для серверов Windows одна из следующих операционных систем:

· Microsoft® Windows® 2000 Server с пакетом обновлений SP4 и Update Rollup 1;
· Microsoft® Windows Server® 2003 с пакетом обновлений SP1;
· Microsoft® Windows Server® 2008.

Все антивирусные продукты Dr.Web поддерживают работу в среде 32- и 64-разрядных операционных систем.

При установке может потребоваться загрузить с сайта Microsoft и установить ряд обновлений системных компонентов. Dr.Web сообщит вам, при необходимости, их наименования и адреса загрузки.

Прочее

Подключение к сети Интернет для обновления вирусных баз Dr.Web и компонентов Dr.Web.

Опущенные требования к конфигурации совпадают с таковыми для соответствующих операционных систем.


Лицензирование

Права пользователя на использование Dr.Web регулируются при помощи специального файла, называемого ключевым файлом.

Для работы Dr.Web вам необходимо получить и установить ключевой файл.

Дополнительную информацию о сроках и типах лицензирования можно найти на официальном сайте «Доктор Веб» по адресу http://www.drweb.com/.


Ключевой файл

Ключевой файл имеет расширение .key и содержит, в частности, следующую информацию:

· перечень компонентов, которые разрешено использовать данному пользователю;
· период, в течение которого разрешено использование антивируса;
· другие ограничения (в частности, количество компьютеров, на которых разрешено использовать антивирус).

Существует три типа ключевых файлов:

· лицензионный ключевой файл, который приобретается вместе с программой Dr.Web и позволяет как пользоваться продуктом, так и получать техническую поддержку. Параметры этого ключевого файла, регулирующие права пользователя, установлены в соответствии с пользовательским договором. В такой файл также заносится информация о пользователе и продавце продукта;
· демонстрационный ключевой файл, который используется для ознакомления с продуктом. Такой ключевой файл обеспечивает полную функциональность основных компонентов, но имеет ограниченный срок действия — 30 дней;

Демонстрационный ключ выдается на одну и ту же машину не чаще, чем 1 раз в 4 месяца.

· временный ключевой файл, который используется в том случае, если при установке вы не указываете лицензионный или демонстрационный ключевой файл. Такой ключевой файл обеспечивает полную функциональность компонентов программы Dr.Web, однако обновления не будут загружаться до тех пор, пока вы не установите лицензионный или демонстрационный ключевой файл.

Ключевой файл Dr.Web является действительным при одновременном выполнении следующих условий:

· срок действия лицензии не истек;
· ключ распространяется на все используемые программой модули;
· целостность ключа не нарушена.

При нарушении любого из условий ключевой файл становится недействительным, при этом Dr.Web перестает обезвреживать вредоносные программы и пропускает почтовые сообщения без проверки.


Получение ключевого файла

Ключевой файл поставляется в виде файла c расширением .key или в виде ZIP-архива, содержащего этот файл.

Вы можете получить ключевой лицензионный файл одним из следующих способов:

· при помощи процедуры регистрации продукта в процессе установки, первого обновления или в любой другой момент;
· при помощи регистрации продукта вручную на официальном сайте «Доктор Веб»;
· вместе с дистрибутивом продукта, если лицензионный файл был включен в комплект поставки;
· на отдельном носителе.

Ключевые файлы, полученные в комплекте дистрибутива, устанавливаются автоматически. Ключевые файлы, полученные другим путем, необходимо установить.

Получение ключевого файла в процессе регистрации на сайте

Примечание

Регистрация на сайте и загрузка ключевого файла осуществляется по сети Интернет.

Для получения лицензионного ключевого файла необходим регистрационный серийный номер продукта. Во время данной процедуры получение демонстрационного файла невозможно.

1. Зайдите на сайт, адрес которого указан в регистрационной карточке, прилагаемой к продукту.
2. Заполните форму со сведениями о покупателе.
3. Введите регистрационный серийный номер (находится на регистрационной карточке).
4. Сформированный ключевой файл высылается по электронной почте в виде ZIP-архива, содержащего файл с расширением .key. Также вы можете загрузить архив со страницы регистрации.
5. После получения ключевого файла, установите его на вашем компьютере.

При получении ключевого файла запрашивается перезагрузка.

Рекомендуется сохранять лицензионный ключевой файл до истечения срока его действия. При переустановке продукта или в случае установки на несколько компьютеров повторная регистрация серийного номера не требуется. Вы можете использовать ключевой файл, полученный при первой регистрации.

Примечание

Демонстрационный ключ может использоваться на только том компьютере, на котором вы проходили регистрацию.

Повторная регистрация

Повторная регистрация может потребоваться в случае утраты ключевого файла. При повторной регистрации необходимо указать те же персональные данные, которые вы ввели при первой регистрации. Допускается использовать другой адрес электронной почты – в таком случае ключевой файл будет выслан по новому адресу.

В случае использования демонстрационного ключа выдаётся тот же ключевой файл, который был выдан ранее.

Количество запросов на получение ключевого файла ограничено – регистрация с одним и тем же серийным номером допускается не более 25 раз. Если это число превышено, ключевой файл не будет выслан. В этом случае обратитесь в службу технической поддержки (в запросе следует подробно описать ситуацию, указать персональные данные, введенные при регистрации, и серийный номер). Ключевой файл будет выслан вам службой технической поддержки по электронной почте.


Продление лицензии

В некоторых случаях, например, при окончании срока действия лицензии или при изменении характеристик защищаемой системы или требований к ее безопасности, вы можете принять решение о приобретении новой или расширенной лицензии на Dr.Web. В таком случае вам потребуется заменить уже существующий и зарегистрированный в системе лицензионный ключевой файл. Dr.Web поддерживает обновление лицензии «на лету», при котором не требуется переустанавливать Dr.Web или прерывать его работу.

Замена ключевого файла

1. Чтобы продлить лицензию, используйте Менеджер лицензий. Для приобретения новой лицензии или продления текущей лицензии вы также можете воспользоваться вашей персональной страничкой на официальном сайте компании «Доктор Веб», которая открывается в окне интернет-браузера по умолчанию при выборе пункта Мой Dr.Web как в Менеджере лицензий, так и в меню SpIDer Agent.
2. Если текущий ключевой файл недействителен, Dr.Web переключится на использование нового ключевого файла.


Проверка антивируса

Вы можете проверить работоспособность антивирусных программ, обнаруживающих вирусы по их сигнатурам, с использованием тестового файла EICAR - European Institute for Computer Anti-Virus Research.

Многими разработчиками антивирусов принято для этой цели использовать одну и ту же стандартную программу test.com. Эта программа была специально разработана для того, чтобы пользователь, не подвергая свой компьютер опасности, мог посмотреть, как установленный антивирус будет сигнализировать об обнаружении вируса. Программа test.com не является сама по себе вредоносной, но специально обрабатывается большинством антивирусных программ как вирус. Антивирусный продукт Dr.Web® называет этот «вирус» следующим образом: EICAR Test File (Not a Virus!). Примерно так его называют и другие антивирусные программы.

Программа test.com представляет собой 68-байтный COM-файл, в результате исполнения которого на консоль выводится текстовое сообщение EICAR-STANDARD-ANTIVIRUS-TEST-FILE!

Файл test.com состоит только из текстовых символов, которые формируют следующую строку:

X5O!P%@AP[4\PZX54(P^)7CC)7}$EICAR-STANDARD-ANTIVIRUS-TEST-FILE!$H+H*

Если вы создадите файл, содержащий приведенную выше строку и сохраните его под именем test.com, то в результате получится программа, которая и будет описанным «вирусом».

SpIDer Guard в оптимальном режиме не определяет тестовый файл EICAR как вредоносную программу, так как он является DOS-приложением, которое не представляет угрозы для компьютера.


Методы обнаружения

Все антивирусы Dr.Web одновременно используют несколько методов обнаружения вредоносных объектов, что позволяет максимально тщательно проверить подозрительные файлы:

1. В первую очередь применяется сигнатурный анализ. Он выполняется путем анализа кода подозрительных файлов на предмет соответствия сигнатурам известных вирусов (сигнатурой называется непрерывная конечная последовательность байт, необходимая и достаточная для опознания вируса). При этом сравнение проводится по контрольным суммам сигнатур, что позволяет значительно снизить размер записей в вирусных базах данных, сохранив при этом однозначность соответствия и, следовательно, корректность обнаружения и лечения зараженных файлов. Вирусные базы Dr.Web составлены таким образом, что благодаря одной записи можно обнаруживать целые классы угроз.
2. После завершения сигнатурного анализа применяется уникальная технология Origins Tracing, которая позволяет определить новые или модифицированные вирусы, использующие известные механизмы заражения файлов. Так, например, эта технология защищает пользователей антивирусных решений Dr.Web от таких вирусов, как вирус-шантажист Trojan.Encoder.18 (также известный под названием gpcode). Кроме того, именно введение Origins Tracing™ позволяет значительно снизить количество ложных срабатываний эвристического анализатора.
3. Работа эвристического анализатора основывается на неких знаниях (эвристиках) о характерных признаках вирусного и, наоборот, безопасного кода. Каждый признак имеет определенный вес (число, показывающее серьезность и достоверность данного признака). На основании суммарного веса, характеризующего каждый конкретный файл, эвристический анализатор вычисляет вероятность заражения файла неизвестным вирусом. Как и любая система проверки гипотез в условиях неопределенности, эвристический анализатор может допускать ошибки как первого (пропуск неизвестных вирусов), так и второго рода (ложная тревога).

Во время любой из проверок компоненты антивирусов Dr.Web используют самую свежую информацию о всех известных вредоносных программах. Сигнатуры вирусов, информация об их признаках и моделях поведения обновляется сразу же, как только специалисты Антивирусной Лаборатории «Доктор Веб» обнаруживают новые угрозы, иногда – до нескольких раз в час. Даже если новейший вирус проникает на компьютер, минуя резидентные средства защиты, после обновления вирусных баз он будет обнаружен в списке процессов и нейтрализован.


Управление и настройка Dr.Web

После установки Dr.Web в область уведомлений Windows добавляется значок модуля управления SpIDer Agent Значок SpIDer Agent :

SpIDer Agent icon

Note

Если SpIDer Agent не запущен, в меню Пуск раскройте группу Dr.Web и выберите пункт SpIDer Agent.

Значок SpIDer Agent отражает текущее состояние Dr.Web:

· SpIDer Agent icon – все компоненты, необходимые для защиты компьютера, запущены и работают правильно;
· SpIDer Agent icon – Самозащита Dr.Web или важный компонент (сторож SpIDer Guard, Брандмауэр) отключены, что ослабляет защиту антивируса и компьютера. Включите Самозащиту или отключенный компонент;
· SpIDer Agent icon – в процессе запуска одного из ключевых компонентов Dr.Web возникла ошибка. Компьютер находится под угрозой заражения. Проверьте наличие действительного ключевого файла и при необходимости установите его.

При наведении курсора мыши на значок появляется всплывающая подсказка с информацией о запущенных компонентах, а также датой последнего обновления антивируса и количеством записей в вирусных базах. Также, в соответствии с настройками, над значком SpIDer Agent Значок SpIDer Agent могут появляться различные подсказки-уведомления.

Меню SpIDer Agent для Dr.Web Security Space Pro

В контекстном меню значка SpIDer Agent Значок SpIDer Agent сосредоточены основные средства управления и настройки Dr.Web.

Пункт меню

Описание

О программе

Открывает окно с информацией о версии Dr.Web.

Зарегистрировать лицензию

Запускает процедуру регистрации пользователя для получения ключевого файла с сервера компании «Доктор Веб».

Мой Dr.Web

Открывает вашу персональную страницу на сайте компании «Доктор Веб». На данной странице вы сможете получить информацию о вашей лицензии (срок действия, серийный номер), продлить срок ее действия, задать вопрос службе поддержки и многое другое.

Справка

Открывает файл справки Dr.Web.

SpIDer Guard, SpIDer Mail, SpIDer Gate, Родительский контроль, Брандмауэр

Открывают доступ к настройкам и управлению соответствующих компонентов Dr.Web.

Набор компонентов определяется видом антивирусного продукта.

Обновление

Открывает окно Модуля обновления, в котором вы можете запустить обновление или настроить параметры работы модуля.

Сканер

Запускает Сканер Dr.Web.

Отключить/Включить Самозащиту

Данный пункт недоступен в пользовательском режиме.

Позволяет отключить/включить защиту файлов, веток реестра и запущенных процессов Dr.Web от повреждений и удаления. По умолчанию режим Самозащиты включен.

Инструменты

Открывает меню, предоставляющее доступ:

· к Менеджеру Лицензий;
· к настройкам самого модуля управления SpIDer Agent;
· к заданию операционной системы Windows, которое определяет периодичность и параметры обновления Dr.Web (пункт Планировщик). Данный пункт недоступен в пользовательском режиме;
· к Карантину Dr.Web;
· к созданию отчета.

Административный/Пользовательский режим

Данный пункт отображается только при отсутствии административных привилегий. Например, при работе в среде операционных систем Microsoft Windows 2000 или Windows XP в пользовательском режиме, или в среде Windows Vista или Microsoft Windows 7 при включенной системе контроля учетных записей UAC. В противном случае данный пункт недоступен и Dr.Web постоянно работает в полнофункциональном режиме.

Позволяет переключаться между полнофункциональным Административным режимом и ограниченным Пользовательским режимом работы с Dr.Web. В Пользовательском режиме действуют следующие ограничения: недоступны настройки компонентов, обновление, Родительский контроль и пункт Планировщик, а также функции отключения сторожа SpIDer Guard, Брандмауэр и самозащиты.

Для переключения в Административный режим необходимы права администратора.

Note

Для отключения некоторых модулей Dr.Web необходимо ввести код подтверждения.

Отключение самозащиты

Примечание

Самозащита помогает предотвратить подмену и случайное повреждение компонентов Dr.Web. Отключать самозащиту не рекомендуется.

Данное действие невозможно в пользовательском режиме.

1. Чтобы отключить защиту файлов Dr.Web, откройте контекстное меню значка SpIDer Agent Значок SpIDer Agent и выберите пункт Отключить Самозащиту.
2. Введите код подтверждения. Пункт Отключить Самозащиту заменится пунктом Включить самозащиту.

Note

В случае возникновения проблем при использовании программ дефрагментации, рекомендуется временно отключить модуль самозащиты.

Возобновление функций самозащиты

Чтобы включить защиту файлов Dr.Web, откройте контекстное меню значка SpIDer Agent Значок SpIDer Agent и выберите пункт Включить Самозащиту. Пункт Включить Самозащиту заменится пунктом Отключить самозащиту.


Менеджер лицензий

В данном окне в доступном виде отображается информация об имеющихся у вас ключевых файлах Dr.Web.

Чтобы открыть это окно, в контекстном меню значка SpIDer Agent Значок SpIDer Agent в области уведомлений Windows выберите пункт Инструменты, а затем пункт Менеджер лицензий.

Чтобы ознакомиться с какой-либо опцией, доступной в этом окне,  щелкните по соответствующему фрагменту окна на рисунке.

Чтобы ознакомиться с какой-либо опцией, доступной в этом окне,
щелкните по соответствующему фрагменту окна на рисунке.

В верхней части окна приводится информация о выбранной лицензии. В группе ниже выделены компоненты Dr.Web, использование которых разрешается лицензией.

Кнопка Получить новую лицензию позволяет вам выбрать способ установки новой лицензии:

· указав путь к файлу на диске;
· через сеть Интернет с помощью процедуры регистрации пользователя.

Кнопка Онлайн-сервис «Мой Dr.Web» открывает вашу персональную страницу на сайте компании «Доктор Веб». На данной странице вы сможете получить информацию о вашей лицензии (срок действия, серийный номер и.т.д), продлить срок ее действия, задать вопрос службе поддержки и многое другое.

Кнопка Удалить текущую лицензию позволяет удалить выбранную в верхней части окна лицензию. Последний используемый ключ не может быть удален.

Для работы Dr.Web требуется установить в защищаемой системе ключевой файл Dr.Web.

Установка полученного ключевого файла

1. Запустите Менеджер лицензий.
2. Нажмите кнопку Получить новую лицензию. В выпадающем списке выберите указав путь к файлу на диске.
3. Укажите путь до ключевого файла. Если вы получили ключевой файл в виде архива, распаковывать его необязательно.
4. Dr.Web запросит перезагрузку компьютера и затем автоматически начнет использовать ключевой файл.

При получении ключевого файла в процессе установки или в комплекте дистрибутива продукта установка ключевого файла производится автоматически и никаких дополнительных действий не требует.

Примечание

При работе программы ключевой файл по умолчанию должен находиться в каталоге установки Dr.Web. Программа регулярно проверяет наличие и корректность ключевого файла. Во избежание порчи ключа, не модифицируйте ключевой файл.

При отсутствии действительного ключевого файла (лицензионного или демонстрационного) активность всех компонентов Dr.Web блокируется. Единственное разрешенное в такой ситуации действие – запуск модуля автоматического обновления с целью регистрации и получения ключевого файла.


Настройка SpIDer Agent

Окно настроек модуля управления SpIDer Agent позволяет задать общие параметры работы Dr.Web.

Общая настройка Dr.Web

1. Щелкните значок SpIDer Agent Значок SpIDer Agent в области уведомлений Windows.
2. В подменю Инструменты выберите пункт Настройки. Откроется окно настроек, содержащее следующие разделы:
· раздел Настройки, в котором задаются общие настройки графического интерфейса и уведомлений Dr.Web;
· раздел Компоненты, в котором задаются параметры запуска компонентов Dr.Web при загрузке операционной системы.
· раздел Расширенные, в котором задаются параметры безопасности.
3. Внесите необходимые изменения. Для получения информации о настройках, расположенных в разделе, нажмите кнопку Справка Справка .
4. По окончании редактирования настроек нажмите кнопку ОК для сохранения внесенных изменений или кнопку Отмена для отказа от них.


Раздел Настройки Dr.Web

В этом разделе задаются настройки графического интерфейса Dr.Web и вывода уведомлений о работе различных компонентов.

Чтобы подробнее ознакомиться с какой-либо настройкой, задаваемой в этом разделе,  щелкните по соответствующему фрагменту окна на рисунке.  Чтобы получить справку о параметрах, задаваемых в каком-либо другом разделе,  щелкните по ссылке на этот раздел на рисунке.

Чтобы подробнее ознакомиться с какой-либо настройкой, задаваемой в этом разделе,
щелкните по соответствующему фрагменту окна на рисунке.
Чтобы получить справку о параметрах, задаваемых в каком-либо другом разделе,
щелкните по ссылке на этот раздел на рисунке.

Вы можете указать язык интерфейса Dr.Web, выбрав необходимый пункт в раскрывающемся списке Выбор языка. Если вы выберете язык, который не был установлен, Dr.Web предложит его установить.

Группы настроек Устаревание вирусных баз и Типы уведомлений позволяют задать типы подсказок-уведомлений, появляющихся в виде всплывающего окна над значком SpIDer Agent Значок SpIDer Agent в области уведомлений Windows. SpIDer Agent выводит уведомления при условиях, указанных в группе Устаревание вирусных баз. Компоненты, перечисленные в группе Типы уведомлений, посылают уведомления в случае срабатывания соответствующей защиты. Также уведомления могут появляться при каждом обновлении вирусных баз и в том случае, если сканирование системы не проводилось более 7 дней (флаг Уведомления о проблемах безопасности).

Настройка | Описание
Выбор языка | Изменить язык интерфейса Dr.Web.
Извещать меня об устаревших базах после | Получать уведомления об устаревании вирусных баз. Укажите период отсутствия обновлений вирусных баз, после которого вы хотите получать уведомления.
Напоминать каждые | Получать уведомления об устаревании вирусных баз периодически. Укажите периодичность, с которой вы хотите получать оповещения об устаревании вирусных баз.
Уведомления об обновлении баз | Получать уведомления об обновлении вирусных баз.
SpIDer Guard | Получать уведомления сторожа SpIDer Guard.
SpIDer Mail | Получать уведомления почтового сторожа SpIDer Mail.
SpIDer Gate | Получать уведомления веб-антивируса SpIDer Gate.
Родительский контроль | Получать уведомления модуля Родительского контроля.
Уведомления о проблемах безопасности | Получать уведомления о давно не проводившемся сканировании системы.
Не показывать уведомления в полноэкранном режиме | Не получать уведомления при работе с приложениями в полноэкранном режиме (просмотр фильмов, графики и т.д.).


Раздел Компоненты

В этом разделе задаются параметры запуска компонентов Dr.Web при загрузке операционной системы.

Чтобы подробнее ознакомиться с какой-либо настройкой, задаваемой в этом разделе,  щелкните по соответствующему фрагменту окна на рисунке.  Чтобы получить справку о параметрах, задаваемых в каком-либо другом разделе,  щелкните по ссылке на этот раздел на рисунке.

Чтобы подробнее ознакомиться с какой-либо настройкой, задаваемой в этом разделе,
щелкните по соответствующему фрагменту окна на рисунке.
Чтобы получить справку о параметрах, задаваемых в каком-либо другом разделе,
щелкните по ссылке на этот раздел на рисунке.

Вы можете выбрать один из следующих вариантов:

· Запускать все установленные компоненты антивируса при загрузке (рекомендуется);
· Выборочный запуск компонентов (не рекомендуется). В этом режиме вы можете отключить автоматический запуск некоторых компонентов.
Настройка | Описание
Запускать все установленные компоненты антивируса при загрузке (рекомендуется) | Выберите, чтобы запускать все компоненты Dr.Web при старте операционной системы.
Выборочный запуск компонет (не рекомендуется) | Выберите, чтобы отключить автоматический запуск некоторых компонетов Dr.Web при старте операционной системы.
SpIDer Mail | Запускать почтовый сторож SpIDer Mail автоматически при старте операционной системы.
SpIDer Gate | Запускать веб-антивирус SpIDer Gate автоматически при старте операционной системы.


Раздел Расширенные

В данном разделе вы можете настроить параметры самозащиты, а также запретить некоторые действия, которые могут привести к заражению вашего компьютера.

Чтобы подробнее ознакомиться с какой-либо настройкой, задаваемой в этом разделе,  щелкните по соответствующему фрагменту окна на рисунке.  Чтобы получить справку о параметрах, задаваемых в каком-либо другом разделе,  щелкните по ссылке на этот раздел на рисунке.

Чтобы подробнее ознакомиться с какой-либо настройкой, задаваемой в этом разделе,
щелкните по соответствующему фрагменту окна на рисунке.
Чтобы получить справку о параметрах, задаваемых в каком-либо другом разделе,
щелкните по ссылке на этот раздел на рисунке.

Предотвращение подозрительных действий

Данная группа настроек позволяет запретить некоторые действия, которые могут привести к заражению вашего компьютера.

Настройка

Описание

Запрещать модификацию системного файла HOSTS

Проверять при проверке компьютера состояние файла HOSTS, который используется операционной системой для упрощения доступа к сети Интернет. Изменения этого файла могут быть результатом работы вируса или другой вредоносной программы.

Запрещать модификацию важных объектов Windows

Защищать от модификации следующие ветки реестра:

· SOFTWARE\Microsoft\Windows NT\CurrentVersion\Image File Execution Options
· SOFTWARE\Microsoft\Windows NT\CurrentVersion\Drivers32
· SOFTWARE\Policies\Microsoft\Windows\Safer
· SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon, Shell
· SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon, UIHost
· SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon, Userinit
· SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon\Notify
· SOFTWARE\Microsoft\Windows NT\CurrentVersion\Windows, AppInit_DLLs
· SOFTWARE\Microsoft\Windows NT\CurrentVersion\Windows, LoadAppInit_DLLs
· SOFTWARE\Classes\exefile
· SOFTWARE\Classes\scrfile
· SOFTWARE\Classes\comfile
· SOFTWARE\Classes\cmdfile
· SOFTWARE\Classes\batfile
· SOFTWARE\Classes\piffile
· SOFTWARE\Classes\lnkfile
· SYSTEM\CurrentControlSet\Control\SafeBoot\Minimal
· SYSTEM\CurrentControlSet\Control\SafeBoot\Network

Запрещать приложениям низкоуровневую запись на жесткий диск

Запрещать приложениям запись на жёсткий диск посекторно, не обращаясь к файловой системе.

Если при установке важных обновлений от Microsoft или при установке и работе программ (в том числе программ дефрагментации) возникают проблемы, отключите соответствующие опции в этой группе настроек.

Параметры самозащиты

Настройка Запрещать эмуляцию действий пользователя позволяет предотвратить любые изменения в работе Dr.Web, производимые автоматизированно. В том числе будет запрещено исполнение скриптов, эмулирующих работу пользователя с программой Dr.Web, запущенных самим пользователем.


Карантин

Это окно содержит данные о содержимом Карантина Dr.Web, который служит для изоляции файлов, подозрительных на наличие вредоносных объектов. Также в Карантин помещаются резервные копии файлов, обработанных Dr.Web.

Каталог Карантина создается отдельно на каждом логическом диске, где были обнаружены подозрительные файлы. При обнаружении зараженных объектов на съемном носителе папка Карантина создается только в том случае, если возможна запись на носитель. Зараженный объект переносится в соответствующую папку Карантина и, если файл находится не на съемном носителе, шифруется. Использование отдельных каталогов и отказ от шифрования на съемных носителях позволяют предотвратить возможную потерю данных.

Чтобы открыть это окно, в контекстном меню значка SpIDer Agent Значок SpIDer Agent в области уведомлений Windows выберите пункт Инструменты, а затем пункт Карантин.

Чтобы ознакомиться с какой-либо опцией, доступной в этом окне,  щелкните по соответствующему фрагменту окна на рисунке.

Чтобы ознакомиться с какой-либо опцией, доступной в этом окне,
щелкните по соответствующему фрагменту окна на рисунке.

Настройка | Описание
Все угрозы | Показать все объекты в Карантине.
Файлы | Нажмите, чтобы показать в списке Карантина только файлы.
Почта | Нажмите, чтобы показать в списке Карантина только письма электронной почты.
Веб-страницы | Нажмите, чтобы показать в списке Карантина только веб-страницы.
Прочее | Нажмите, чтобы показать в списке Карантина объекты иных типов.
 | Нажмите для доступа к настройкам Карантина.
Добавить | Нажмите, чтобы вручную добавить подозрительный объект в Карантин.
Восстановить | Нажмите, чтобы восстановить объект из Карантина в ту папку, откуда он был перемещен. Чтобы восстановить объект в другую папку, в выпадающем меню кнопки выберите вариант Восстановить в и укажите нужную папку.
Пересканировать | Нажмите, чтобы повторно проверить объект. В ряде случаев обновление вирусных баз Dr.Web и программных модулей Dr.Web позволяет обнаруживать ранее неизвестные вирусы и излечивать ранее неизлечимые зараженные файлы.
Удалить | Нажмите, чтобы удалить выбранный объект насовсем.

В центральной части окна отображается таблица с информацией о состоянии карантина, включающая следующие поля:

· Имя – список имен объектов, находящихся в карантине;
· Угроза – классификация вредоносной программы, определяемая Dr.Web при автоматическом перемещении объекта в карантин;
· Путь – полный путь, по которому находился объект до перемещения в карантин.

В нижней части окна карантина отображается подробная информация о выделенных объектах карантина. Вы можете включить отображение столбцов с подробной информацией об объекте, аналогичной данным в нижней части окна.

Настройка отображения столбцов

1. Чтобы задать параметры отображения информации в таблице Карантина, щелкните правой кнопки мыши по заголовку таблицы и выберите пункт Настроить колонки.
2. В открывшемся окне установите флажки напротив тех пунктов, которые вы хотите включить в таблицу объектов. Чтобы исключить столбцы из таблицы объектов, снимите флажки напротив соответствующих пунктов. Также вы можете выполнить одно из следующих действий:
· чтобы установить флажки напротив всех объектов сразу, нажмите кнопку Отметить все;
· чтобы снять все флажки, нажмите кнопку Снять отметки.
3. Для изменения порядка следования столбцов в таблице выберите соответствующий столбец в списке и выполните одно из следующих действий:
· чтобы переместить столбец на одну позицию левее, нажмите кнопку Вверх;
· чтобы переместить столбец на одну позицию правее, нажмите кнопку Вниз.
4. По окончании редактирования настроек нажмите кнопку ОК для сохранения внесенных изменений или кнопку Отмена для отказа от них.

Боковая панель слева служит для фильтрации объектов карантина, которые будут отображены. При нажатии на соответствующую ссылку в центральной части окна будут показаны все объекты карантина или только заданные группы объектов: файлы, почтовые объекты, веб-страницы или все остальные объекты, не попадающие в данные категории.

В окне Карантина файлы могут видеть только те пользователи, которые имеют к ним доступ.

Чтобы отобразить скрытые объекты, запустите под административной учетной записью либо файл dwqrui.exe, расположенный в каталоге установки, либо собственно Dr.Web.

В окне карантина доступны следующие кнопки управления:

· Добавить – добавить файл в карантин. В открывшемся браузере по файловой системе выберите нужный файл;
· Восстановить – переместить файл из карантина и восстановить первоначальное местоположение файла на компьютере (восстановить файл под тем же именем и в папку, в которой он находился до перемещения в карантин). В выпадающем меню вы можете выбрать вариант Восстановить в – переместить файл под заданным именем в папку, указанную администратором;

Примечание

Используйте данную функцию только в том случае, если вы уверены, что объект безопасен.

· Пересканировать – сканировать файл из карантина повторно;
· Удалить – удалить файл из карантина и из системы;
· Отправить файл(ы) в лабораторию «Доктор Веб» – отправить в Антивирусную Лабораторию «Доктор Веб» файл или файлы на проверку.

Для работы одновременно с несколькими файлами выберите необходимые файлы, удерживая клавиши Shift или CTRL, затем щелкните правой кнопкой мыши на любой строчке таблицы и выберите необходимое действие.

Настройка Карантина

1. Чтобы задать параметры работы Карантина, нажмите кнопку Настройки [image] .
2. В открывшемся окне вы можете задать следущие параметры:
· Раздел Задать размер карантина позволяет управлять объемом дискового пространства, занимаемого папкой Карантина. Передвиньте ползунок для изменения максимально допустимого размера Карантина, который определяется в процентном соотношении относительно общего размера диска (при наличии нескольких логических дисков, данный размер будет рассчитан отдельно для каждого диска, на котором располагаются папки Карантина). Значение 100% означает снятие ограничений для максимального размера папки Карантина.
· В разделе Вид установите флаг Показывать резервные копии, чтобы отобразить резервные копии файлов, модифицированных или удаленных Dr.Web (например, в процессе лечения).
3. По окончании редактирования настроек нажмите кнопку ОК для сохранения внесенных изменений или кнопку Отмена для отказа от них.


Создание отчета

При обращении в службу технической поддержки компании «Доктор Веб» вы можете сформировать отчёт о вашей операционной системе и работе Dr.Web. Для настройки параметров, в открывшемся окне нажмите Параметры отчёта. Отчёт будет сохранён в виде архива в каталоге DoctorWeb, расположенном в папке профиля пользователя %USERPROFILE%.

Чтобы ознакомиться с какой-либо опцией, доступной в этом окне,  щелкните по соответствующему фрагменту окна на рисунке.

Чтобы ознакомиться с какой-либо опцией, доступной в этом окне,
щелкните по соответствующему фрагменту окна на рисунке.

Настройка | Описание
Сформировать отчет | Нажмите, чтобы сгенерировать отчет.
Параметры отчета | Нажмите, чтобы настроить параметры отчета.
Заявление о конфиденциальности (на сайте) | Нажмите, чтобы перейти к описанию политики конфиденциальности компании «Доктор Веб» на сайте www.drweb.com.

Отчёт может включать в себя следующее:

1. Техническая информация об ОС:
· общие сведения о компьютере;
· запущенных процессах;
· запланированных заданиях;
· службах, драйверах;
· браузере по умолчанию;
· установлённых приложениях;
· политиках ограничений;
· файле HOSTS;
· о серверах DNS;
· отчет программы MSInfo;
· записи системного журнала событий;
· перечень системных каталогов;
· ветви реестра;
· провайдеры Winsock;
· сетевые соединения;
· отчеты отладчика Dr.Watson;
· индекс производительности.
2. Информация о следующих продуктах Dr.Web:
· Антивирусные решения Dr.Web;
· Dr.Web для IBM Lotus Domino;
· Dr.Web для Kerio MailServer;
· Dr.Web для Kerio WinRoute.

Информация о работе Антивирусных решений Dr.Web находится в Журнале событий операционной системы Windows, в разделе Журналы приложений и служб -> Doctor Web.

Для создания отчёта необходимы права администратора.


Сканер Dr.Web для Windows

Сканер Dr.Web для Windows предназначен для антивирусного сканирования загрузочных секторов, памяти, а также как отдельных файлов, так и объектов в составе сложных структур (архивы, контейнеры, электронные письма с вложениями).

Главное окно Сканера Dr.Web состоит из следующих вкладок:

· вкладка Проверка, на которой формируется задание на сканирование;
· вкладка Статистика, на которой предоставляется доступ к итоговым сведениям о работе сканера.

В случае обнаружения вредоносного объекта Сканер Dr.Web только предупреждает вас об угрозе (исключение составляют программы-шутки, потенциально опасные программы и программы взлома, которые при обнаружении по умолчанию игнорируются). Отчет о результатах сканирования приводится в нижней части вкладки Проверка, где вы можете выбрать необходимое действие для обработки обнаруженного вредоносного или подозрительного объекта.

В окне настройки вы можете изменить параметры работы Сканера Dr.Web.


Антивирусная проверка

По умолчанию сканирование осуществляется с использованием всех методов обнаружения вредоносных объектов, при этом:

· распаковываются и проверяются исполняемые файлы, упакованные специальными упаковщиками;
· проверяются файлы в архивах всех распространенных типов (ACE (до версии 2.0), ALZIP, AR, ARJ, BGA, 7-ZIP, BZIP2, CAB, GZIP, DZ, HA, HKI, LHA, RAR, TAR, ZIP и др.);
· проверяются файлы в составе файловых контейнеров (1C, CHM, MSI, RTF, ISO, CPIO, DEB, RPM и др.);
· проверяются электронные письма (формат писем должен соответствовать стандарту RFC822), хранящиеся в почтовых ящиках программ обработки электронной почты.

Как правило, Сканер Dr.Web только информирует пользователя об обнаружении угроз безопасности (за исключением обнаружения программ-шуток, потенциально опасных программ и программ взлома, которые по умолчанию игнорируются). Информация об обнаруженных заражениях и вредоносных объектах приводится в поле отчета в нижней части главного окна.

Вы можете изменить параметры проведения проверок и реакцию Сканера Dr.Web на обнаружение вредоносных объектов в окне настроек Сканера Dr.Web.

Запуск антивирусной проверки

Примечание

При работе под управлением операционных систем Windows Vista и более поздних Сканер Dr.Web рекомендуется запускать от имени пользователя, обладающего правами администратора. В противном случае те файлы и папки, к которым непривилегированный пользователь не имеет доступа (в том числе, и системные папки), не будут подвергнуты проверке.

1. В контекстном меню значка SpIDer Agent Значок SpIDer Agent выберите пункт Сканер. Откроется главное окно Сканера Dr.Web.

2. Для управления проверкой используйте следующие опции:
· чтобы приступить к сканированию, нажмите кнопку Пуск Пуск в правой части окна;
· чтобы приостановить проверку, нажмите кнопку Пауза Пауза. Чтобы продолжить проверку, повторно нажмите кнопку Пуск Пуск;
· чтобы остановить проверку, нажмите кнопку Стоп Стоп.
3. При необходимости остановите сканирование и выберите другой тип проверки на вкладке Проверка:
· Быстрая проверка;
· Полная проверка;
· Выборочно.
4. Результаты сканирования отражаются в списке в нижней части вкладки Проверка и на вкладке Статистика. Отчет включает следующую информацию:

Колонка

Описание

Объект

Наименование зараженного файла, загрузочного сектора или процесса в памяти.

Если вредоносный или подозрительный объект обнаружен внутри составного объекта (архива, файла электронной почты или файлового контейнера), то в отчете также указывается наименование составного объекта.

Путь

Полный путь к вредоносному объекту (для файлов и загрузочных секторов) или информация о зараженном архиве.

Статус

Наименование вредоносной программы или ее модификации (модификацией известного вируса называется код, полученный таким изменением известного вируса, что при этом он опознается, но алгоритмы лечения исходного вируса к нему неприменимы) по внутренней классификации компании «Доктор Веб». Для подозрительных объектов указывается, что объект «возможно, инфицирован» и указывается тип возможной вредоносной программы по классификации эвристического анализатора.

Действие

Информация о действиях, предпринятых Сканером Dr.Web для деактивации вредоносной программы. Например, лечение, удаление, переименование, перемещение.

При обнаружении зараженного или подозрительного файла, используемого другим приложением Windows, выбранное вами действие не может быть выполнено немедленно. В поле отчета сканера в колонке Действие в этом случае появляется запись Будет излечен после рестарта, Будет удален после рестарта или Будет переименован после рестарта в зависимости от выбранного действия. Соответственно только при последующей перезагрузке нужное действие и будет реально выполнено. Поэтому при обнаружении таких объектов рекомендуется провести перезагрузку системы сразу после окончания сканирования.

Кроме кнопок и пунктов меню для доступа к различным окнам, настройкам и функциям предусмотрены [image] клавиши быстрого доступа.

F1 – вызвать справку

F3 – открыть главное окно Cканера Dr.Web на вкладке Проверка

F4 – открыть главное окно Cканера Dr.Web на вкладке Статистика

F5 – открыть окно задания пути и маска проверки

F7 – запустить быструю проверку (сканирование оперативной памяти и объектов автозапуска)

F8 – запустить процесс обновления

F9 – открыть окно настроек Cканера Dr.Web

F10 – перевести фокус на меню текущего окна

Ctrl+F5 – запустить сканирование

Ctrl+F6 – остановить сканирование

Ctrl+F2 – очистить отчет Cканера Dr.Web

Alt+X – завершить работу Cканера Dr.Web

Если сканирование системы не проводится более 7 дней, выводится уведомление (см. Настройки Dr.Web).

См. также:

· Действия при обнаружении вирусов


Действия над объектами

В случае обнаружения известного вируса или при подозрении на зараженность объекта вирусом Сканер Dr.Web по умолчанию информирует пользователя об этом в специальном поле отчета, расположенном в нижней части вкладки Проверка. Инфицированные процессы, обнаруженные в памяти компьютера, автоматически прекращаются, а обнаруженные троянские программы – удаляются.

Чтобы ознакомиться с какой-либо опцией, доступной в этом окне,  щелкните по соответствующему фрагменту окна на рисунке.

Чтобы ознакомиться с какой-либо опцией, доступной в этом окне,
щелкните по соответствующему фрагменту окна на рисунке.

Настройка | Описание
Быстрая проверка | Режим быстрой проверки.
Полная проверка | Режим полной проверки. Проверке подвергаются все объекты на жестких дисках и сменных носителях
Выборочно | Режим выборочной проверки.
Пуск | Нажмите на эту кнопку, чтобы запустить процесс проверки.
Пауза | Нажмите на эту кнопку, чтобы приостановить процесс проверки.
Стоп | Нажмите на эту кнопку, чтобы остановить процесс проверки.

В поле отчета в табличной форме представлены сведения о найденных в ходе сканирования зараженных и подозрительных объектах, а также о произведенных программой действиях. Если указанные объекты обнаружены в файловых архивах, почтовых файлах или файловых контейнерах, в таблице приводятся как инфицированные объекты, так и содержащие их архивы.

Существуют следующие действия, применяемые к обнаруженным объектам:

Действие

Описание

Вылечить

Восстановить состояние объекта до заражения. Когда вы выбираете это действие, открывается дополнительное контекстное меню, в котором необходимо выбрать реакцию Сканера Dr.Web в случае невозможности лечения конкретного объекта.

Данное действие возможно только при обнаружении объектов, зараженных известным излечимым вирусом, за исключением троянских программ и зараженных файлов внутри составных объектов (архивов, файлов электронной почты или файловых контейнеров).

Это единственное действие, доступное для зараженных загрузочных секторов.

Удалить

Удалить объект. Данное действие неприменимо для загрузочных секторов.

Переименовать

Изменить расширение имени файла объекта в соответствии с настройками Сканера Dr.Web. По умолчанию первый символ расширения заменяется на символ «#». Данное действие неприменимо для загрузочных секторов.

Переместить

Переместить объект в специальный каталог, путь к которому задается настройками Сканера Dr.Web. Данное действие неприменимо для загрузочных секторов.

Выполнение действий по устранению угроз

1. Выберите объект в списке отчета. Чтобы выбрать несколько объектов, удерживайте клавишу Shift или Ctrl. Также вы можете использовать следующие клавиши и комбинации клавиш:
· Insert – выделить объект с перемещением курсора на следующую позицию;
· Ctrl+A – выделить все;
· клавиша умножения (*) на цифровой клавиатуре – выделить все или полностью снять выделение.
2. Выполните одно из следующих действий:
· щелкните правой клавишей мыши по выделенному объекту и выберите действие, которое вы хотите предпринять;
· нажмите на кнопку, соответствующую действию, которое вы хотите предпринять, под полем отчета.

Примечание

Любые действия для отдельных файлов внутри составных объектов (архивов, файлов электронной почты или файловых контейнеров) невозможны. Действие в таких случаях применяется только ко всему объекту целиком. При этом по умолчанию при выборе действия Удалить для составного объекта (архива, файла электронной почты или файлового контейнера) Сканер Dr.Web выдает предупреждение о возможной потере данных.

Кроме кнопок и пунктов меню для доступа к различным окнам, настройкам и функциям предусмотрены [image] клавиши быстрого доступа.

F1 – вызвать справку

F3 – открыть главное окно Cканера Dr.Web на вкладке Проверка

F4 – открыть главное окно Cканера Dr.Web на вкладке Статистика

F5 – открыть окно задания пути и маска проверки

F7 – запустить быструю проверку (сканирование оперативной памяти и объектов автозапуска)

F8 – запустить процесс обновления

F9 – открыть окно настроек Cканера Dr.Web

F10 – перевести фокус на меню текущего окна

Ctrl+F5 – запустить сканирование

Ctrl+F6 – остановить сканирование

Ctrl+F2 – очистить отчет Cканера Dr.Web

Alt+X – завершить работу Cканера Dr.Web


Виды проверки

Сканер Dr.Web поддерживает несколько режимов проверки.

Быстрая проверка

В данном режиме производится сканирование следующих объектов:

· оперативная память;
· загрузочные секторы всех дисков;
· объекты автозапуска;
· корневой каталог загрузочного диска;
· корневой каталог диска установки Windows;
· системный каталог Windows;
· папка Мои Документы;
· временный каталог системы;
· временный каталог пользователя.

Полная проверка

В данном режиме производится полное сканирование оперативной памяти и всех жестких дисков и сменных носителей (включая загрузочные секторы).

Выборочно

Данный режим предоставляет возможность выбрать любые папки и файлы для последующего сканирования.

При выборе данного режима в центральной части вкладки Проверка будет представлена файловая система в виде иерархического дерева. При необходимости его можно развернуть вплоть до каталогов любого уровня и файлов в них.

Выберите в иерархическом списке объекты, которые будут подвергнуты сканированию. Наряду с выбранными объектами будут проверены загрузочные секторы всех дисков.

На рисунке изображена ситуация, в которой в режиме Выборочно выбрана для проверки папка на диске C.

Чтобы ознакомиться с какой-либо опцией, доступной в этом окне,  щелкните по соответствующему фрагменту окна на рисунке.

Чтобы ознакомиться с какой-либо опцией, доступной в этом окне,
щелкните по соответствующему фрагменту окна на рисунке.

По умолчанию наряду с выбранными объектами также будут проверяться подкаталоги всех выбранных каталогов и логических дисков, а также загрузочные секторы всех логических дисков, на которых выбран хотя бы один каталог или файл, а также главные загрузочные секторы соответствующих физических дисков.

При быстром или полном типе проверки Сканер определит, не был ли изменен HOSTS-файл (текстовый файл, который содержит базу данных доменных имен и используется при их трансляции в сетевые адреса узлов). HOSTS-файл может подвергнуться воздействию вредоносных программ (например, с целью перенаправить пользователя на определённый сайт). В том случае, если HOSTS-файл был изменен, Сканер предложит восстановить его исходное состояние. Это позволит устранить несанкционированное изменение файла вредоносным программным обеспечением.

См. также:

· Действия при обнаружении вирусов


Вкладка Проверка

На этой вкладке формируется задание на сканирование объектов операционной системы Windows. По умолчанию сканирование производится с использованием всех методов обнаружения вредоносных объектов.

стоппаузастартВыборочноПолная проверкаБыстрая проверка
Чтобы ознакомиться с какой-либо опцией, доступной в этом окне,  щелкните по соответствующему фрагменту окна на рисунке.

Чтобы ознакомиться с какой-либо опцией, доступной в этом окне,
щелкните по соответствующему фрагменту окна на рисунке.

В центральной части окна в зависимости от выбора режима сканирования отображается список объектов, которые будут подвергнуты проверке, либо иерархический список объектов файловой системы. В нижней части окна располагается таблица для отображения сведений о найденных в ходе сканирования зараженных и подозрительных объектах, а также о произведенных Сканером Dr.Web действиях.

Кроме кнопок и пунктов меню для доступа к различным окнам, настройкам и функциям предусмотрены [image] клавиши быстрого доступа.

F1 – вызвать справку

F3 – открыть главное окно Cканера Dr.Web на вкладке Проверка

F4 – открыть главное окно Cканера Dr.Web на вкладке Статистика

F5 – открыть окно задания пути и маска проверки

F7 – запустить быструю проверку (сканирование оперативной памяти и объектов автозапуска)

F8 – запустить процесс обновления

F9 – открыть окно настроек Cканера Dr.Web

F10 – перевести фокус на меню текущего окна

Ctrl+F5 – запустить сканирование

Ctrl+F6 – остановить сканирование

Ctrl+F2 – очистить отчет Cканера Dr.Web

Alt+X – завершить работу Cканера Dr.Web

См. также:

· Антивирусная проверка
· Виды проверки
· Действия при обнаружении вирусов
· Статистика проверки


Вкладка Статистика

На данной вкладке собраны итоговые сведения о работе Сканера Dr.Web, включая общее количество проверенных объектов, количество обнаруженных объектов, инфицированных известными вирусами, модификациями известных вирусов, количество обнаруженных подозрительных объектов, а также сведения о действиях программы над зараженными и подозрительными объектами.

Чтобы ознакомиться с какой-либо опцией, доступной в этом окне,  щелкните по соответствующему фрагменту окна на рисунке.

Чтобы ознакомиться с какой-либо опцией, доступной в этом окне,
щелкните по соответствующему фрагменту окна на рисунке.

Вы также можете получить эти сведения для любого из логических дисков компьютера. Для этого выберите необходимый диск в раскрывающемся списке, расположенном в верхней части окна.

Для того чтобы обнулить статистические сведения, нажмите кнопку Очистить.

Кроме кнопок и пунктов меню для доступа к различным окнам, настройкам и функциям предусмотрены [image] клавиши быстрого доступа.

F1 – вызвать справку

F3 – открыть главное окно Cканера Dr.Web на вкладке Проверка

F4 – открыть главное окно Cканера Dr.Web на вкладке Статистика

F5 – открыть окно задания пути и маска проверки

F7 – запустить быструю проверку (сканирование оперативной памяти и объектов автозапуска)

F8 – запустить процесс обновления

F9 – открыть окно настроек Cканера Dr.Web

F10 – перевести фокус на меню текущего окна

Ctrl+F5 – запустить сканирование

Ctrl+F6 – остановить сканирование

Ctrl+F2 – очистить отчет Cканера Dr.Web

Alt+X – завершить работу Cканера Dr.Web


Настройка Сканера Dr.Web

Примечание

При работе под управлением операционных систем Windows Vista и более поздних Сканер Dr.Web рекомендуется запускать от имени пользователя, обладающего правами администратора.

Настройки по умолчанию являются оптимальными для большинства применений Сканера Dr.Web, их не следует изменять без необходимости.

Изменение настроек Сканера Dr.Web

1. Если Сканер Dr.Web не запущен, запустите его. Для этого в контекстном меню значка SpIDer Agent Значок SpIDer Agent выберите пункт Сканер. Откроется главное окно Сканера Dr.Web.
2. Выберите в меню главного окна Сканера Dr.Web пункт Настройки, после чего в открывшемся подменю выберите пункт Изменить настройки. Откроется окно настроек, содержащее следующие вкладки:
· вкладка Проверка, на которой задаются списки каталогов и файлов, исключаемых из сканирования;
· вкладка Типы файлов, на которой задаются дополнительные ограничения на состав файлов, подлежащих проверке;
· вкладка Действия, на которой задается реакция Сканера Dr.Web на обнаружение зараженных или подозрительных файлов, вредоносных программ, а также инфицированных архивов;
· вкладка Отчет, задается режим ведения файла отчета Сканера Dr.Web;
· вкладка Общие, на которой задаются параметры взаимодействия Сканера Dr.Web с операционной системой, а также звуковые реакции на различные события.
3. Внесите необходимые изменения. При необходимости нажимайте кнопку Применить перед переходом на другую вкладку.
4. Чтобы получить информацию о настройках, расположенных на вкладке, нажмите кнопку Справка Справка .
5. По окончании редактирования настроек нажмите кнопку ОК для сохранения внесенных изменений или кнопку Отмена для отказа от них.
6. Если на вкладке Общие отменен режим Автосохранение настроек, выберите в меню Настройки пункт Сохранить настройки.


Вкладка Проверка

На этой вкладке задаются списки каталогов и файлов, исключаемых из сканирования. Также на этой вкладке предоставляется возможность использования эвристического анализа (метода, позволяющего выявлять подозрительные объекты, с большой вероятностью зараженные еще неизвестными вирусами). По умолчанию данная настройка включена. Рекомендуется сохранить использование эвристического анализа при сканировании и не менять данную настройку.

Чтобы подробнее ознакомиться с какой-либо настройкой, задаваемой на этой вкладке,  щелкните по соответствующему фрагменту окна на рисунке.  Чтобы получить справку о параметрах, задаваемых на какой-либо другой вкладке,  щелкните по наименованию этой вкладки.

Чтобы подробнее ознакомиться с какой-либо настройкой, задаваемой на этой вкладке,
щелкните по соответствующему фрагменту окна на рисунке.
Чтобы получить справку о параметрах, задаваемых на какой-либо другой вкладке,
щелкните по наименованию этой вкладки.

Элемент интерфейса

Описание

Эвристический анализ

Включение режима эвристического анализа (обнаружение неизвестных вирусов по априорным соображениям об устройстве вирусного кода).

Особенностью этого типа поиска вирусов является приблизительный, вероятностный характер обнаружения заражения, что позволяет говорить не о зараженных, а лишь о подозрительных объектах. Целый класс программ (например, мультисистемные загрузчики ПК) ввиду использования сходного с вирусами кода может вызывать ложные срабатывания эвристического анализатора. Кроме того, данный вид проверки может несколько увеличить время проверки на ПК со слабыми процессорами. Эти обстоятельства могут быть доводами в пользу отмены эвристического анализа. Вместе с тем, сохранение этого типа анализа увеличивает надежность антивирусной защиты. По умолчанию этот режим включен.

Список исключаемых путей

Введите путь к каталогу, который должен быть исключен из проверки и нажмите кнопку Добавить, расположенную справа. Каталог будет добавлен к списку исключенных из проверки каталогов.

Добавить

Введите в поле, расположенном слева, путь к каталогу, который вы хотите добавить в список, и нажмите на кнопку Добавить.

Удалить

Выберите в списке удаляемый объект и нажмите на кнопку Удалить.

Список исключаемых файлов

Введите имя файла, который должен быть исключен из проверки. Нажмите кнопку Добавить, расположенную справа, чтобы добавить этот файл к списку исключенных из проверки файлов.

Вы можете использовать символы «*» и «?» вместо части имени файла. Символ «*» заменяет любую последовательность символов; символ «?» заменят любой, но только один символ

Добавить

Введите имя файла, который вы хотите добавить в список, и нажмите на кнопку Добавить

Удалить

Выберите удаляемый элемент в раскрывающемся списке и нажмите на кнопку Удалить

Список исключаемых путей

Здесь можно задать список каталогов, файлы в которых не будут подвергнуты проверке. В таком качестве могут выступать каталоги карантина антивируса, рабочие каталоги некоторых программ и т.п.

Задание списка исключаемых путей

Чтобы задать список, выполните одно из следующих действий:

· введите путь к каталогу, файлы в котором должны быть исключены из проверки. Вы также можете воспользоваться кнопкой Обзор Обзор и выбрать объект в стандартном окне операционной системы;
· нажмите кнопку Добавить, расположенную справа. Каталог будет добавлен в список, расположенный ниже;
· для того чтобы удалить какой-либо каталог из списка, выберите его в этом списке и нажмите кнопку Удалить. Содержимое каталога будет допущено к последующей проверке.

Список исключаемых файлов

Здесь можно задать список файлов (масок файлов), которые не будут сканироваться. (Из проверки будут исключены все файлы с данным именем.) В таком качестве могут выступать временные файлы (файлы подкачки) и т. п.

Задание списка исключаемых файлов

Чтобы задать список, выполните одно из следующих действий:

· введите имя (маску) файла, который должен быть исключен из проверки. Если вводится имя существующего файла, можно воспользоваться кнопкой Обзор Обзор и выбрать объект в стандартном окне открытия файла. Также вы можете использовать [image] маски;

Маска задает общую часть имени объекта при этом:

· символ «*» заменяет любую, возможно пустую последовательность символов;
· символ «?» заменяет любой, но только один символ;
· остальные символы маски ничего не заменяют и означают, что на этом месте в имени должен находиться именно этот символ.

Примеры:

· отчет*.doc – маска, задающая все документы Microsoft Word, название которых начинается с подстроки «отчет», например, файлы отчет-февраль.doc, отчет121209.doc и т.д.;
· *.exe – маска, задающая все исполняемые файлы c расширением EXE, например, setup.exe, iTunes.exe и т.д.;
· photo????09.jpg – маска, задающая все файлы изображений формата JPG, название которых начинается с подстроки «photo» и заканчивается подстрокой «09», при этом между двумя этими подстроками в названии файла стоит ровно четыре произвольных символа, например, photo121209.jpg, photoмама09.jpg или photo----09.jpg.
· нажмите кнопку Добавить, расположенную справа. Файл (маска файла) будет добавлен в список, расположенный ниже;
· для того чтобы удалить какой-либо объект из списка, выберите его в списке и нажмите кнопку Удалить. Файл будет допущен к последующей проверке.

Примечание

При необходимости исключения из антивирусной проверки определенного файла, внесите полный путь к данному файлу включая его имя в Список исключаемых путей (вы можете воспользоваться кнопкой Обзор Обзор, чтобы выбрать папку, где расположен файл, а затем ввести имя файла вручную).


Вкладка Типы файлов

На этой вкладке задаются дополнительные ограничения на состав файлов, подлежащих сканированию в соответствии с заданием на сканирование.

Чтобы подробнее ознакомиться с какой-либо настройкой, задаваемой на этой вкладке,  щелкните по соответствующему фрагменту окна на рисунке.  Чтобы получить справку о параметрах, задаваемых на какой-либо другой вкладке,  щелкните по наименованию этой вкладки.

Чтобы подробнее ознакомиться с какой-либо настройкой, задаваемой на этой вкладке,
щелкните по соответствующему фрагменту окна на рисунке.
Чтобы получить справку о параметрах, задаваемых на какой-либо другой вкладке,
щелкните по наименованию этой вкладки.

Настройка | Описание
Режим проверки | Выбор способа отбора файлов для проверки. Установите его в требуемое положение (для получения более подробной справки подведите указатель мыши к конкретному положению переключателя и нажмите на левую клавишу мыши).
Все файлы | Осуществлять полную проверку всех файлов, входящих в указанное для проверки множество.
Выбранные типы | Проверять файлы, расширения которых входят в задаваемый пользователем список расширений. В элементах списка расширений могут использоваться специальные символы «*» и «?». Программа хранит список по умолчанию, содержащий основные расширения исполняемых и архивных файлов. Вы можете отредактировать этот список. Для того чтобы добавить новый элемент в список проверяемых, введите его в поле ввода в верхней части поля Список и нажмите на кнопку Добавить. Для того чтобы удалить элемент из списка, выберите его в списке и нажмите на кнопку Удалить. Для того чтобы восстановить список, заданный по умолчанию, нажмите на кнопку Базовый.
Заданные типы | Этот вариант аналогичен варианту Выбранные типы, но позволяет отбирать файлы не только по расширениям, но и по маскам имен файлов.
Добавить | При нажатии на данную кнопку расширение или маска для файлов, введенная в поле слева, добавляется в список.
Удалить | При нажатии на данную кнопку выбранное слева расширение файлов или маска удаляются из списка проверки.
Базовый | Нажмите на эту кнопку, чтобы восстановить состояние списка по умолчанию (при этом список содержит основные расширения исполняемых и архивных файлов).
Файлы в архивах | Распаковывать ли архивы и проверять входящие в них файлы. Это действие требует больших расходов времени, памяти и других ресурсов Windows. Для того чтобы отменить режим проверки файлов в архивах, снимите этот флажок.
Почтовые файлы | Проверять ли файлы почтовых клиентов, хранящих сообщения в текстовом виде. Если вы не пользуетесь такими почтовыми клиентами, снимите этот флажок.

В группе кнопок выбора Режим проверки задается способ отбора проверяемых файлов:

· вариант Все файлы обеспечивает максимальную защиту (выбран по умолчанию);
· варианты Выбранные типы и Заданные маски предписывают проверять только файлы, расширения или имена которых соответственно входят в список, задаваемый в правой части вкладки. По умолчанию список включает расширения основных типов файлов, могущих быть носителями вирусов, и основных типов файловых архивов. Вы можете отредактировать этот список. Чтобы восстановить первоначальный список, нажмите кнопку Базовый.

На этой вкладке задается также режим проверки Файлов в архивах и Почтовых файлов. По умолчанию файловые и почтовые архивы проверяются.


Вкладка Действия

На этой вкладке задается реакция Сканера Dr.Web на обнаружение зараженных или подозрительных файлов, вредоносных программ, а также инфицированных архивов.

Реакция задается отдельно для каждой категории объектов:

· объекты, зараженные известным и (предположительно) излечимым вирусом;
· объекты, зараженные неизлечимым вирусом;
· предположительно зараженные (подозрительные) объекты.

Также отдельно задается реакция для конкретных видов вредоносных программ и типов пакетов (архивы, почтовые файлы, контейнеры).

Чтобы подробнее ознакомиться с какой-либо настройкой, задаваемой на этой вкладке,  щелкните по соответствующему фрагменту окна на рисунке.  Чтобы получить справку о параметрах, задаваемых на какой-либо другой вкладке,  щелкните по наименованию этой вкладки.

Чтобы подробнее ознакомиться с какой-либо настройкой, задаваемой на этой вкладке,
щелкните по соответствующему фрагменту окна на рисунке.
Чтобы получить справку о параметрах, задаваемых на какой-либо другой вкладке,
щелкните по наименованию этой вкладки.

По умолчанию Сканер Dr.Web лишь информирует пользователя в случае обнаружения известного вируса или при подозрении на зараженность объекта вирусом. При этом сведения обо всех зараженных и подозрительных объектах выводятся в поле отчета, в котором вы можете в дальнейшем указать программе необходимые действия вручную.

Вы можете выбрать другие реакции:

Действие

Описание

Вылечить

Восстановить состояние объекта до заражения. Если вирус неизлечим или попытка лечения не была успешной, будет отработана реакция, заданная для неизлечимых вирусов.

Данное действие возможно только для объектов, зараженных известным излечимым вирусом, за исключением троянских программ и зараженных файлов внутри составных объектов (архивов, файлов электронной почты или файловых контейнеров). Троянские программы при обнаружении удаляются.

Это единственное действие, доступное для зараженных загрузочных секторов.

Удалить

Удалить объект.

Для загрузочных секторов никаких действий производиться не будет.

Переименовать

Изменить расширение имени файла объекта в соответствии с маской, задаваемой в поле Переименовать расширение (по умолчанию #??, т. е. заменить первый символ расширения на символ «#»).

Для загрузочных секторов никаких действий производиться не будет.

Переместить

Переместить объект в специальный каталог, задаваемый в поле Путь для перемещения (по умолчанию, подкаталог infected.!!! каталога установки Dr.Web) и доступный и после окончания проверки.

Для загрузочных секторов никаких действий производиться не будет.

Игнорировать

Пропустить объект без выполнения каких-либо действий и не выводить информацию в отчете.

Данное действие возможно только для вредоносных программ: рекламные программы, программы дозвона, программы-шутки, потенциально опасные программы и программы взлома.

При обнаружении инфицированного объекта в архиве применяется реакция, заданная для архивов. Предписанное действие выполняется для всего архива целиком, а не только для инфицированного объекта.


Дополнительные настройки лечения

Для успешного завершения лечения некоторых зараженных (инфицированных) файлов требуется перезагрузка операционной системы Windows. В этом окне задаются дополнительные настройки лечения таких файлов.

Для доступа к этому окну в настройках Сканера Dr.Web выберите вкладку Действия и нажмите кнопку Дополнительно.

Чтобы подробнее ознакомиться с какой-либо настройкой, задаваемой на этой вкладке,  щелкните по соответствующему фрагменту окна на рисунке.

Чтобы подробнее ознакомиться с какой-либо настройкой, задаваемой на этой вкладке,
щелкните по соответствующему фрагменту окна на рисунке.

Вариант Перезагружать систему автоматически, если необходимо предписывает Dr.Web перезагружать операционную систему автоматически, без дополнительного диалога с пользователем.

Примечание

При проведении перезагрузки все несохраненные данные будут утеряны. При выборе пункта Перезагружать систему автоматически перед началом лечения рекомендуется завершить работу всех запущенных приложений (кроме Сканера Dr.Web).

Выбранный по умолчанию вариант Не перезагружать систему автоматически при установленном флажке Предлагать перезагрузку в случае необходимости предписывает Сканеру Dr.Web выдавать запрос на перезагрузку.

Снятие флажка Предлагать перезагрузку в случае необходимости отменяет возможность перезагрузки операционной системы Windows Сканером Dr.Web. В этом случае лечение некоторых инфекций может остаться незавершенным.


Вкладка Отчет

На этой вкладке задается режим ведения файла отчета.

Чтобы подробнее ознакомиться с какой-либо настройкой, задаваемой на этой вкладке,  щелкните по соответствующему фрагменту окна на рисунке.  Чтобы получить справку о параметрах, задаваемых на какой-либо другой вкладке,  щелкните по наименованию этой вкладки.

Чтобы подробнее ознакомиться с какой-либо настройкой, задаваемой на этой вкладке,
щелкните по соответствующему фрагменту окна на рисунке.
Чтобы получить справку о параметрах, задаваемых на какой-либо другой вкладке,
щелкните по наименованию этой вкладки.

Элемент интерфейса

Описание

Вести файл отчета

Вести ли файл отчета

Режим открытия отчета

Будут ли записи отчета добавляться в конец файла отчета или при каждом новом запуске сканера файл отчета будет очищаться

Добавлять – предписывает сканеру добавлять новые записи в конец файла отчета;

Перезаписывать – предписывает очищать файл отчета при каждом новом запуске Сканера Dr.Web.

Ограничить размер файла отчета

В группе Ограничить размер файла отчета определяется, будет ли размер файла отчета ограничен и если да, то каким будет предельный размер файла отчета.

При установленном флажке Предельный размер файла размер файла отчета не превысит размера, указанного в поле КБ. При превышении максимального размера файл отчета очищается, и информация в него начинает записываться с начала

Кодировка

Выбор кодировки файла отчета

ANSI – использовать для отчета кодировку ANSI (Windows);

OEM – использовать для отчета кодировку OEM (DOS).

Детали

Группа флажков позволяет выбрать, какая именно информация заносится в файл отчета. При предписанном ведении отчета в файл всегда (даже если больше ни один флажок не установлен) заносятся сообщения об обнаружении зараженных или подозрительных объектов, в том числе наименования вирусов или их модификаций (для подозрительных – классификация подозрительных кодов, принятая в эвристическом анализаторе), а также о предпринятых действиях

Проверяемые объекты

Заносить имена всех проверенных объектов, причем для незараженных выводится также пометка Ok (этот режим может значительно увеличить файл отчета). Флажок по умолчанию не установлен

Имена упаковщиков

Заносить сообщения об обнаружении исполняемых файлов, упакованных специальными упаковщиками, и имена этих упаковщиков. Флажок по умолчанию не установлен

Имена архиваторов

Заносить сообщения о проверенных архивах и создавших их архиваторах, а также о связанных с ними ошибках (например, архив не удалось разархивировать, т. к. он защищен паролем). Флажок по умолчанию не установлен

Статистика

Если флажок Статистика установлен, выводится статистическая информация о работе программы во время очередного сканирования и всего сеанса работы

По умолчанию режим ведения отчета включен (флажок Вести файл отчета установлен), файл отчета называется drweb32w.log и расположен в каталоге %USERPROFILE%\DoctorWeb (в Windows 7 – C:\Users\<имя_пользователя>\DoctorWeb).

Вы можете настроить наименование и расположение файла отчета, кодировку текста, режим открытия (добавлять ли записи в конец файла отчета или перезаписывать его в начале каждого сеанса), а также степень детальности отчета. Также можно указать, следует ли ограничивать максимальный размер отчета и настроить этот размер.


Вкладка Общие

На этой вкладке задаются параметры взаимодействия программы с операционной системой, а также звуковые реакции программы на различные события.

Чтобы подробнее ознакомиться с какой-либо настройкой, задаваемой на этой вкладке,  щелкните по соответствующему фрагменту окна на рисунке.  Чтобы получить справку о параметрах, задаваемых на какой-либо другой вкладке,  щелкните по наименованию этой вкладки.

Чтобы подробнее ознакомиться с какой-либо настройкой, задаваемой на этой вкладке,
щелкните по соответствующему фрагменту окна на рисунке.
Чтобы получить справку о параметрах, задаваемых на какой-либо другой вкладке,
щелкните по наименованию этой вкладки.

Флажок Автосохранение настроек предписывает программе сохранять измененные настройки при завершении работы Сканера Dr.Web. В противном случае изменения в настройках сохраняются, только если пользователь явно потребовал этого (пункт Сохранить настройки в меню Настройки главного окна Сканера Dr.Web). Данный режим задан по умолчанию.

Флажок Проверять работу от батареи позволяет проверять перед началом сканирования, работает ли ноутбук от батареи. Опция доступна только для портативных компьютеров (ноутбуков).

Бегунок Приоритет проверки позволяет изменить приоритет процесса сканирования в системе.

По умолчанию режим звуковых реакций на вирусные события выключен. Вы можете включить режим «озвучивания» работы или сопоставить событиям звуковые файлы.


Сканирование в режиме командной строки

Вы можете запускать программу Dr.Web Сканер для Windows в режиме командной строки. Такой способ позволяет задать настройки текущего сеанса сканирования и перечень сканируемых объектов в качестве параметров вызова. Именно в таком режиме возможен автоматический вызов Сканера по расписанию.

Синтаксис команды запуска следующий:

[<путь_к_программе>]drweb32w [<объекты>] [<ключи>]

Список объектов сканирования может быть пуст или содержать несколько элементов, разделенных пробелами.

Наиболее распространенные следующие варианты указания объектов сканирования:

· * – сканировать все жесткие диски;
· C: – сканировать диск C:;
· D:\games – сканировать файлы в каталоге;
· C:\games\* – сканировать все файлы и подкаталоги каталога C:\games.

Параметры – ключи командной строки, которые задают настройки программы. При их отсутствии сканирование выполняется с ранее сохраненными настройками (или настройками по умолчанию, если вы не меняли их).

Каждый параметр этого типа начинается с символа /, ключи разделяются пробелами.

Ниже приведено несколько наиболее часто используемых ключей. Полный их список содержится в Приложении A.

· /cu – лечить инфицированные объекты.
· /icm – перемещать неизлечимые файлы (в каталог по умолчанию).
· /icr – переименовывать (по умолчанию).
· /qu – закрыть окно Сканера по окончании сеанса.
· /go – не выдавать никаких запросов.

Последние два параметра особенно полезны при автоматическом запуске Сканера (например, по расписанию).

С такими же параметрами может использоваться Dr.Web Консольный сканер для Windows DrWebWcl. В этом случае вместо drweb32w необходимо набрать имя команды drwebwcl.

Консольный сканер DrWebWcl по умолчанию использует те же настройки, что и GUI-версия Сканера. Параметры, заданные средствами графического интерфейса Сканера (см. п. Настройка параметров программы), используются также при сканировании в режиме командной строки, если иные значения параметров не были заданы в виде ключей.


Консольный сканер

Также в состав компонентов Dr.Web входит Консольный сканер DWScancl. В отличие от Консольного сканера DrWebWcl, он предоставляет пользователю расширенные возможности настройки (большее количество параметров) и рассчитан на многопроцессорные системы.

Файлы, подозрительные на наличие вредоносных объектов, Консольный сканер DWScancl помещает не в каталог infected.!!!, а в Карантин.

Чтобы запустить Консольный сканер DWScancl, воспользуйтесь следующей командой:

[<путь_к_программе>]dwscancl [<ключи>] [<объекты>]

Ключ начинается с символа /, несколько ключей разделяются пробелами. Список объектов сканирования может быть пуст или содержать несколько элементов, разделенных пробелами.

Список ключей Консольного сканера DWScancl содержится в Приложении А.

Коды возврата:

0 – сканирование успешно завершено, инфицированные объекты не найдены

1 – сканирование успешно завершено, найдены инфицированные объекты

10 – указаны некорректные ключи

11 – ключевой файл не найден либо не поддерживает Консольный сканер DWScancl

12 – не запущен Scanning Engine

255 – сканирование прервано пользователем


Сторож SpIDer Guard

Антивирусный сторож SpIDer Guard постоянно находится в оперативной памяти компьютера, осуществляя проверку файлов «на лету», а также обнаруживая проявления вирусной активности.

SpIDer Guard запускается автоматически при каждой загрузке операционной системы, при этом запущенный сторож не может быть выгружен в течение текущего сеанса работы операционной системы. При необходимости (например, в случае выполнения критически чувствительного к загрузке процессора задания в реальном масштабе времени) вы можете временно отключить сканирование файлов «на лету».

При настройках по умолчанию сторож SpIDer Guard «на лету» проверяет все создаваемые или изменяемые файлы и загрузочные сектора, а на сменных носителях – также все открываемые файлы. Сканирование проводится аналогично тому, как работает Сканер Dr.Web, однако с более «мягкими» условиями проверки. Кроме того, сторож SpIDer Guard постоянно отслеживает действия запущенных процессов, характерные для вирусов, и при обнаружении угроз безопасности – блокирует соответствующие процессы.

Файлы внутри архивов и почтовые ящики не проверяются. Если какой-либо файл в архиве или почтовом вложении инфицирован, то вредоносный объект будет обнаружен сторожем при извлечении файла до появления возможности заражения компьютера. Включение проверки архивов или почтовых файлов значительно увеличивает нагрузку на компьютер. Для предотвращения проникновения на ваш компьютер вредоносных объектов, распространяемых посредством электронной почты, используйте почтовый сторож SpIDer Mail.

При обнаружении зараженных объектов сторож SpIDer Guard применяет к ним действия согласно установленным настройкам. Соответствующим изменением настроек вы изменить автоматическую реакцию сторожа на вирусные события. Результаты работы сторожа отражаются в окне статистики и файле отчета.

Возможна несовместимость Dr.Web Антивируса для серверов с MS Exchange Server. В случае возникновения проблем, добавьте базы данных и журнал транзакций MS Exchange Server в список исключений SpIDer Guard.


Управление SpIDer Guard

Основные средства настройки и управления сторожем SpIDer Guard сосредоточены в группе SpIDer Guard контекстного меню SpIDer Agent:

Меню SpIDer Agent для Dr.Web Security Space Pro

Группа SpIDer Guard включает следующие пункты:

Пункт меню | Описание
Статистика | Открывает окно, содержащее сведения о работе сторожа в течение текущего сеанса (количество проверенных, зараженных и подозрительных объектов, предпринятые действия и др.).
Настройки | Данный пункт недоступен в пользовательском режиме. Предоставляет доступ к основной части настраиваемых параметров сторожа SpIDer Guard.
Отключить/Включить | Данный пункт недоступен в пользовательском режиме. Позволяет временно отключить сканирование файлов в режиме реального времени с помощью сторожа SpIDer Guard. Пункт Включить появляется в меню в том случае, когда сканирование файлов было приостановлено.

Временное отключение сторожа

Вы можете временно отключать антивирусную проверку, выполняемую сторожем SpIDer Guard. При этом снимается блокировка файлов, установленная сторожем в соответствии с настройками реакций на вирусные события.

Примечание

Данное действие невозможно в пользовательском режиме.

Прибегайте к этой возможности с исключительной осторожностью! В период отключения функций сторожа не следует подключаться к сети Интернет, а также считывать файлы с носителей, не проверенных Сканером Dr.Web.

Отключение функций сторожа

1. Откройте контекстное меню значка SpIDer Agent Значок SpIDer Agent .
2. В подменю SpIDer Guard выберите пункт Отключить.

При отключении SpIDer Guard запрашивается код подтверждения.

Восстановление функций сторожа

1. Откройте контекстное меню значка SpIDer Agent Значок SpIDer Agent .
2. В подменю SpIDer Guard выберите пункт Включить.


Настройка SpIDer Guard

Примечание

Настройки сторожа SpIDer Guard недоступны в пользовательском режиме.

Основные средства настройки и управления сторожем SpIDer Guard сосредоточены в группе SpIDer Guard контекстного меню SpIDer Agent. Настройки программы по умолчанию являются оптимальными для большинства применений, их не следует изменять без необходимости.

Настройка сторожа

1. Откройте контекстное меню значка SpIDer Agent Значок SpIDer Agent .
2. В подменю SpIDer Guard выберите пункт Настройки. Откроется окно настроек, содержащее следующие разделы:
· раздел Проверка, в котором задается режим проверки файлов и процессов защищаемого компьютера;
· раздел Исключения, в котором задается список каталогов и файлов, исключаемых из проверки сторожем SpIDer Guard;
· раздел Действия, в котором задается реакция сторожа SpIDer Guard на обнаружение зараженных или подозрительных файлов и вредоносных программ;
· раздел Отчет, в котором задается режим ведения файла отчета сторожа SpIDer Guard.
3. Внесите необходимые изменения. Для получения информации о настройках, расположенных в разделе, нажмите кнопку Справка Справка .
4. По окончании редактирования настроек нажмите кнопку ОК для сохранения внесенных изменений или кнопку Отмена для отказа от них.


Раздел Проверка

В этом разделе задается режим проверки файлов и процессов защищаемого компьютера.

Чтобы подробнее ознакомиться с какой-либо настройкой, задаваемой в этом разделе,  щелкните по соответствующему фрагменту окна на рисунке.  Чтобы получить справку о параметрах, задаваемых в каком-либо другом разделе,  щелкните по ссылке на этот раздел на рисунке.

Чтобы подробнее ознакомиться с какой-либо настройкой, задаваемой в этом разделе,
щелкните по соответствующему фрагменту окна на рисунке.
Чтобы получить справку о параметрах, задаваемых в каком-либо другом разделе,
щелкните по ссылке на этот раздел на рисунке.

Режим проверки

В данной группе настроек задается, при каких действиях с объектом должна производиться его проверка сторожем SpIDer Guard.

Настройка

Описание

Оптимальный (рекомендуется)

Используется по умолчанию.

В данном режиме сканирование производится только в следующих случаях:

· для объектов на жестких дисках – при запуске или создании файлов, а также попытке записи в существующие файлы или загрузочные сектора;
· для объектов на сменных носителях – при любом обращении к файлам или загрузочным секторам (чтение, запись, запуск).

Параноидальный

В данном режиме при любом обращении (создание, чтение, запись, запуск) производится проверка всех файлов и загрузочных секторов на жестких и сетевых дисках, а также сменных носителях.

Использовать эвристический анализ

Установите этот флажок, чтобы использовать при проверке эвристический анализатор.

Снимите этот флажок, чтобы проводить проверку только по сигнатурам известных вирусов.

Подробнее об эвристическом анализаторе см. Методы обнаружения вирусов.

В оптимальном режиме SpIDer Guard не определяет DOS-приложения (например, тестовый файл EICAR) как вредоносную программу, так как они не представляют угрозы для компьютера.

Уточнения и рекомендации

Режим Оптимальный рекомендуется использовать после тщательной проверки всех жестких дисков при помощи Сканера Dr.Web. При этом будет исключено проникновение на компьютер новых вирусов или других вредоносных программ через сменные устройства, но при этом не будет проводиться повторной проверки уже проверенных, «чистых», объектов.

Установка режима Параноидальный обеспечивает максимальный уровень защиты, но значительно увеличивает нагрузку на компьютер.

В любом из режимов проверка объектов на сетевых дисках или съемных носителях производится только при установке соответствующих флажков в группе настроек Дополнительные возможности.

Реакция сторожа SpIDer Guard на обнаружение вредоносных объектов задается в разделе Действия.

Примечание

Некоторые внешние накопители (в частности, мобильные жесткие диски с интерфейсом USB) могут представляться в системе как жесткие диски. Поэтому такие устройства следует использовать с особой осторожностью и проверять на вирусы при подключении к компьютеру с помощью Сканера Dr.Web.

Файлы внутри архивов и почтовые ящики по умолчанию не проверяются. Отказ от проверки архивов и электронной почты в условиях постоянной работы сторожа SpIDer Guard не ведет к проникновению вирусов на компьютер, а лишь откладывает момент их обнаружения. При распаковке зараженного архива или открытии зараженного письма операционная система производит попытку записать инфицированный объект на диск, при этом сторож SpIDer Guard неминуемо обнаруживает вредоносный объект.

Дополнительные возможности

Данная группа настроек позволяет задать параметры проверки «на лету», которые будут применяться вне зависимости от выбранного режима работы сторожа SpIDer Guard. Также вы можете запретить автоматический запуск активного содержимого внешних носителей данных (CD/DVD дисков, флэш-памяти и т.д.), установив флажок Блокировать автозапуск со сменных носителей. Использование этой настройки помогает предотвратить заражение вашего компьютера через внешние носители.

Здесь вы можете задать проверку:

· файлов запускаемых процессов вне зависимости от их расположения;
· установочных файлов;
· файлов на сетевых дисках;
· файлов и загрузочных секторов на съемных носителях.

В случае возникновения проблем при установке программ, обращающихся к файлу autorun.inf, рекомендуется временно снять флажок Блокировать автозапуск со сменных носителей.

Элемент интерфейса

Описание

Оптимальный (рекомендуется)

На постоянно установленных дисках (разделах жестких дисков ПК) проверять только создаваемые или изменяемые файлы, на сменных дисках (дискетах, компакт-дисках) и сетевых дисках проверять все открываемые файлы, а также проверять файлы запускаемых процессов. Таким образом, файлы на постоянных дисках проверяются однократно в момент их создания (или изменения).

Параноидальный

Использовать другие настройки проверки «на лету», отличные от режима Оптимальный.

Использовать эвристический анализ (рекомендуется)

Использовать ли эвристический анализ.

Проверять работающие программы и модули

Проверять файлы программ, работающих в данный период времени.

Проверять инсталляционные пакеты

Проверять установочные файлы программ.

Проверять объекты в локальной сети (не рекомендуется)

Установите этот флаг, чтобы проверять объекты на сетевых дисках при их открытии и запуске на исполнение на вашем компьютере.

Если флаг снят, то сканирование файлов на сетевых дисках будет производиться только при запуске этих файлов на исполнение на вашем компьютере.

Проверять объекты на съемных носителях

Установите этот флаг, чтобы сканировать файлы на сменных носителях информации (CD/DVD диски, магнитные диски (FDD), flash-накопители и прочие носители информации, подключаемые через USB-порт и т.п.) при любом обращении к ним, в том числе при открытии файлов с правами только на чтение.

Если флаг снят, то сканирование файлов на сменных носителях будет производиться только при запуске этих файлов на исполнение.

Блокировать автозапуск со сменных носителей

Запрещать автоматический запуск активного содержимого внешних носителей данных (CD/DVD дисков, флэш-памяти и т.д.). Использование этой настройки помогает предотвратить заражение вашего компьютера через внешние носители.

См. также:

· Методы обнаружения вирусов


Раздел Исключения

В этом разделе задается список каталогов и файлов, исключаемых из проверки.

В поле Список исключаемых путей и файлов приводится список каталогов и файлов, которые не проверяются сторожем SpIDer Guard. В таком качестве могут выступать каталоги карантина антивируса, рабочие каталоги некоторых программ, временные файлы (файлы подкачки) и т. п.

Чтобы подробнее ознакомиться с какой-либо настройкой, задаваемой в этом разделе,  щелкните по соответствующему фрагменту окна на рисунке.  Чтобы получить справку о параметрах, задаваемых в каком-либо другом разделе,  щелкните по ссылке на этот раздел на рисунке.

Чтобы подробнее ознакомиться с какой-либо настройкой, задаваемой в этом разделе,
щелкните по соответствующему фрагменту окна на рисунке.
Чтобы получить справку о параметрах, задаваемых в каком-либо другом разделе,
щелкните по ссылке на этот раздел на рисунке.

По умолчанию список пуст. Вы можете добавить к исключениям конкретные каталоги и файлы или использовать маски, чтобы запретить проверку определенной группы файлов.

Формирование списка исключений

1. Чтобы добавить каталог или файл к списку исключений, выполните одно из следующих действий:
· чтобы указать конкретный существующий каталог или файл, нажмите кнопку Обзор и выберите каталог или файл в стандартном окне открытия файла. Вы также можете вручную ввести полный путь к файлу или каталогу в поле ввода;
· чтобы исключить из проверки все файлы или каталоги с определенным именем, введите это имя в поле ввода. Указывать путь к каталогу или файлу при этом не требуется;
· чтобы исключить из проверки файлы или каталоги определенного вида, введите определяющую их маску в поле ввода. Подробнее о масках.

Маска задает общую часть имени объекта при этом:

· символ «*» заменяет любую, возможно пустую последовательность символов;
· символ «?» заменяет любой, но только один символ;
· остальные символы маски ничего не заменяют и означают, что на этом месте в имени должен находиться именно этот символ.

Примеры:

· отчет*.doc – маска, задающая все документы Microsoft Word, название которых начинается с подстроки «отчет», например, файлы отчет-февраль.doc, отчет121209.doc и т.д.;
· *.exe – маска, задающая все исполняемые файлы c расширением EXE, например, setup.exe, iTunes.exe и т.д.;
· photo????09.jpg – маска, задающая все файлы изображений формата JPG, название которых начинается с подстроки «photo» и заканчивается подстрокой «09», при этом между двумя этими подстроками в названии файла стоит ровно четыре произвольных символа, например, photo121209.jpg, photoмама09.jpg или photo----09.jpg.
2. Нажмите кнопку Добавить.
3. При необходимости повторите шаги 1 и 2 для добавления других файлов или каталогов. Чтобы удалить файл или каталог из списка исключений, выберите соответствующий элемент в списке и нажмите кнопку Удалить.

Примеры задания исключений:

· C:\folder или C:\folder\** – исключает из проверки все файлы в каталоге C:\folder. В подкаталогах файлы будут проверяться.
· C:\folder\* – исключает из проверки все файлы в каталоге C:\folder и всех подкаталогах на любом уровне.
· C:\folder\*.txt – исключает из проверки файлы *.txt в каталоге C:\folder. В подкаталогах файлы *.txt будут проверяться.
· C:\folder\*\*.txt – исключает из проверки файлы *.txt только в подкаталогах первого уровня каталога C:\folder.
· C:\folder\**\*.txt – исключает из проверки файлы *.txt в подкаталогах любого уровня каталога C:\folder. В самом каталоге C:\folder файлы *.txt будут проверяться.


Раздел Действия

В этом разделе задается реакция сторожа SpIDer Guard на обнаружение зараженных или подозрительных файлов и вредоносных программ.

Реакция задается отдельно для каждой категории объектов:

· Инфицированные файлы, зараженные известным и (предположительно) излечимым вирусом;
· Неизлечимые объекты, зараженные неизлечимым вирусом;
· Подозрительные файлы, предположительно зараженные вирусом или содержащие вредоносный объект;
· различные потенциально опасные объекты.

Вы можете изменить реакцию сторожа SpIDer Guard на обнаружение каждого типа объектов в отдельности. Состав доступных реакций при этом зависит от типа вирусного события.

Чтобы подробнее ознакомиться с какой-либо настройкой, задаваемой в этом разделе,  щелкните по соответствующему фрагменту окна на рисунке.  Чтобы получить справку о параметрах, задаваемых в каком-либо другом разделе,  щелкните по ссылке на этот раздел на рисунке.

Чтобы подробнее ознакомиться с какой-либо настройкой, задаваемой в этом разделе,
щелкните по соответствующему фрагменту окна на рисунке.
Чтобы получить справку о параметрах, задаваемых в каком-либо другом разделе,
щелкните по ссылке на этот раздел на рисунке.

По умолчанию сторож SpIDer Guard пытается вылечить файлы, зараженные известным и потенциально излечимым вирусом, остальные наиболее опасные объекты – перемещает в Карантин. Программы-шутки, программы взлома и неблагонадежные объекты по умолчанию игнорируются. Реакции сторожа SpIDer Guard аналогичны соответствующим реакциям Сканера Dr.Web.

Подробнее о реакциях

Существуют следующие действия, применяемые к обнаруженным объектам:

Действие

Описание

Лечить

Восстановить состояние объекта до заражения. Если вирус неизлечим или попытка лечения не была успешной, будет отработана реакция, заданная для неизлечимых вирусов.

Данное действие возможно только для объектов, зараженных известным излечимым вирусом, за исключением троянских программ и зараженных файлов внутри составных объектов (архивов, файлов электронной почты или файловых контейнеров).

Это единственное действие, доступное для зараженных загрузочных секторов.

Удалить

Удалить объект.

Для загрузочных секторов никаких действий производиться не будет.

Перемещать в карантин

Переместить объект в специальный каталог Карантина.

Для загрузочных секторов никаких действий производиться не будет.

Игнорировать

Пропустить объект без выполнения каких-либо действий и не выводить оповещения.

Данное действие возможно только для вредоносных программ: рекламные программы, программы дозвона, программы-шутки, потенциально опасные программы и программы взлома.

Примечание

Сторож SpIDer Guard не проверяет составные объекты (архивы, файлы электронной почты или файловые контейнеры), поэтому никакие действия над ними или входящими в их состав файлами не производятся.

Резервные копии обработанных объектов сохраняются в Карантинe.

После выполнения предписанного действия сторож SpIDer Guard по умолчанию выводит соответствующее оповещение в область уведомлений Windows. Вы можете запретить или разрешить вывод уведомлений.

Настройка уведомлений сторожа SpIDer Guard

1. Откройте контекстное меню значка SpIDer Agent Значок SpIDer Agent .
2. В подменю Инструменты выберите пункт Настройки. Откроется окно настроек Dr.Web.
3. Выполните одно из следующих действий:
· чтобы запретить вывод уведомлений сторожа SpIDer Guard, в группе Типы уведомлений снимите флажок SpIDer Guard;
· чтобы разрешить вывод уведомлений сторожа SpIDer Guard, в группе Типы уведомлений установите флажок SpIDer Guard.
4. По окончании редактирования настроек нажмите кнопку ОК для сохранения внесенных изменений или кнопку Отмена для отказа от них.


Раздел Отчет

В этом разделе задается режим ведения файла отчета.

Отчет сторожа SpIDer Guard хранится в файле spiderg3.log, расположенном в каталоге установки Dr.Web. Рекомендуется периодически анализировать файл отчета.

Чтобы получить справку о параметрах, задаваемых в каком-либо другом разделе,  щелкните по ссылке на этот раздел на рисунке.

Чтобы получить справку о параметрах, задаваемых в каком-либо другом разделе,
щелкните по ссылке на этот раздел на рисунке.

Вы можете задать одну из следующих степеней детальности ведения отчета:

· Стандартный – в данном режиме в отчете фиксируются только наиболее значимые события, такие как проведение обновлений, запуск и останов сторожа SpIDer Guard и вирусные события. Данный режим ведения отчета походит для большинства применений;
· Расширенный – в данном режиме в отчете помимо общих событий фиксируются данные о проверяемых файлах, именах упаковщиков и содержимом проверяемых составных объектов (архивов, файлов электронной почты или файловых контейнеров). Рекомендуется использовать этот режим для определения объектов, которые сторож SpIDer Guard проверяет наиболее часто. При необходимости вы можете добавить такие объекты в список исключений, что может снизить нагрузку на компьютер;
· Отладочный – в данном режиме в отчете фиксируется максимальное количество информации о работе сторожа SpIDer Guard, что может привести к значительному увеличению файла отчета. Рекомендуется использовать этот режим только при возникновении проблем в работе сторожа SpIDer Guard или по просьбе технической поддержки компании «Доктор Веб».


Статистика

В данном окне отображаются результаты работы сторожа SpIDer Guard в течение текущего сеанса.

Для доступа к этому окну откройте контекстное меню значка SpIDer Agent Значок SpIDer Agent и в подменю SpIDer Guard выберите пункт Статистика.

Чтобы ознакомиться с какой-либо опцией, доступной в этом окне,  щелкните по соответствующему фрагменту окна на рисунке.

Чтобы ознакомиться с какой-либо опцией, доступной в этом окне,
щелкните по соответствующему фрагменту окна на рисунке.


Почтовый сторож SpIDer Mail

Примечание

Данный компонент не включается в состав Антивируса Dr.Web для серверов Windows.

Почтовый сторож SpIDer Mail по умолчанию включается в состав устанавливаемых компонентов, постоянно находится в памяти и автоматически запускается при загрузке операционной системы. При необходимости вы можете изменить режим запуска почтового сторожа при загрузке операционной системы. Для продуктов семейства Dr.Web Security Space почтовый сторож также может осуществлять проверку корреспонденции на спам с помощью Антиспама Dr.Web.

По умолчанию почтовый сторож SpIDer Mail автоматически перехватывает все обращения к почтовым серверам, выполняемые по стандартным для протоколов портам любыми почтовыми программами вашего компьютера. Стандартными являются следующие порты:

· для протокола POP3 - порт 110;
· для протокола SMTP - порт 25;
· для протокола IMAP4 - порт 143;
· для протокола NNTP - порт 119.

В ряде случаев автоматический перехват POP3-, SMTP-, IMAP4- и NNTP-соединений невозможен. В таком случае вы можете настроить перехват соединений вручную.

Обработка писем

Почтовый сторож SpIDer Mail получает все входящие письма вместо почтового клиента и подвергает их антивирусному сканированию с максимальной степенью подробности. При отсутствии вирусов или подозрительных объектов оно передается почтовой программе «прозрачным» образом – так, как если бы оно поступило непосредственно с сервера. Аналогично исходящие письма проверяются до отправки на сервер.

Реакция почтового сторожа SpIDer Mail на обнаружение инфицированных и подозрительных входящих писем, а также писем, не прошедших проверки (например, писем с чрезмерно сложной структурой), по умолчанию следующая:

· из зараженных писем удаляется вредоносная информация (это действие называется лечением письма), затем они доставляются обычным образом;
· письма с подозрительными объектами перемещаются в виде отдельных файлов в Карантин, почтовой программе посылается сообщение об этом (это действие называется перемещением письма). Перемещенные письма удаляются с POP3- или IMAP4-сервера;
· незараженные письма и письма, не прошедшие проверки, передаются без изменений (пропускаются).

Инфицированные или подозрительные исходящие письма не передаются на сервер, пользователь извещается об отказе в отправке сообщения (как правило, почтовая программа при этом сохраняет письмо).

При наличии на компьютере неизвестного вируса, распространяющегося через электронную почту, почтовый сторож SpIDer Mail может определять признаки типичного для таких вирусов «поведения» (массовые рассылки). По умолчанию эта возможность включена.

Почтовый сторож SpIDer Mail предоставляет возможность проверки входящих писем на спам с помощью Антиспама Dr.Web. По умолчанию эта возможность включена.

Примечание

Функция проверки писем на спам доступна только для продуктов семейства Dr.Web Security Space.

Настройки SpIDer Mail по умолчанию являются оптимальными для начинающего пользователя, обеспечивая максимальный уровень защиты при наименьшем вмешательстве пользователя. При этом, однако, блокируется ряд возможностей почтовых программ (например, направление письма по многим адресам может быть воспринято как массовая рассылка, полученный спам не распознается), а также утрачивается возможность получения полезной информации из автоматически уничтоженных писем (из незараженной текстовой части). Более опытные пользователи могут изменить параметры проверки почты и настройки реакции почтового сторожа SpIDer Mail на различные события.

Проверка писем другими средствами

Сканер Dr.Web также может обнаруживать вирусы в почтовых ящиках некоторых форматов, однако почтовый сторож SpIDer Mail имеет перед ним ряд преимуществ:

· далеко не все форматы почтовых ящиков популярных программ поддерживаются Сканером Dr.Web; при использовании почтового сторожа SpIDer Mail зараженные письма даже не попадают в почтовые ящики;
· Cканер Dr.Web проверяет почтовые ящики, но только по запросу пользователя или по расписанию, а не в момент получения почты, причем данное действие является трудоемким и занимает значительное время.

Таким образом, при настройках всех компонентов Dr.Web по умолчанию почтовый сторож SpIDer Mail первым обнаруживает и не допускает на компьютер вирусы и подозрительные объекты, распространяющиеся по электронной почте. Его работа является весьма экономичной с точки зрения расхода вычислительных ресурсов; остальные компоненты могут не использоваться для проверки почтовых файлов.

Антиспам Dr.Web

Технологии антиспам-фильтра Dr.Web состоят из нескольких тысяч правил, которые условно можно разбить на несколько групп:

· эвристический анализ – чрезвычайно сложная, высокоинтеллектуальная технология эмпирического разбора всех частей письма: поля заголовка, тела, содержания вложения;
· фильтрация противодействия – состоит в распознавании уловок, используемых спамерами для обхода антиспам-фильтров;
· анализ на основе HTML-сигнатур – сообщения, в состав которых входит HTML-код, сравниваются с образцами библиотеки HTML-сигнатур антиспама;
· семантический анализ – сравнение слов и выражений сообщения со словами и идиомами, типичными для спама, производится по специальному словарю. Анализу подвергаются как видимые, так и визуально скрытые специальными техническими уловками слова, выражения и символы;
· анти-скамминг технология – к числу скамминг- и фарминг-сообщений относятся т.н. «нигерийские письма», сообщения о выигрышах в лотерею, казино, поддельные письма банков. Для их фильтрации применяется специальный модуль;
· фильтрация технического спама – так называемые bounce-сообщения возникают как реакция на вирусы, или как проявление вирусной активности. Специальный модуль антиспама определяет такие сообщения как нежелательные.


Управление SpIDer Mail

Основные средства настройки и управления почтовым сторожем SpIDer Mail сосредоточены в группе SpIDer Mail контекстного меню SpIDer Agent:

Меню SpIDer Agent для Dr.Web Security Space Pro

Группа SpIDer Mail включает следующие пункты:

Пункт меню | Описание
Статистика | Открывает окно, содержащее сведения о работе почтового сторожа в течение текущего сеанса (количество проверенных, зараженных и подозрительных писем, предпринятые действия и др.).
Настройки | Данный пункт недоступен в пользовательском режиме. Предоставляет доступ к основной части настраиваемых параметров почтового сторожа SpIDer Mail.
Отключить/Включить | Позволяет временно отключить сканирование сообщений электронной почты с помощью почтового сторожа SpIDer Mail. Пункт Включить появляется в меню в том случае, когда сканирование почты было приостановлено.

Временное отключение почтового сторожа

Вы можете временно отключать проверку входящих и исходящих писем электронной почты на вирусы и спам, выполняемую почтовым сторожем SpIDer Mail.

Отключение функций почтового сторожа

1. Откройте контекстное меню значка SpIDer Agent Значок SpIDer Agent .
2. В подменю SpIDer Mail выберите пункт Отключить.

Восстановление функций почтового сторожа

1. Откройте контекстное меню значка SpIDer Agent Значок SpIDer Agent .
2. В подменю SpIDer Mail выберите пункт Включить.


Настройка SpIDer Mail

Примечание

Настройки почтового сторожа SpIDer Mail недоступны в пользовательском режиме.

Основные средства настройки и управления почтовым сторожем SpIDer Mail сосредоточены в группе SpIDer Mail контекстного меню SpIDer Agent. Настройки программы по умолчанию являются оптимальными для большинства применений, их не следует изменять без необходимости.

Настройка почтового сторожа

1. Откройте контекстное меню значка SpIDer Agent Значок SpIDer Agent .
2. В подменю SpIDer Mail выберите пункт Настройки. Откроется окно настроек, содержащее следующие разделы (слева):
· раздел Проверка, в котором задается режим проверки электронной почты;
· раздел Антиспам, в котором задается режим проверки электронной почты на спам с помощью Антиспама Dr.Web;
· раздел Исключения, в котором задается список приложений, почтовый трафик которых исключается из проверки почтовым сторожем SpIDer Mail;
· раздел Перехват, в котором задаются параметры перехвата соединений с почтовыми серверами;
· раздел Отчет, в котором задается режим ведения файла отчета почтового сторожа SpIDer Mail.
3. Внесите необходимые изменения. Для получения информации о настройках, расположенных в разделе, нажмите кнопку Справка Справка .
4. По окончании редактирования настроек нажмите кнопку ОК для сохранения внесенных изменений или кнопку Отмена для отказа от них.


Раздел Проверка

В этом разделе задаются реакции почтового сторожа SpIDer Mail на обнаружение вредоносных объектов в электронной почте.

Реакция задается отдельно для каждой категории объектов:

· Инфицированные письма, зараженные известным и (предположительно) излечимым вирусом;
· Неизлечимые сообщения, зараженные неизлечимым вирусом;
· Подозрительные письма, предположительно зараженные вирусом или содержащие вредоносный объект;
· письма, содержащие различные потенциально опасные объекты.

Вы можете изменить реакцию почтового сторожа SpIDer Mail на обнаружение каждого типа объектов. Состав доступных реакций при этом зависит от типа вирусного события.

Чтобы подробнее ознакомиться с какой-либо настройкой, задаваемой в этом разделе,  щелкните по соответствующему фрагменту окна на рисунке.  Чтобы получить справку о параметрах, задаваемых в каком-либо другом разделе,  щелкните по ссылке на этот раздел на рисунке.

Чтобы подробнее ознакомиться с какой-либо настройкой, задаваемой в этом разделе,
щелкните по соответствующему фрагменту окна на рисунке.
Чтобы получить справку о параметрах, задаваемых в каком-либо другом разделе,
щелкните по ссылке на этот раздел на рисунке.

По умолчанию почтовый сторож SpIDer Mail пытается вылечить письма, зараженные известным и потенциально излечимым вирусом. Неизлечимые и подозрительные письма, а также рекламные программы и программы дозвона перемещаются в Карантин. Остальные письма передаются почтовым сторожем без изменений (пропускаются). Реакции почтового сторожа SpIDer Mail аналогичны соответствующим реакциям Сканера Dr.Web.

Уточнения и рекомендации

Вы можете предписать почтовому сторожу SpIDer Mail следующие реакции:

Действие

Описание

Лечить

Восстановить состояние письма до заражения. Если вирус неизлечим или попытка лечения не была успешной, будет отработана реакция, заданная для неизлечимых вирусов.

Данное действие возможно только для инфицированных писем, зараженных известным излечимым вирусом, за исключением троянских программ, которые при обнаружении удаляются. Лечение файлов в архивах невозможно вне зависимости от типа вируса.

Удалять

Удалить письмо. В этом случае электронное письмо не пересылается адресату, вместо этого почтовой программе передается сообщение о совершенной операции.

Карантин

Переместить письмо в специальный каталог Карантина. В этом случае письмо не пересылается адресату, вместо этого почтовой программе передается сообщение о совершенной операции.

Игнорировать

Передать письмо без выполнения каких-либо действий над ним.

В случае обнаружения вредоносных объектов в почте любая из указанных настроек, кроме действия Игнорировать, приводит к отказу в передаче письма.

Вы можете увеличить надежность антивирусной защиты по сравнению с уровнем, предусмотренным по умолчанию, выбрав в списке Непроверенные письма пункт Перемещать в карантин. Файлы с перемещенными письмами в этом случае рекомендуется в последствие проверять Сканером Dr.Web.

Примечание

Защиту от подозрительных писем можно отключать только в том случае, когда ваш компьютер дополнительно защищен постоянно загруженным сторожем SpIDer Guard.

Опытные пользователи могут также задать более гибкие настройки сканирования, действий над письмами, а также оптимизации. Для доступа к дополнительным настройкам нажмите кнопку Дополнительно.

После выполнения предписанного действия почтовый сторож SpIDer Mail по умолчанию выводит соответствующее оповещение в область уведомлений Windows. Вы можете запретить или разрешить вывод уведомлений.

Настройка уведомлений сторожа SpIDer Mail

1. Откройте контекстное меню значка SpIDer Agent Значок SpIDer Agent .
2. В подменю Инструменты выберите пункт Настройки. Откроется окно настроек Dr.Web.
3. Выполните одно из следующих действий:
· чтобы запретить вывод уведомлений сторожа SpIDer Mail, в группе Типы уведомлений снимите флажок SpIDer Mail;
· чтобы разрешить вывод уведомлений сторожа SpIDer Mail, в группе Типы уведомлений установите флажок SpIDer Mail.
4. По окончании редактирования настроек нажмите кнопку ОК для сохранения внесенных изменений или кнопку Отмена для отказа от них.


Дополнительные настройки сканирования

Дополнительные настройки режима проверки

В этом окне задаются дополнительные настройки режима проверки электронной почты, включая особенности сканирования, действия над письмом и параметры оптимизации.

Для доступа к этому окну в настройках почтового сторожа SpIDer Mail выберите раздел Проверка и нажмите кнопку Дополнительно.

Чтобы подробнее ознакомиться с какой-либо настройкой, задаваемой в этом окне,  щелкните по соответствующему фрагменту окна на рисунке.

Чтобы подробнее ознакомиться с какой-либо настройкой, задаваемой в этом окне,
щелкните по соответствующему фрагменту окна на рисунке.

Особенности проверки

Эта группа настроек задает дополнительные параметры проверки электронной почты. По умолчанию установлены следующие важные настройки, изменять которые не рекомендуется:

· использование эвристического анализа – в данном режиме используются специальные механизмы, позволяющие выявить в электронной почте подозрительные объекты, с большой вероятностью зараженные еще неизвестными вирусами. Чтобы отключить эвристический анализ, снимите флажок Эвристический анализатор;
· пресечение массовых рассылок – в данном режиме обнаруживаются характерные признаки массовых рассылок, которые являются частым следствием заражения компьютера вирусами. В данном режиме почтовый сторож SpIDer Mail может блокировать посылку вами почты по нескольким адресам. При возникновении трудностей с отправкой сообщений нескольким адресатам снимите флажок Контроль вирусной активности;
· проверка содержимого архивов, передаваемых по электронной почте. Для ускорения работы почтового сторожа SpIDer Mail снимите флажок Проверять файлы в архивах, чтобы отключить эту настройку.

Примечание

Отказ от проверки содержимого архивов в условиях постоянной работы сторожа SpIDer Guard не ведет к проникновению вирусов на компьютер, а лишь откладывает момент их обнаружения. При распаковке зараженного архива операционная система производит попытку записать инфицированный объект на диск, при этом сторож SpIDer Guard неминуемо обнаруживает вредоносный объект.

Действия над письмом

В данной группе настроек указываются дополнительные действия над электронными письмами, обработанными почтовым сторожем SpIDer Mail.

Настройка

Описание

Вставка заголовка 'X‑Antivirus' в сообщения

Установлена по умолчанию.

При использовании данной настройки в заголовок всех писем, обработанных почтовым сторожем SpIDer Mail, добавляется информация о проверке электронного сообщения и версии Dr.Web. Вы не можете изменить формат добавляемого заголовка.

Удалять модифицированые письма на сервере

Установлена по умолчанию.

При использовании данной настройки входящие письма, удаленные или перемещенные в карантин почтовым сторожем SpIDer Mail, удаляются с почтового сервера независимо от настроек почтовой программы.

Снимите этот флажок для удаления таких письма вручную или с использованием более гибких настроек почтовой программы.

Оптимизация сканирования

Эта группа настроек задает условия, при выполнении которых сложноустроенные письма, проверка которых является чрезмерно трудоемкой, признаются непроверенными.

Вы можете указать следующие параметры:

· таймаут проверки письма – максимальное время, в течение которого письмо проверяется. По истечении указанного времени проверка письма будет прекращаться;
· максимальную длину файла при распаковке. Если почтовый сторож определяет, что после распаковки архив будет больше указанной длины, проверка и распаковка производиться не будет;
· максимальный коэффициент сжатия архива. Если почтовый сторож определяет, что коэффициент сжатия архива превышает указанный, распаковка и проверка производиться не будет;
· максимальный уровень вложенности в архив. Если уровень вложенности в архив превышает указанный, проверка будет производиться только до указанного уровня вложенности.

Для включения одного или нескольких параметров оптимизации установите соответствующие флажки.


Раздел Антиспам

В этом разделе задаются настройки Антиспама Dr.Web.

Примечание

Функция проверки писем на спам доступна только для Dr.Web Security Space.

Почтовый сторож SpIDer Mail по умолчанию осуществляет проверку входящих писем на спам. Чтобы входящая корреспонденция не проверялась спам-фильтром, выберите режим Не проверять почту на наличие спама.

Чтобы подробнее ознакомиться с какой-либо настройкой, задаваемой в этом разделе,  щелкните по соответствующему фрагменту окна на рисунке.  Чтобы получить справку о параметрах, задаваемых в каком-либо другом разделе,  щелкните по ссылке на этот раздел на рисунке.

Чтобы подробнее ознакомиться с какой-либо настройкой, задаваемой в этом разделе,
щелкните по соответствующему фрагменту окна на рисунке.
Чтобы получить справку о параметрах, задаваемых в каком-либо другом разделе,
щелкните по ссылке на этот раздел на рисунке.

В группе настроек Особенности проверки на спам вы можете указать, какие письма не следует причислять к спаму и каким образом помечать отфильтрованные сообщения.

Подробнее о настройках

Настройка

Описание

Разрешать текст на кириллице

Установлена по умолчанию.

Данная настройка указывает почтовому сторожу SpIDer Mail без предварительного анализа не причислять к спаму письма, написанные с соответствии с установленной кириллической кодировкой. Если этот флажок снят, то такие письма с большой вероятностью будут отмечены фильтром как спам.

Разрешать текст на азиатских языках

Установлена по умолчанию.

Данная настройка указывает почтовому сторожу SpIDer Mail без предварительного анализа не причислять к спаму письма, написанные в соответствии с наиболее распространенными кодировками азиатских языков. Если этот флажок снят, то такие письма с большой вероятностью будут отмечены фильтром как спам.

Добавлять префикс к полю Subject писем, содержащих спам

По умолчанию данный флажок установлен, в начало темы спам-писем добавляется подстрока «[SPAM]».

Данная настройка указывает почтовому сторожу SpIDer Mail добавлять указанный префикс к темам писем, распознаваемых как спам.

Добавление префикса поможет вам создать правила для фильтрации почтовых сообщений, помеченных как спам, в тех почтовых клиентах (например, MS Outlook Express), в которых невозможно настроить фильтры по заголовкам писем.

Белый список

Нажмите, чтобы задать список адресатов, чьи электронные письма вы хотите гарантированно пропускать без проверки на спам.

Чёрный список

Нажмите, чтобы задать список адресатов, чьи электронные письма вы хотите гарантированно блокировать.

Обработка писем спам-фильтром

Почтовый сторож SpIDer Mail добавляет ко всем проверенным письмам следующие заголовки:

· X-DrWeb-SpamState: <значение>, где <значение> указывает на то, является ли письмо спамом (Yes) по мнению почтового сторожа SpIDer Mail или нет (No);
· X-DrWeb-SpamVersion: <версия>, где <версия> – версия библиотеки Антиспама Dr.Web;
· X-DrWeb-SpamReason: <рейтинг спама>, где <рейтинг спама> – перечень оценок по различным критериям принадлежности к спаму.

Используйте эти заголовки и префикс в теме письма (если соответствующий флажок установлен) для настройки фильтрации спама вашей почтовой программой.

Примечание

Если для получения почтовых сообщений вы используете протоколы IMAP/NNTP, то настройте вашу почтовую программу таким образом, чтобы письма загружались с почтового сервера сразу целиком, без предварительного просмотра заголовков. Это необходимо для корректной работы спам-фильтра.

Для повышения качества работы спам-фильтра, вы можете сообщать об ошибках распознавания спама.

Исправление ошибок распознавания

1. При обнаружении ошибки в работе спам-фильтра, создайте новое письмо и приложите к нему неправильно распознанное сообщение. Письма, отправленные в тексте письма, анализироваться не будут.
2. Отправьте письмо со вложением на один из следующих адресов:
· письмо, ошибочно оцененное как спам, – на адрес vrnonspam@drweb.com;
· спам, нераспознанный системой, – на адрес vrspam@drweb.com.


Белый cписок адресов

В этом окне задаются списки отправителей, почтовые сообщения которых пропускаются почтовым сторожем SpIDer Mail без проведения анализа.

Для доступа к этому окну в настройках почтового сторожа SpIDer Mail выберите раздел Антиспам и нажмите кнопку Белый список.

Чтобы подробнее ознакомиться с какой-либо настройкой, задаваемой в этом разделе,  щелкните по соответствующему фрагменту окна на рисунке.  Чтобы получить справку о параметрах, задаваемых в каком-либо другом разделе,  щелкните по ссылке на этот раздел на рисунке.

Чтобы подробнее ознакомиться с какой-либо настройкой, задаваемой в этом разделе,
щелкните по соответствующему фрагменту окна на рисунке.
Чтобы получить справку о параметрах, задаваемых в каком-либо другом разделе,
щелкните по ссылке на этот раздел на рисунке.

Если адрес отправителя добавлен в «белый» список, письмо не подвергается анализу на содержание спама. Однако если доменное имя адресов получателя и отправителя письма совпадают, и это доменное имя занесено в «белый» список с использованием маски *@<имя.домена>, то письмо подвергается проверке на спам. По умолчанию список пуст.

Примечание

Если какие-либо письма неправильно распознаются спам-фильтром, следует отправлять их на специальные почтовые адреса.

Задание списков антиспама

1. На вкладке Белый список введите в поле ввода почтовый адреса отправителя или маску, задающую почтовые адреса отправителей, чьи письма вы хотите гарантированно получать без проведения проверки на спам. Методы ввода.
· чтобы добавить в список определенного отправителя, введите его полный почтовый адрес (например, name@pochta.ru). Все письма, полученные с этого адреса, будут доставляться без проверки на спам;
· чтобы добавить в список отправителей, использующих похожие адреса электронной почты, используйте символы «*» и «?», чтобы заменить отличающуюся часть адреса. При этом символ «*» замещает любую последовательность символов, а символ «?» – один (любой) символ. Пример: если вы введете адрес name*@pochta.ru, то письма от отправителей с адресами вида name@pochta.ru, name1@pochta.ru, name_moj@pochta.ru и т.п. не будут проверяться на спам;
· чтобы гарантированно получать письма с почтовых адресов в конкретном домене, используйте символ «*» вместо имени пользователя. Пример: чтобы получать все письма от адресатов из домена mail.ru, введите *@mail.ru.
2. Нажмите кнопку Добавить.
3. При необходимости повторите шаги 1 и 2 для добавления других адресов. Чтобы удалить адресата из «белого» списка, выберите соответствующий элемент в списке и нажмите кнопку Удалить.
4. По окончании редактирования списков нажмите кнопку ОК для сохранения внесенных изменений или кнопку Отмена для отказа от них.


Черный список адресов

В этом окне задаются списки отправителей, почтовые сообщения которых расцениваются почтовым сторожем SpIDer Mail как спам без проведения анализа.

Для доступа к этому окну в настройках почтового сторожа SpIDer Mail выберите раздел Антиспам и нажмите кнопку Чёрный список.

Чтобы подробнее ознакомиться с какой-либо настройкой, задаваемой в этом разделе,  щелкните по соответствующему фрагменту окна на рисунке.  Чтобы получить справку о параметрах, задаваемых в каком-либо другом разделе,  щелкните по ссылке на этот раздел на рисунке.

Чтобы подробнее ознакомиться с какой-либо настройкой, задаваемой в этом разделе,
щелкните по соответствующему фрагменту окна на рисунке.
Чтобы получить справку о параметрах, задаваемых в каком-либо другом разделе,
щелкните по ссылке на этот раздел на рисунке.

Если адрес отправителя добавлен в «черный» список, письму без дополнительного анализа присваивается статус спама. По умолчанию список пуст.

Примечание

Если какие-либо письма неправильно распознаются спам-фильтром, следует отправлять их на специальные почтовые адреса.

Задание списков антиспама

1. Введите в поле ввода почтовый адрес отправителя или маску, задающую почтовые адреса отправителей, чьи письма вы хотите помечать как спам без проведения проверки. Методы ввода.
· чтобы добавить в список определенного отправителя, введите его полный почтовый адрес (например, spam@spam.ru). Все письма, полученные с этого адреса, будут автоматически распознаваться как спам;
· чтобы добавить в список отправителей, использующих похожие адреса электронной почты, используйте символы «*» и «?», чтобы заменить отличающуюся часть адреса. При этом символ «*» замещает любую последовательность символов, а символ «?» – один (любой) символ. Пример: если вы введете адрес spam*@spam.ru, то все письма от отправителей с адресами вида spam@spam.ru, spam1@spam.ru, spamer@spam.ru и т.п. будут автоматически распознаваться как спам;
· чтобы гарантированно помечать как спам письма с почтовых адресов в конкретном домене, используйте символ «*» вместо имени пользователя. Пример: чтобы помечать как спам все письма от адресатов из домена spam.ru, введите *@spam.ru.
2. Нажмите кнопку Добавить.
3. При необходимости повторите шаги 1 и 2 для добавления других адресов. Чтобы удалить адресата из «черного» списка, выберите соответствующий элемент в списке и нажмите кнопку Удалить.
4. По окончании редактирования списков нажмите кнопку ОК для сохранения внесенных изменений или кнопку Отмена для отказа от них.


Раздел Исключения

По умолчанию почтовый сторож SpIDer Mail автоматически перехватывает почтовый трафик всех пользовательских приложений на вашем компьютере. В этом разделе задается список приложений, почтовый трафик которых не будет перехватываться и, соответственно, анализироваться почтовым сторожем.

Чтобы подробнее ознакомиться с какой-либо настройкой, задаваемой в этом разделе,  щелкните по соответствующему фрагменту окна на рисунке.  Чтобы получить справку о параметрах, задаваемых в каком-либо другом разделе,  щелкните по ссылке на этот раздел на рисунке.

Чтобы подробнее ознакомиться с какой-либо настройкой, задаваемой в этом разделе,
щелкните по соответствующему фрагменту окна на рисунке.
Чтобы получить справку о параметрах, задаваемых в каком-либо другом разделе,
щелкните по ссылке на этот раздел на рисунке.

По умолчанию список пуст. Вы можете добавить к исключениям конкретные программы.

Формирование списка исключений

1. Чтобы добавить программу к списку исключений, выполните одно из следующих действий:
· нажмите кнопку Обзор и выберите файл программы;
· вручную ввести полный путь к файлу программы в поле ввода.
2. Нажмите кнопку Добавить.
3. При необходимости повторите шаги 1 и 2 для добавления других программ. Чтобы удалить программу из списка исключений и добавить ее почтовый трафик к проверке почтовым сторожем SpIDer Mail, выберите соответствующий элемент в списке и нажмите кнопку Удалить.


Раздел Перехват

В этом разделе задаются параметры перехвата соединений с почтовыми серверами.

Почтовый сторож SpIDer Mail поддерживает перехват соединений со следующими видами почтовых серверов:

· POP3-сервера;
· SMTP-сервера;
· IMAP4-сервера;
· NNTP-сервера.

Перехват соединений осуществляется в одном из следующих режимов:

· автоматический режим, в котором перехват соединений осуществляется скрыто от почтовых программ. Этот режим подходит для большинства применений и не требует дополнительной настройки почтовых программ;
· ручной режим, в котором перехват соединений с почтовыми серверами настраивается в явном виде. Почтовый сторож SpIDer Mail в данном режиме выступает в роли прокси-сервера между почтовыми программами и почтовыми серверами, поэтому использование данного типа перехвата требует изменения настроек подключения почтовых программ.

Примечание

Почтовый сторож SpIDer Mail может работать одновременно только в одном режиме. Если автоматический перехват соединений для какой-либо почтовой программы невозможен, необходимо переключиться на ручной режим перехвата и настроить отслеживание соединений не только для программы-исключения, но и для всех остальных почтовых программ.

В ручном режиме осуществляется перехват только тех соединений, которые указаны в настройках. Перехват остальных соединений не осуществляется.

Чтобы подробнее ознакомиться с какой-либо настройкой, задаваемой в этом разделе,  щелкните по соответствующему фрагменту окна на рисунке.  Чтобы получить справку о параметрах, задаваемых в каком-либо другом разделе,  щелкните по ссылке на этот раздел на рисунке.

Чтобы подробнее ознакомиться с какой-либо настройкой, задаваемой в этом разделе,
щелкните по соответствующему фрагменту окна на рисунке.
Чтобы получить справку о параметрах, задаваемых в каком-либо другом разделе,
щелкните по ссылке на этот раздел на рисунке.

Рекомендуется использовать для перехвата почтового трафика автоматический режим. При настройках по умолчанию в этом режиме перехватываются обращения к почтовым серверам всех типов с любыми IP-адресами.

Ручной режим следует использовать только в тех случаях, когда автоматический режим для всех или части почтовых программ или серверов невозможен, поскольку почтовый сторож SpIDer Mail может работать одновременно только в одном режиме.

Чтобы изменить настройки перехвата соединений, под соответствующим вариантом нажмите кнопку Настройка соединения.


Настройка автоматического перехвата

В этом окне задаются настройки автоматического перехвата подключений к почтовым серверам. Этот режим подходит для работы с большинством почтовых программам.

Чтобы подробнее ознакомиться с какой-либо настройкой, задаваемой в этом окне,  щелкните по соответствующему фрагменту окна на рисунке.

Чтобы подробнее ознакомиться с какой-либо настройкой, задаваемой в этом окне,
щелкните по соответствующему фрагменту окна на рисунке.

По умолчанию список перехватываемых адресов почтовых серверов содержит следующие элементы:

· любые адреса с портом 143 (стандартные IMAP4-сервера);
· любые адреса с портом 119 (стандартные NNTP-сервера);
· любые адреса с портом 110 (стандартные POP3-сервера);
· любые адреса с портом 25 (стандартные SMTP-сервера).

При данных настройках перехватываются стандартные обращения ко всем типам поддерживаемых почтовых серверов, использующих любые IP-адреса (задано при помощи символа «*»).

Примечание

В данном режиме обращения к почтовым серверам, расположенным на вашем компьютере (имеющим адрес localhost), не перехватываются. Для перехвата подобных соединений используйте ручной режим.

При необходимости вы можете отредактировать список правил перехвата (добавить или изменить порт почтового сервера, если для подключения используются нестандартные настройки, указать конкретные IP-адреса почтовых серверов и т.д.)

Настройка автоматического перехвата соединений

1. В настройках почтового сторожа SpIDer Mail выберите раздел Перехват, затем выберите автоматический режим перехвата и нажмите соответствующую кнопку Настройки соединения.
2. В открывшемся диалоговом окне в поле Адрес введите IP-адрес почтового сервера.
3. В поле Порт введите порт, по которому производятся обращения к почтовому серверу.
4. Нажмите кнопку Добавить.
5. При необходимости повторите шаги 2-4 для других серверов. Чтобы прекратить перехватывать подключения к серверу, выберите соответствующий элемент в списке и нажмите кнопку Удалить.
6. По окончании редактирования настроек нажмите кнопку ОК для сохранения внесенных изменений или кнопку Отмена для отказа от них.

Примечание

Почтовый сторож SpIDer Mail может работать одновременно только в одном режиме. Если автоматический перехват соединений для какой-либо почтовой программы невозможен, необходимо переключиться на ручной режим перехвата и настроить отслеживание соединений не только для программы-исключения, но и для всех остальных почтовых программ. При этом потребуется также изменить настройки всех почтовых программ.


Настройка перехвата вручную

В этом окне задаются настройки ручного перехвата подключений к почтовым серверам. В данном режиме почтовый сторож SpIDer Mail выступает в роли прокси-сервера между почтовыми программами и почтовыми серверами и отслеживает только те соединения, которые указаны в настройках в явном виде. Использование данного типа перехвата требует изменения настроек подключения почтовых программ.

Чтобы подробнее ознакомиться с какой-либо настройкой, задаваемой в этом окне,  щелкните по соответствующему фрагменту окна на рисунке.

Чтобы подробнее ознакомиться с какой-либо настройкой, задаваемой в этом окне,
щелкните по соответствующему фрагменту окна на рисунке.

Список перехватываемых адресов состоит из записей, каждая из которых устанавливает соответствие между настройками почтового сторожа SpIDer Mail и почтового сервера.

По умолчанию список перехвата пуст. Вы можете добавить в него необходимые записи.

Настройка перехвата соединений вручную

1. Составьте список почтовых серверов, обращения к которым вы хотите перехватывать, и пронумеруйте сервера в возрастающем порядке без пропусков. Рекомендуется начинать нумерацию с числа 7000. Эти номера далее будут именоваться портами SpIDer Mail.

Примечание

Почтовый сторож SpIDer Mail поддерживает почтовые сервера, работающие согласно протоколам POP3, SMTP, IMAP4 или NNTP.

2. В настройках почтового сторожа SpIDer Mail выберите раздел Перехват, затем выберите ручной режим перехвата и нажмите соответствующую кнопку Настройки соединения.
3. В открывшемся диалоговом окне введите следующую информацию:
· в поле Порт SpIDer Mail – порт SpIDer Mail, выбранный для почтового сервера;
· в поле Адрес сервера – доменное имя или IP-адрес почтового сервера;
· в поле Порт сервера – номер порта, который использует почтовый сервер.
4. Нажмите кнопку Добавить.
5. При необходимости повторите шаги 3 и 4 для других серверов. Чтобы прекратить перехватывать подключения к серверу, выберите соответствующий элемент в списке и нажмите кнопку Удалить.
6. По окончании редактирования настроек нажмите кнопку ОК для сохранения внесенных изменений или кнопку Отмена для отказа от них.
7. Настройте почтовый клиент на работу с почтовым сторожем SpIDer Mail при перехвате соединений вручную.

Настройка почтового клиента

Если SpIDer Mail использует для перехвата соединений ручные настройки, измените настройки вашего почтового клиента соответствующим образом:

· в качестве адреса сервера входящей и исходящей почты укажите localhost;
· в качестве порта почтового сервера укажите порт SpIDer Mail, назначенный вами для соответствующего почтового сервера.

Как правило, для этого необходимо в настройках адреса почтового сервера указать localhost:<порт_SpIDer_Mail>, где <порт_SpIDer_Mail> – порт, назначенный вами соответствующему почтовому серверу. Пример.

Например, если почтовому серверу с адресом pop.mail.ru и портом 110 назначен порт SpIDer Mail 7000, то в настройках почтового клиента необходимо указать localhost в качестве севера входящей почты и 7000 в качестве порта.


Раздел Отчет

В этом разделе задается режим ведения файла отчета.

Отчет почтового сторожа SpIDer Mail хранится в файле spiderml.log и находится в каталоге %USERPROFILE%\DoctorWeb (в Windows 7 – C:\Users\<имя_пользователя>\DoctorWeb).

Рекомендуется периодически анализировать файл отчета.

Чтобы получить справку о параметрах, задаваемых в каком-либо другом разделе,  щелкните по ссылке на этот раздел на рисунке.

Чтобы получить справку о параметрах, задаваемых в каком-либо другом разделе,
щелкните по ссылке на этот раздел на рисунке.

Вы можете задать одну из следующих степеней детальности ведения отчета:

· Стандартный – в данном режиме в отчете фиксируются только наиболее значимые события, такие как проведение обновлений, запуск и останов почтового сторожа SpIDer Mail и вирусные события. Данный режим ведения отчета подходит для большинства применений;
· Расширенный – в данном режиме в отчете помимо общих событий фиксируются параметры перехвата соединений, а также данные о проверяемых файлах, именах упаковщиков и содержимом проверяемых архивов. Рекомендуется использовать этот режим для проверки настроек перехвата соединений с почтовыми серверами;
· Отладочный – в данном режиме в отчете фиксируется максимальное количество информации о работе сторожа SpIDer Mail, что может привести к значительному увеличению файла отчета и снизить производительность работы операционной системы. Рекомендуется использовать этот режим только при возникновении проблем в работе сторожа SpIDer Mail или по просьбе технической поддержки компании «Доктор Веб».


Окно Статистика

Статистика

В данном окне отображаются результаты работы сторожа SpIDer Mail в течение текущего сеанса.

Для доступа к этому окну откройте контекстное меню значка SpIDer Agent Значок SpIDer Agent и в подменю SpIDer Mail выберите пункт Статистика.

Чтобы ознакомиться с какой-либо опцией, доступной в этом окне,  щелкните по соответствующему фрагменту окна на рисунке.

Чтобы ознакомиться с какой-либо опцией, доступной в этом окне,
щелкните по соответствующему фрагменту окна на рисунке.


Dr.Web для Outlook

Основные функции компонента

Подключаемый модуль Dr.Web для Outlook выполняет следующие функции:

· антивирусная проверка вложенных файлов почтовых сообщений;
· проверка почты, поступающей по зашифрованному соединению SSL;
· проверка почтовых сообщений на спам;
· обнаружение и нейтрализацию вредоносного программного обеспечения;
· использование эвристического анализатора для дополнительной защиты от неизвестных вирусов.

Настройка модуля Dr.Web для Outlook

Настройка параметров и просмотр статистики работы программы осуществляется в почтовом приложении Microsoft Outlook в разделе Сервис → Параметры → вкладка Антивирус Dr.Web (для Microsoft Outlook 2007 в разделе Инструменты → Опции → вкладка Антивирус Dr.Web).

Вкладка Антивирус Dr.Web в настройках приложения Microsoft Outlook доступна только при наличии у пользователя прав, позволяющих изменять данные настройки.

Чтобы подробнее ознакомиться с какой-либо настройкой, задаваемой в этом разделе,  щелкните по соответствующему фрагменту окна на рисунке.  Чтобы получить справку о параметрах, задаваемых в каком-либо другом разделе,  щелкните по ссылке на этот раздел на рисунке.

Чтобы подробнее ознакомиться с какой-либо настройкой, задаваемой в этом разделе,
щелкните по соответствующему фрагменту окна на рисунке.
Чтобы получить справку о параметрах, задаваемых в каком-либо другом разделе,
щелкните по ссылке на этот раздел на рисунке.

На вкладке Антивирус Dr.Web отображается текущее состояние защиты (включена/выключена). Кроме того, она предоставляет доступ к следующим функциям программы:

· Журнал - позволяет настроить регистрацию событий программы;
· Проверка вложений - позволяет настроить проверку электронной почты и определить действия программы для обнаруженных вредоносных объектов;
· Спам-фильтр - позволяет определить действия программы для спам-сообщений, а также создать белый и черный списки электронных адресов;
· Статистика - показывает данные об объектах, проверенных и обработанных программой.

Раздел Спам-фильтр доступен только для Dr.Web Security Space.


Проверка на вирусы

Dr.Web для Outlook использует различные методы обнаружения вирусов. К найденным вредоносным объектам применяются определяемые пользователем действия: программа может лечить инфицированные объекты, удалять их или перемещать в Карантин для их изоляции и безопасного хранения.


Вредоносные объекты

Программа Dr.Web для Outlook обнаруживает следующие вредоносные объекты:

· инфицированные объекты;
· файлы-бомбы или архивы-бомбы;
· рекламные программы;
· программы взлома;
· программы дозвона;
· программы-шутки;
· потенциально опасные программы;
· шпионские программы;
· троянские программы;
· компьютерные черви и вирусы.


Действия

Dr.Web для Outlook позволяет задать реакцию программы на обнаружение зараженных или подозрительных файлов и вредоносных программ при проверке вложений электронной почты.

Чтобы настроить проверку вложений и определить действия программы для обнаруженных вредоносных объектов, в почтовом приложении Microsoft Outlook в разделе Сервис → Параметры → вкладка Антивирус Dr.Web (для Microsoft Outlook 2007 в разделе Инструменты → Опции → вкладка Антивирус Dr.Web). нажмите кнопку Проверка вложений.

Чтобы подробнее ознакомиться с какой-либо настройкой, задаваемой в этом разделе,  щелкните по соответствующему фрагменту окна на рисунке.

Чтобы подробнее ознакомиться с какой-либо настройкой, задаваемой в этом разделе,
щелкните по соответствующему фрагменту окна на рисунке.

Окно Проверка вложений доступно только при наличии у пользователя прав администратора системы.

Для ОС Windows Vista и старше при нажатии кнопки Проверка вложений:

· При включенном UAC: администратору будет выдан запрос на подтверждение действий программы, пользователю без административных прав будет выдан запрос на ввод учетных данных администратора системы;
· При выключенном UAC: администратор сможет изменять настройки программы, пользователь не сможет получить доступ к изменению настроек.

В окне Проверка вложений вы можете задать действия программы для различных категорий проверяемых объектов, а также для случая, когда при проверке возникли ошибки. Кроме того, вы можете включить или выключить проверку архивов.

Для задания действий над обнаруженными вредоносными объектами служат следующие настройки:

· Выпадающий список Инфицированные задает реакцию на обнаружение объектов, зараженных известными и (предположительно) излечимыми вирусами;
· Выпадающий список Невылеченные задает реакцию на обнаружение объектов, зараженных известным неизлечимым вирусом, а также когда предпринятая попытка излечения не принесла успеха.
· Выпадающий список Подозрительные задает реакцию на обнаружение объектов, предположительно зараженных вирусом (срабатывание эвристического анализатора).
· Раздел Вредоносные программы задает реакцию на обнаружение следующего нежелательного ПО:
· рекламные программы;
· программы дозвона;
· программы шутки;
· программы взлома;
· потенциально опасные.
· Выпадающий список При ошибке проверки позволяет настроить действия программы в случае, если проверка вложения невозможна, например, если оно представляет собой поврежденный или защищенный паролем файл.
· Флаг Проверка архивов позволяет включить или отключить проверку вложенных файлов, представляющих собой архивы. Установите данный флаг для включения проверки, снимите - для отключения.

Состав доступных реакций зависит от типа вирусного события.

Предусмотрены следующие действия над обнаруженными объектами:

· Вылечить (действие доступно только для инфицированных объектов) - означает, что программа предпримет попытку вылечить инфицированный объект;
· Как для невылеченных (действие доступно только для инфицированных объектов) - означает, что к инфицированному вложению будет применено действие, выбранное для невылеченных объектов;
· Удалить - означает, что объект будет удален;
· Переместить в карантин - означает, что объект будет изолирован в каталоге Карантина;
· Пропустить - означает, что объект будет пропущен без изменений.
Объект | Действие
 | Вылечить | Как для невылеченных | Удалить | Переместить в карантин | Пропустить
Инфицированные | +/* | + |  |  |
Невылеченные |  |  | + | +/* |
Подозрительные |  |  | + | +/* | +
Рекламные программы |  |  | + | +/* | +
Программы дозвона |  |  | + | +/* | +
Программы-шутки |  |  | + | +/* | +
Программы взлома |  |  | + | +/* | +
Потенциально опасные |  |  | + | +/* | +
При ошибке проверки |  |  | + | +/* | +

Условные обозначения

+ | действие разрешено для данного типов объектов
+/* | действие установлено как реакция по умолчанию для данного типов объектов


Проверка на спам

Раздел Спам-фильтр доступен только для Dr.Web Security Space.

Если лицензия не поддерживает использование спам-фильтра, настройки проверки на спам будут недоступны, и сама проверка сообщений на спам осуществляться не будет.

Dr.Web для Outlook проверяет на спам все почтовые сообщения с помощью Антиспама Dr.Web и осуществляет фильтрацию сообщений в соответствии с настройками, задаваемыми пользователем.

Чтобы настроить проверку сообщений на спам, в почтовом приложении Microsoft Outlook в разделе Сервис → Параметры → вкладка Антивирус Dr.Web нажмите кнопку Спам-фильтр. Откроется окно настроек Спам фильтра.

Окно Спам-фильтр доступно только при наличии у пользователя прав администратора системы.

Для ОС Windows Vista и старше при нажатии кнопки Спам-фильтр:

· При включенном UAC: администратору будет выдан запрос на подтверждение действий программы, пользователю без административных прав будет выдан запрос на ввод учетных данных администратора системы;
· При выключенном UAC: администратор сможет изменять настройки программы, пользователь не сможет получить доступ к изменению настроек.


Настройка спам-фильтра
Чтобы подробнее ознакомиться с какой-либо настройкой, задаваемой в этом разделе,  щелкните по соответствующему фрагменту окна на рисунке.

Чтобы подробнее ознакомиться с какой-либо настройкой, задаваемой в этом разделе,
щелкните по соответствующему фрагменту окна на рисунке.

Для настройки параметров спам-фильтра:

· Установите флаг Проверять почту на спам для активации спам-фильтра.
· Если вы хотите добавлять специальный текст в заголовок сообщения, распознанного как спам, установить флаг Добавлять префикс в тему письма. Добавляемый текст можно ввести в текстовом поле справа от флага. По умолчанию добавляется префикс ***SPAM***.
· Проверенные сообщения могут отмечаться как прочитанные в свойствах письма. Для этого необходимо установить флаг Отметить письмо как прочитанное. По умолчанию флаг Отметить как прочитанное установлен.
· Также вы можете настроить белые и черные списки для фильтрации писем.

Если некоторые письма были неправильно распознаны, следует отправить их на специальные почтовые адреса для анализа и повышения качества работы фильтра. Подробнее

· Письма, ошибочно принятые за спам, следует отправлять на адрес vrnonspam@drweb.com;
· Нераспознанные и пропущенные спам-сообщения следует отправлять на адрес vrspam@drweb.com.

Все сообщения необходимо высылать только в виде вложения (а не в теле письма).


Черный и белый списки

Черный и белый списки электронных адресов служат для фильтрации сообщений.

Для просмотра и редактирования черного или белого списка, в настройках спам-фильтра, нажмите кнопку Черный список или Белый список соответственно.

Чтобы подробнее ознакомиться с какой-либо настройкой, задаваемой в этом разделе,  щелкните по соответствующему фрагменту окна на рисунке.

Чтобы подробнее ознакомиться с какой-либо настройкой, задаваемой в этом разделе,
щелкните по соответствующему фрагменту окна на рисунке.

Чтобы добавить адрес в черный или белый список:

1. Нажмите кнопку Добавить.
2. Введите электронный адрес в соответствующее поле (см. методы заполнения белого и черного списков).
3. Нажмите кнопку ОК в окне Редактировать список.

Чтобы изменить адреса в списке:

1. Выберите адрес в списке, нажмите кнопку Изменить.
2. Отредактируйте необходимую информацию.
3. Нажмите ОК в окне Редактировать список.

Чтобы удалить адрес из списка:

1. Выберите адрес в списке.
2. Нажмите кнопку Удалить.

В окне Белые и черные списки нажмите ОК, чтобы сохранить внесенные изменения.

Белый список

Если адрес отправителя добавлен в «белый» список, письмо не подвергается анализу на содержание спама. Однако, если доменное имя адресов получателя и отправителя письма совпадают, и это доменное имя занесено в белый список с использованием знака «*», то письмо подвергается проверке на спам. Методы ввода.

· чтобы добавить в список определенного отправителя, введите его полный почтовый адрес (например, mail@example.net). Все письма, полученные с этого адреса, будут доставляться без проверки на спам;
· каждый элемент списка может содержать только один почтовый адрес или одну маску почтовых адресов;
· чтобы добавить в список отправителей адреса определенного вида, введите маску, определяющую данные адреса. Маска задает шаблон для определения объекта. Она может включать обычные символы, допустимые в почтовых адресах, а также специальный символ *, который заменяет любую (в том числе пустую) последовательность любых символов.

Например, допускаются следующие варианты:

· mailbox@domain.com
· *box@domain.com
· mailbox@dom*
· *box@dom*

Знак * может ставиться только в начале или в конце адреса.

Символ @ обязателен.

· чтобы гарантированно получать письма с почтовых адресов в конкретном домене, используйте символ * вместо имени пользователя. Например, чтобы получать все письма от адресатов из домена example.net, введите *@example.net;
· чтобы гарантированно получать письма с почтовых адресов с конкретным именем пользователя с любого домена, используйте символ * вместо имени домена. Например, чтобы получать все письма от адресатов с названием почтового ящика ivanov, введите ivanov@*.

Черный список

Если адрес отправителя добавлен в «черный» список, то письму без дополнительного анализа присваивается статус спам. Методы ввода.

· чтобы добавить в список определенного отправителя, введите его полный почтовый адрес (например, spam@spam.ru). Все письма, полученные с этого адреса, будут автоматически распознаваться как спам;
· каждый элемент списка может содержать только один почтовый адрес или одну маску почтовых адресов;
· чтобы добавить в список отправителей адреса определенного вида, введите маску, определяющую данные адреса. Маска задает шаблон для определения объекта. Она может включать обычные символы, допустимые в почтовых адресах, а также специальный символ *, который заменяет любую (в том числе пустую) последовательность любых символов.

Например, допускаются следующие варианты:

· mailbox@domain.com
· *box@domain.com
· mailbox@dom*
· *box@dom*

Знак * может ставиться только в начале или в конце адреса.

Символ @ обязателен.

· чтобы гарантированно помечать как спам письма с почтовых адресов в конкретном домене, используйте символ * вместо имени пользователя. Например, чтобы помечать как спам все письма от адресатов из домена spam.ru, введите *@spam.ru;
· чтобы гарантированно помечать как спам письма с почтовых адресов с конкретным именем пользователя с любого домена, используйте символ * вместо имени домена. Например, чтобы помечать как спам все письма от адресатов с названием почтового ящика ivanov, введите ivanov@*;
· адреса из домена получателя не обрабатываются. Например, если почтовый ящик получателя (ваш почтовый ящик) находится в домене mail.ru, то адреса отправителей с домена mail.ru обрабатываться спам-фильтром не будут.


Регистрация событий

Dr.Web для Outlook регистрирует ошибки и происходящие события в следующих журналах регистрации:

· журнале регистрации событий операционной системы (Event Log);
· текстовом журнале отладки.


Журнал операционной системы

В журнал регистрации операционной системы (Event Log) заносится следующая информация:

· сообщения о запуске и остановке программы;
· параметры лицензионного ключевого файла: действительность или недействительность лицензии, срок действия лицензии (информация заносится при запуске программы, в процессе ее работы и при замене лицензионного ключевого файла);
· параметры модулей программы: сканера, ядра, вирусных баз (информация заносится при запуске программы и при обновлении модулей);
· сообщение о недействительности лицензии: отсутствие ключевого файла, отсутствие в ключевом файле разрешения на использование модулей программы, лицензия заблокирована, нарушение целостности ключевого файла (информация заносится при запуске программы и в процессе ее работы);
· сообщения об обнаружении вирусов;
· уведомления о завершении срока действия лицензии (информация заносится за 30, 15, 7, 3, 2 и 1 день до окончания срока).

Чтобы просмотреть журнал регистрации событий операционной системы:

1. Откройте Панель управления операционной системы.
2. Выберите раздел Администрирование → Просмотр Событий.
3. В левой части окна Просмотр Событий выберите пункт Приложение. Откроется список событий, зарегистрированных в журнале пользовательскими приложениями. Источником сообщений Dr.Web для Outlook является приложение Dr.Web for Outlook.


Текстовый журнал отладки

В текстовый журнал отладки заносится следующая информация:

· сообщения о действительности или недействительности лицензии;
· сообщения об обнаружении вирусов;
· сообщения об ошибках записи или чтения файлов, ошибках анализа архивов или файлов, защищенных паролем;
· параметры модулей программы: сканера, ядра, вирусных баз;
· сообщения об экстренных остановах ядра программы;
· уведомления о завершении срока действия лицензии (информация заносится за 30, 15, 7, 3, 2 и 1 день до окончания срока).

Ведение текстового журнала программы приводит к снижению быстродействия системы, поэтому рекомендуется включать регистрацию событий только в случае возникновения ошибок работы приложения Dr.Web для Outlook.

Настройка регистрации событий

1. На вкладке Антивирус Dr.Web нажмите кнопку Журнал. Откроется окно настроек журнала.
2. Выберите уровень детализации (от 0 до 5) для записи событий:
· уровень 0 означает, что регистрация событий в текстовом журнале отладки не ведется,
· уровень 5 соответствует максимальной детализации регистрируемых событий.

По умолчанию регистрация событий отключена.

3. Задайте максимальный размер (в килобайтах) файла журнала.
4. Нажмите кнопку ОК для сохранения изменений.

Окно Журнал доступно только при наличии у пользователя прав администратора системы.

Для операционной системы Windows Vista и старше при нажатии кнопки Журнал:

· При включенном UAC: администратору будет выдан запрос на подтверждение действий программы, пользователю без административных прав будет выдан запрос на ввод учетных данных администратора системы;
· При выключенном UAC: администратор сможет изменять настройки программы, пользователь не сможет получить доступ к изменению настроек.

Просмотр журнала событий программы

Для просмотра текстового журнала событий программы нажмите кнопку Показать в папке. Откроется каталог, в котором хранится журнал.


Статистика

В почтовом приложении Microsoft Outlook в разделе Сервис → Параметры → вкладка Антивирус Dr.Web содержится статистическая информация об общем количестве объектов, проверенных и обработанных программой.

Объекты разделяются на следующие категории:

· Проверено – общее количество проверенных писем.
· Инфицированных – количество писем, содержащие вирусы.
· Подозрительных – количество писем, предположительно зараженных вирусом (срабатывание эвристического анализатора).
· Вылечено – количество объектов, успешно вылеченных программой.
· Непроверенных – количество объектов, проверка которых невозможна или при проверке возникли ошибки.
· Чистых – количество писем, не содержащие вредоносных объектов.

Затем указывается количество объектов, которые были:

· Перемещено – количество объектов, перемещенных в Карантин.
· Удалено – количество объектов, удаленных из системы.
· Пропущено – количество объектов, пропущенных без изменений.
· Спам-писем – количество писем, распознанных как спам.

По умолчанию статистика сохраняется в файле drwebforoutlook.stat, который находится в каталоге %USERPROFILE%\DoctorWeb (в Windows 7, C:\Users\<имя пользователя>\DoctorWeb).

Файл статистики drwebforoutlook.stat ведется отдельно для каждого пользователя системы.


Веб-антивирус SpIDer Gate

Примечание

Данный компонент включается в состав только Dr.Web Security Space.

SpIDer Gate — модуль антивирусной проверки HTTP-трафика. При настройках по умолчанию SpIDer Gate автоматически проверяет входящий HTTP-трафик и блокирует передачу объектов, содержащих вредоносные программы. Через протокол HTTP работают веб-обозреватели (браузеры), менеджеры загрузки и многие другие приложения, обменивающиеся данными с веб-серверами, т.е. работающие с сетью Интернет.

С помощью изменения настроек SpIDer Gate вы можете отключить проверку входящего трафика или добавить к проверке и исходящий трафик, а также сформировать список тех приложений, HTTP-трафик которых будет проверяться в любом случае и в полном объеме. Также существует возможность исключения из проверки трафика отдельных приложений.

При базовых настройках SpIDer Gate блокирует получаемые по сети объекты, содержащие вредоносные программы.

Программа постоянно находится в оперативной памяти компьютера и автоматически перезапускается при загрузке Windows. При необходимости вы можете изменить режим запуска веб-антивируса при загрузке операционной системы.


Управление SpIDer Gate

Основные средства настройки и управления веб-антивирусом SpIDer Gate сосредоточены в группе SpIDer Gate контекстного меню SpIDer Agent:

Меню SpIDer Agent для Dr.Web Securty Space Pro

Группа SpIDer Gate включает следующие пункты:

Пункт меню | Описание
Статистика | Открывает окно, содержащее сведения о работе веб-антивируса SpIDer Gate в течение текущего сеанса (количество проверенных, зараженных и подозрительных веб-страниц, предпринятые действия и др.).
Настройки | Данный пункт недоступен в пользовательском режиме. Предоставляет доступ к основной части настраиваемых параметров веб-антивируса SpIDer Gate. Доступ к изменению настроек веб-антивируса защищен паролем.
Отключить/Включить | Позволяет временно отключить сканирование веб-страниц с помощью веб-антивируса SpIDer Gate. Пункт Включить появляется в меню в том случае, когда сканирование HTTP-трафика было приостановлено.

Временное отключение веб-антивируса

Вы можете временно отключать антивирусную проверку трафика, выполняемую веб-антивирусом SpIDer Gate.

Отключение функций веб-антивируса

1. Откройте контекстное меню значка SpIDer Agent Значок SpIDer Agent .
2. В подменю SpIDer Gate выберите пункт Отключить.

Восстановление функций веб-антивируса

1. Откройте контекстное меню значка SpIDer Agent Значок SpIDer Agent .
2. В подменю SpIDer Gate выберите пункт Включить.


Настройка SpIDer Gate

Основные средства настройки и управления веб-антивирусом SpIDer Gate сосредоточены в группе SpIDer Gate контекстного меню SpIDer Agent.

Доступ к изменению настроек модуля защищен паролем. При первом запуске модуля появится диалоговое окно, в котором вам будет предложено ввести новый пароль. Вы сможете изменить пароль в настройках Родительского контроля.

Пароль для доступа к настройкам

Настройка веб-антивируса

Примечание

Настройки веб-антивируса SpIDer Gate недоступны в пользовательском режиме.

Доступ к изменению настроек веб-антивируса защищен паролем.

1. Откройте контекстное меню значка SpIDer Agent Значок SpIDer Agent .
2. В подменю SpIDer Gate выберите пункт Настройки.
3. Введите ранее сохраненный пароль. Задание пароля производится при вызове настроек параметров модуля в первый раз.
4. Откроется окно настроек, содержащее следующие разделы:
· раздел Действия, в котором задается режим проверки HTTP-трафика;
· раздел Фильтр приложений, в котором задаются параметры проверки HTTP-трафика для конкретных программ;
· раздел Прокси-сервер, в котором указываются настройки доступа в Интернет;
· раздел Отчет, в котором задается режим ведения файла отчета веб-антивируса SpIDer Gate.
5. Внесите необходимые изменения. Для получения информации о настройках, расположенных в разделе, нажмите кнопку Справка Справка .
6. По окончании редактирования настроек нажмите кнопку ОК для сохранения внесенных изменений или кнопку Отмена для отказа от них.


Раздел Действия

В данном разделе задается режим проверки HTTP-трафика.

Чтобы подробнее ознакомиться с какой-либо настройкой, задаваемой в этом разделе,  щелкните по соответствующему фрагменту окна на рисунке.  Чтобы получить справку о параметрах, задаваемых в каком-либо другом разделе,  щелкните по ссылке на этот раздел на рисунке.

Чтобы подробнее ознакомиться с какой-либо настройкой, задаваемой в этом разделе,
щелкните по соответствующему фрагменту окна на рисунке.
Чтобы получить справку о параметрах, задаваемых в каком-либо другом разделе,
щелкните по ссылке на этот раздел на рисунке.

В группе Режим проверки предоставляется возможность выбора типа проверяемого HTTP-трафика. По умолчанию проверяется только входящий трафик.

В группе Параметры блокировки вы можете установить автоматическую блокировку доступа к известным веб-сайтам, с которых распространяются вирусы или вредоносные программы других типов (для этого установите флажок Блокировать известные источники распространения вирусов), а также к нерекомендованным сайтам, известным как неблагонадежные (для этого установите флажок Блокировать нерекомендуемые сайты). Нажмите кнопку Белый список, чтобы указать сайты, доступ к которым должен быть разрешен несмотря на установленные ограничения.

В этом же разделе вы можете настроить Баланс проверки – распределение ресурсов в зависимости от приоритетности сканирования трафика. При меньшем приоритете проверки скорость работы с сетью Интернет уменьшается, поскольку веб-антивирусу SpIDer Gate приходится дольше ждать загрузки данных и проверять больший объем информации. При увеличении приоритета сканирования проверка производится чаще, что позволяет сторожу отдавать данные быстрее, тем самым повышая скорость работы с сетью. Однако при более частых проверках повышается нагрузка на процессор. Вы можете подобрать наилучший баланс опытным путем.

Кнопка Расширенные настройки открывает доступ к окну выбора типов блокируемых объектов.


Белый список

В этом окне задаются списки веб-сайтов, доступ к которым разрешается вне зависимости от настроек, заданных в группе Параметры блокировки в разделе Действия.

Для доступа к этому окну в настройках SpIDer Gate выберите раздел Действия и нажмите кнопку Белый список.

Чтобы подробнее ознакомиться с какой-либо настройкой, задаваемой на этой вкладке,  щелкните по соответствующему фрагменту окна на рисунке.

Чтобы подробнее ознакомиться с какой-либо настройкой, задаваемой на этой вкладке,
щелкните по соответствующему фрагменту окна на рисунке.

По умолчанию список пуст. Если адрес сайта добавлен в «белый» список, то доступ к нему будет предоставляться вне зависимости от других настроек SpIDer Gate.

Формирование списка доменных адресов

1. В поле ввода укажите доменное имя или часть доменного имени веб-сайта, доступ к которому вы хотите разрешить вне зависимости от других ограничений. Методы ввода.
· чтобы добавить в список определенный сайт, введите его адрес (например, www.example.com). Доступ ко всем ресурсам, расположенным на этом сайте будет разрешен;
· чтобы разрешить доступ к тем веб-сайтам, в адресе которых содержится определенный текст, введите в поле этот текст. Пример: если вы введете текст example, то доступ к адресам example.com, example.test.com, test.com/example, test.example222.ru и т. п. будет разрешен;
· чтобы разрешить доступ к определенному домену, укажите имя домена с символом «.». В таком случае доступ ко всем ресурсам, находящиеся на этом домене, будет разрешен. Если при указании домена используется символ «/», то та часть подстроки, что стоит слева от символа «/», будет считаться доменным именем, а части справа от символа – частью разрешенного на данном домене адреса. Пример: если вы введете текст example.com/test, то будут разрешены такие адреса как example.com/test11, template.example.com/test22 и т. п.

Введенная строка при добавлении в список может быть преобразована к универсальному виду. Пример : адрес http://www.example.com будет преобразован в запись www.example.com.

2. Нажмите кнопку Добавить.
3. При необходимости повторите шаги 1 и 2 для добавления других адресов. Чтобы удалить адресата из «белого» списка, выберите соответствующий элемент в списке и нажмите кнопку Удалить.
4. По окончании редактирования списков нажмите кнопку ОК для сохранения внесенных изменений или кнопку Отмена для отказа от них.


Расширенные настройки

В этом окне задаются дополнительные настройки режима проверки HTTP-трафика, включая параметры проверки архивов и блокировки вредоносных объектов.

Для доступа к этому окну в настройках веб-антивируса SpIDer Gate выберите раздел Действия и нажмите кнопку Расширенные настройки.

Чтобы подробнее ознакомиться с какой-либо настройкой, задаваемой на этой вкладке,  щелкните по соответствующему фрагменту окна на рисунке.

Чтобы подробнее ознакомиться с какой-либо настройкой, задаваемой на этой вкладке,
щелкните по соответствующему фрагменту окна на рисунке.

По умолчанию веб-антивирус SpIDer Gate обнаруживает и блокирует следующие вредоносные программы:

· подозрительные,
· потенциально опасные,
· программы дозвона,
· программы взлома,
· рекламные программы,
· программы-шутки.

Веб-антивируса SpIDer Gate может блокировать следующие объекты:

· непроверенные;
· поврежденные.

Также по умолчанию включена опция проверки архивов. Для ускорения работы веб-антивируса SpIDer Gate вы можете отключить эту настройку.

Чтобы изменить состав блокируемых при передаче объектов, установите флажки у наименований типов нежелательных объектов, получение которых вы хотите предотвратить, и удалите флажки у наименований типов объектов, передачу которых блокировать не требуется.


Раздел Фильтр приложений

В данном разделе производится настройка параметров проверки HTTP-трафика.

Веб-антивирус SpIDer Gate производит проверку того HTTP-трафика, который проходит через порты указанные в верхней части раздела. По умолчанию проверяются следующие HTTP-порты, которые чаще всего используются приложениями для передачи информации по протоколу HTTP:

· порт 80;
· порт 8080;
· порт 3128.

Если вы знаете, что какое-либо приложение, установленное на вашем компьютере, использует иной порт для передачи HTTP-трафика, то добавьте данный порт в список Порты HTTP.

Чтобы подробнее ознакомиться с какой-либо настройкой, задаваемой в этом разделе,  щелкните по соответствующему фрагменту окна на рисунке.  Чтобы получить справку о параметрах, задаваемых в каком-либо другом разделе,  щелкните по ссылке на этот раздел на рисунке.

Чтобы подробнее ознакомиться с какой-либо настройкой, задаваемой в этом разделе,
щелкните по соответствующему фрагменту окна на рисунке.
Чтобы получить справку о параметрах, задаваемых в каком-либо другом разделе,
щелкните по ссылке на этот раздел на рисунке.

Вы можете задать списки программ, проверку которых нужно проводить с особой тщательностью (например, новые программы, установленные из неизвестных источников) или, наоборот, можно не проводить.

Настройка проверки трафика приложений

1. В настройках веб-антивируса SpIDer Gate выберите раздел Фильтр приложений.
2. Чтобы указать программу, сетевую активность которой следует проверять с особенной тщательностью, нажмите кнопку Обзор рядом со списком Приложения, проверяемые по всем портам и выберите файл программы. При необходимости повторите действия для других программ. Ненадежными программами могут считаться веб-обозреватели, менеджеры загрузок, а также новые установленные программы.

В список Приложения, проверяемые по всем портам необходимо добавлять только те программы, которые используют протокол HTTP.

3. Чтобы указать программу, сетевую активность которой SpIDer Gate контролировать не должен, нажмите кнопку Обзор рядом со списком Приложения, исключенные из проверки и выберите файл программы. При необходимости повторите действия для других программ. Исключать из проверки следует только те приложения, действиям и защищенности которых вы полностью доверяете.
4. Чтобы удалить частные правила проверки HTTP-трафика программы, выберите программу в одном из списков и нажмите соответствующую кнопку Удалить.


Раздел Прокси-сервер

В разделе Прокси-сервер вы можете включить локальный прокси-сервер. Укажите, какой порт вы ходите выделить локальному прокси-серверу SpIDer Gate. Этот же порт необходимо указать в настройках подключения приложений, использующих для работы сеть Интернет.

Чтобы подробнее ознакомиться с какой-либо настройкой, задаваемой в этом разделе,  щелкните по соответствующему фрагменту окна на рисунке.  Чтобы получить справку о параметрах, задаваемых в каком-либо другом разделе,  щелкните по ссылке на этот раздел на рисунке.

Чтобы подробнее ознакомиться с какой-либо настройкой, задаваемой в этом разделе,
щелкните по соответствующему фрагменту окна на рисунке.
Чтобы получить справку о параметрах, задаваемых в каком-либо другом разделе,
щелкните по ссылке на этот раздел на рисунке.

Настройка | Описание
Включить локальный прокси-сервер | Установите этот флажок, чтобы включить использование прокси-сервера SpIDer Gate.
Порт | Укажите порт прокси-сервера.
Используется прокси-сервер более высокого уровня | Установите этот флажок, если для выхода в Интернет уже используется прокси-сервер.
Адрес | Укажите адрес вышестоящего прокси-сервера.
Порт | Укажите порт вышестоящего прокси-сервера.

Если для доступа в Интернет уже используется прокси-сервер, то для работы SpIDer Gate необходимо указать адрес вышестоящего прокси-сервера.


Раздел Отчет

В этом разделе задается режим ведения файла отчета.

Отчет веб-антивируса SpIDer Gate хранится в файле spidergate.log и находится в каталоге %USERPROFILE%\DoctorWeb (в Windows 7 – C:\Users\<имя_пользователя>\DoctorWeb).

Рекомендуется периодически анализировать файл отчета.

Чтобы получить справку о параметрах, задаваемых в каком-либо другом разделе,  щелкните по ссылке на этот раздел на рисунке.

Чтобы получить справку о параметрах, задаваемых в каком-либо другом разделе,
щелкните по ссылке на этот раздел на рисунке.

Вы можете задать одну из следующих степеней детальности ведения отчета:

· Стандартный – в данном режиме в отчете фиксируются только наиболее значимые события, такие как проведение обновлений, запуск и останов веб-антивируса SpIDer Gate и вирусные события. Данный режим ведения отчета подходит для большинства применений;
· Расширенный – в данном режиме в отчете помимо общих событий фиксируются параметры перехвата соединений, а также данные о проверяемых файлах, именах упаковщиков и содержимом проверяемых архивов. Рекомендуется использовать этот режим для получения более детальной информации о проверенных объектах и работе веб-антивируса;
· Отладочный – в данном режиме в отчете фиксируется максимальное количество информации о работе SpIDer Gate, что может привести к значительному увеличению файла отчета и снизить производительность работы операционной системы. Рекомендуется использовать этот режим только при возникновении проблем в работе веб-антивируса SpIDer Gate или по просьбе технической поддержки компании «Доктор Веб».


Статистика

В данном окне отображаются результаты работы веб-антивируса SpIDer Gate в течение текущего сеанса.

Для доступа к этому окну откройте контекстное меню значка SpIDer Agent Значок SpIDer Agent и в подменю SpIDer Gate выберите пункт Статистика.

Чтобы ознакомиться с какой-либо опцией, доступной в этом окне,  щелкните по соответствующему фрагменту окна на рисунке.

Чтобы ознакомиться с какой-либо опцией, доступной в этом окне,
щелкните по соответствующему фрагменту окна на рисунке.


Модуль Родительского контроля

Примечание

Данный компонент включается в состав только Dr.Web Security Space.

Данный компонент недоступен в пользовательском режиме.

С помощью модуля Родительского контроля осуществляется ограничение доступа пользователя к ресурсам, содержащимся как локально, на самом компьютере, так и в сети.

Ограничение доступа к ресурсам локальной файловой системы позволяет сохранить целостность важных файлов и защитить их от заражения вирусами, а также сохранит необходимую конфиденциальность данных. Существует возможность защиты как отдельных файлов, так и папок целиком, расположенных как на локальных дисках, так и на внешних носителях информации. Также можно наложить полный запрет на просмотр информации со всех внешних носителей.

Контроль доступа к интернет-ресурсам позволяет как оградить пользователя от просмотров нежелательных веб-сайтов (сайтов, посвященных насилию, азартным играм и т.п.), так и разрешить пользователю доступ только к тем сайтам, которые определены настройками модуля Родительского контроля.

Примечание

Доступ к изменению настроек модуля Родительского контроля защищен паролем.


Настройка Родительского контроля

Основные средства настройки и управления модулем Родительский контроль сосредоточены в группе Родительский контроль контекстного меню SpIDer Agent.

Доступ к изменению настроек модуля защищен паролем. При первом запуске модуля появится диалоговое окно, в котором вам будет предложено ввести новый пароль. Впоследствии вы сможете изменить пароль.

Пароль для доступа к настройкам

Настройка Родительского контроля

Примечание

Настройки Родительского контроля недоступны в пользовательском режиме.

Доступ к изменению настроек Родительского контроля защищен паролем.

1. Откройте контекстное меню значка SpIDer Agent Значок SpIDer Agent .
2. В подменю Родительский контроль выберите пункт Настройки.
3. Введите ранее сохраненный пароль. Задание пароля производится при вызове настроек параметров модуля в первый раз.
4. Откроется окно настроек, содержащее следующие разделы:
· раздел Фильтр URL, в котором задаются параметры контроля доступа к веб-ресурсам;
· раздел Локальный доступ, в котором задаются ограничения доступа к локальным ресурсам компьютера.
5. Чтобы изменить пароль в окне настроек нажмите кнопку Сменить пароль и укажите новый пароль.
6. Внесите необходимые изменения. Для получения информации о настройках, расположенных в разделе, нажмите кнопку Справка Справка .
7. По окончании редактирования настроек нажмите кнопку ОК для сохранения внесенных изменений или кнопку Отмена для отказа от них.


Раздел Фильтр URL

В этом разделе производится настройка контроля доступа к веб-ресурсам.

Чтобы подробнее ознакомиться с какой-либо настройкой, задаваемой в этом разделе,  щелкните по соответствующему фрагменту окна на рисунке.  Чтобы получить справку о параметрах, задаваемых в каком-либо другом разделе,  щелкните по ссылке на этот раздел на рисунке.

Чтобы подробнее ознакомиться с какой-либо настройкой, задаваемой в этом разделе,
щелкните по соответствующему фрагменту окна на рисунке.
Чтобы получить справку о параметрах, задаваемых в каком-либо другом разделе,
щелкните по ссылке на этот раздел на рисунке.

В разделе Фильтр URL вы можете выбрать один из вариантов контроля доступа к сайтам:

Режим | Описание
Разрешить посещать все сайты | В этом режиме ограничений на доступ к веб-ресурсам нет.
Блокировать сайты с нежелательным или сомнительным контентом | В этом режиме вы можете указать категории тех ресурсов, доступ к которым вы хотите ограничить. Также в этом режиме вы можете самостоятельно указывать сайты, доступ к которым будет запрещаться или разрешаться вне зависимости от других ограничений. Для задания списков нажмите кнопку Чёрный список или кнопку Белый список соответственно.
Разрешать сайты только из «Белого списка» | В этом режиме запрещается доступ ко всем веб-ресурсам, кроме указанных в «белом» списке веб-сайтов. Для создания списка разрешенных ресурсов нажмите кнопку Белый список.

Примечание

Списки адресов веб-сайтов, относящихся ко всем тематическим категориям, регулярно обновляются модулем автоматического обновления вместе с обновлением вирусных баз.

Для смены пароля доступа к настройкам Родительского контроля и веб-антивируса SpIDer Gate нажмите кнопку Сменить пароль и укажите новый пароль.


Белый и черный списки сайтов

В этом окне задаются списки веб-сайтов, доступ к которым блокируется или разрешается вне зависимости от остальных настроек Родительского контроля.

Для доступа к этому окну в настройках Родительского контроля выберите раздел Фильтр URL и нажмите кнопку Белый список или кнопку Чёрный список.

Чтобы подробнее ознакомиться с какой-либо настройкой, задаваемой на этой вкладке,  щелкните по соответствующему фрагменту окна на рисунке.

Чтобы подробнее ознакомиться с какой-либо настройкой, задаваемой на этой вкладке,
щелкните по соответствующему фрагменту окна на рисунке.

По умолчанию список пуст. Вы можете добавить адреса веб-сайтов:

· если адрес сайта добавлен в «белый» список, то доступ к нему будет предоставляться вне зависимости от других настроек Родительского контроля;
· если адрес сайта добавлен в «черный» список, то доступ к нему будет блокироваться вне зависимости от других настроек Родительского контроля.

Формирование списка доменных адресов

1. На вкладке Черный список в поле ввода укажите доменное имя или часть доменного имени веб-сайта, доступ к которому вы хотите запретить вне зависимости от других ограничений. Методы ввода.
· чтобы добавить в список определенный сайт, введите его полный адрес (например, www.example.com). Доступ ко всем ресурсам, расположенным на этом сайте будет запрещен;
· чтобы запретить доступ к тем сайта, в адресе которых содержится определенный текст, введите в поле этот текст. Пример: если вы введете текст example, то доступ к адресам example.com, example.test.com, test.com/example, test.example222.ru и т. п. будет заблокирован;
· чтобы запретить доступ к определенному домену, укажите имя домена с символом «.». В таком случае все ресурсы, находящиеся на этом домене, будут отфильтрованы. Если при указании домена используется символ «/», то та часть подстроки, что стоит слева от символа «/», будет считаться доменным именем, а части справа от символа – частью блокируемого на данном домене адреса. Пример: Если вы введете текст example.com/test, то будут отфильтрованы такие адреса как example.com/test11, template.example.com/test22 и т. п.

Введенная строка при добавлении в список может быть преобразована к универсальному виду. Пример : адрес http://www.example.com будет преобразован в запись www.example.com.

2. Нажмите кнопку Добавить.
3. При необходимости повторите шаги 1 и 2 для добавления других адресов. Чтобы удалить адресата из «черного» списка, выберите соответствующий элемент в списке и нажмите кнопку Удалить.
4. Выберите вкладку Белый список.
5. В поле ввода укажите доменное имя или часть доменного имени веб-сайта, доступ к которому вы хотите разрешить вне зависимости от других ограничений. Методы ввода.
· чтобы добавить в список определенный сайт, введите его полный адрес (например, www.example.com). Доступ ко всем ресурсам, расположенным на этом сайте будет разрешен;
· чтобы разрешить доступ к тем веб-сайтам, в адресе которых содержится определенный текст, введите в поле этот текст. Пример: если вы введете текст example, то доступ к адресам example.com, example.test.com, test.com/example, test.example222.ru и т. п. будет разрешен;
· чтобы разрешить доступ к определенному домену, укажите имя домена с символом «.». В таком случае доступ ко всем ресурсам, находящиеся на этом домене, будет разрешен. Если при указании домена используется символ «/», то та часть подстроки, что стоит слева от символа «/», будет считаться доменным именем, а части справа от символа – частью разрешенного на данном домене адреса. Пример: если вы введете текст example.com/test, то будут разрешены такие адреса как example.com/test11, template.example.com/test22 и т. п.

Введенная строка при добавлении в список может быть преобразована к универсальному виду. Пример : адрес http://www.example.com будет преобразован в запись www.example.com.

6. Нажмите кнопку Добавить.
7. При необходимости повторите шаги 5 и 6 для добавления других адресов. Чтобы удалить адресата из «белого» списка, выберите соответствующий элемент в списке и нажмите кнопку Удалить.
8. По окончании редактирования списков нажмите кнопку ОК для сохранения внесенных изменений или кнопку Отмена для отказа от них.


Раздел Локальный доступ

В данном разделе задаются ограничения доступа к локальным ресурсам компьютера.

Вы можете разрешить или запретить использование съемных носителей (USB флеш-накопители, дискеты, CD/DVD приводы, ZIP-диски и т. п.) и передачу данных по сети (как локальной сети дома или на предприятии, так и сети Интернет), а также запретить доступ к конкретным папкам и файлам на вашем компьютере.

Чтобы подробнее ознакомиться с какой-либо настройкой, задаваемой в этом разделе,  щелкните по соответствующему фрагменту окна на рисунке.  Чтобы получить справку о параметрах, задаваемых в каком-либо другом разделе,  щелкните по ссылке на этот раздел на рисунке.

Чтобы подробнее ознакомиться с какой-либо настройкой, задаваемой в этом разделе,
щелкните по соответствующему фрагменту окна на рисунке.
Чтобы получить справку о параметрах, задаваемых в каком-либо другом разделе,
щелкните по ссылке на этот раздел на рисунке.

Формирование списка ресурсов ограниченного доступа

1. В группе Ограничивать доступ к папкам и файлам пользователя выберите вариант Ограничивать доступ к выбранным объектам.
2. Нажмите кнопку Обзор и выберите необходимый объект в стандартном окне операционной системы.
3. При необходимости повторите шаги 1 и 2 для добавления других каталогов и файлов. Чтобы возобновить доступ к каталогу или файлу, выберите соответствующий элемент в списке и нажмите кнопку Удалить.


Статистика

В данном окне отображаются результаты работы Родительского контроля в течение текущего сеанса.

Для доступа к этому окну откройте контекстное меню значка SpIDer Agent Значок SpIDer Agent и в подменю Родительский контроль выберите пункт Статистика.

Чтобы ознакомиться с какой-либо опцией, доступной в этом окне,  щелкните по соответствующему фрагменту окна на рисунке.

Чтобы ознакомиться с какой-либо опцией, доступной в этом окне,
щелкните по соответствующему фрагменту окна на рисунке.


Брандмауэр

Примечание

Данный компонент не включается в состав Антивируса Dr.Web для серверов Windows.

Dr.Web® Брандмауэр предназначен для защиты вашего компьютера от несанкционированного доступа извне и предотвращения утечки важных данных по сети. Этот компонент позволяет вам контролировать подключение и передачу данных по сети Интернет и блокировать подозрительные соединения на уровне пакетов и приложений.

Брандмауэр предоставляет вам следующие преимущества:

· контроль и фильтрация всего входящего и исходящего трафика;
· контроль подключения на уровне приложений;
· фильтрация пакетов на сетевом уровне;
· быстрое переключение между наборами правил;
· регистрация событий.


Обучение Брандмауэра

После установки Брандмауэра некоторое время в процессе вашей работы за компьютером производится обучение программы. При обнаружении попытки со стороны операционной системы или пользовательских приложений подключиться к сети Брандмауэр проверяет, заданы ли для этих программ правила фильтрации, и если правила отсутствуют, выводит соответствующее предупреждение:

Чтобы подробнее ознакомиться с какой-либо настройкой, задаваемой в этом разделе, щелкните по соответствующему фрагменту окна на рисунке.

Чтобы подробнее ознакомиться с какой-либо настройкой, задаваемой в этом разделе, щелкните по соответствующему фрагменту окна на рисунке.

При работе под ограниченной учетной записью (Гость) Брандмауэр Dr.Web не выдает пользователю предупреждения о попытках доступа к сети. Предупреждения будут выдаваться под учетной записью с правами администратора, если такая сессия активна одновременно с гостевой.

Обработка сообщений

1. При обнаружении попытки подключения к сети со стороны приложения, ознакомьтесь со следующей информацией:
Поле | Описание
Приложение | Наименование программы. Удостоверьтесь, что путь к нему, указанный в поле Путь к приложению, соответствует правильному расположению программы.
Путь к приложению | Полный путь к исполняемому файлу приложения и его имя.
Цифровая подпись | Цифровая подпись приложения.
Кдаленный адрес | Протокол и адрес хоста, к которому совершается попытка подключения.
Порт | Порт, по которому совершается попытка подключения.
Направление | Тип соединения.
2. Примите решение о подходящей для данного случая операции и выберите соответствующее действие нижней части окна:
· чтобы блокировать данное подключение, выберите действие Запретить однократно;
· чтобы позволить приложению данное подключение, выберите действие Разрешить однократно;
· чтобы перейти к форме создания правила фильтрации, выберите действие Создать правило. Откроется окно, в котором вы можете либо выбрать предустановленное правило, либо вручную создать правило для приложений.
Чтобы подробнее ознакомиться с какой-либо настройкой, задаваемой в этом разделе,  щелкните по соответствующему фрагменту окна на рисунке.

Чтобы подробнее ознакомиться с какой-либо настройкой, задаваемой в этом разделе,
щелкните по соответствующему фрагменту окна на рисунке.

3. Нажмите кнопку OK. Брандмауэр выполнит указанную вами операцию, и окно оповещения будет закрыто.

В случаях, когда программа, осуществляющая попытку подключения, уже известна Брандмауэру (то есть для нее заданы правила фильтрации), но запускается другим неизвестным приложением (родительским процессом), Брандмауэр выводит соответствующее предупреждение:

Чтобы подробнее ознакомиться с какой-либо настройкой, задаваемой в этом разделе,  щелкните по соответствующему фрагменту окна на рисунке.

Чтобы подробнее ознакомиться с какой-либо настройкой, задаваемой в этом разделе,
щелкните по соответствующему фрагменту окна на рисунке.

Правила для родительских процессов

1. При обнаружении попытки подключения к сети со стороны приложения, запущенного неизвестной для Брандмауэра программой, ознакомьтесь с информацией об исполняемом файле родительской программы.
2. Когда вы примете решение о подходящей для данного случая операции, выполните одно из следующий действий:
· чтобы позволить приложению подключиться к сети, нажмите кнопку Разрешить;
· чтобы блокировать подключение приложения к сети, нажмите кнопку Запретить;
· чтобы создать правило, нажмите Создать правило и в открывшемся окне задайте необходимые настройки для родительского процесса.

Чтобы подробнее ознакомиться с какой-либо настройкой, задаваемой в этом разделе,  щелкните по соответствующему фрагменту окна на рисунке.

Чтобы подробнее ознакомиться с какой-либо настройкой, задаваемой в этом разделе,
щелкните по соответствующему фрагменту окна на рисунке.

3. Брандмауэр выполнит указанную вами операцию, и окно оповещения будет закрыто.

Также возможна ситуация, при которой неизвестное приложение запускается другим неизвестным приложением, в таком случае в предупреждении будет выведена соответствующая информация и при выборе Создать правило откроется окно, в котором вы можете настроить правила как для приложений, так и для родительских процессов:

Чтобы подробнее ознакомиться с какой-либо настройкой, задаваемой в этом разделе, щелкните по соответствующему фрагменту окна на рисунке.

Чтобы подробнее ознакомиться с какой-либо настройкой, задаваемой в этом разделе, щелкните по соответствующему фрагменту окна на рисунке.


Управление Брандмауэром

Брандмауэр устанавливается как компонент сетевого подключения и запускается автоматически при загрузке операционной системы. При необходимости вы можете временно приостановить работу Брандмауэра, просмотреть статистику фильтрации и изменить настройки программы.

После открытия сессии под ограниченной учетной записью (Гость) Брандмауэр выдаст сообщение об ошибке доступа. При этом в SpIDer Agent состояние Брандмауэра отображается как неактивное. Однако Брандмауэр включен и работает в соответствии с настройками по умолчанию или с настройками, заданными ранее в административном режиме.

Управление Брандмауэром осуществляется с помощью компонента SpIDer Agent:

Меню SpIDer Agent для Dr.Web Securty Space Pro

Управление Брандмауэром

1. Откройте контекстное меню значка SpIDer Agent Значок SpIDer Agent .
2. Выберите в списке компонентов Брандмауэр.
3. В открывшемся меню выберите необходимый пункт:
Пункт меню | Описание
Статистика | Выберите этот пункт, чтобы открыть окно со сведениями об обработанных Брандмауэром событиях.
Настройки | Данный пункт недоступен в пользовательском режиме. Выберите этот пункт, чтобы получить доступ к основной части настраиваемых параметров программы. На странице Сброс настроек окна настройки Брандмауэра вы можете восстановить параметры работы программы, используемые по умолчанию.
Отключить/Запустить | Данный пункт недоступен в пользовательском режиме. Выберите этот пункт, чтобы временно отключить или заново запустить межсетевой экран. Прибегайте к возможности отключения Брандмауэра с осторожностью. Пункт Запустить появляется в меню в том случае, когда работа Брандмауэра была временно приостановлена.

Примечание

При отключении Брандмауэр запрашивается код подтверждения.


Настройки Брандмауэра

Примечание

Настройки Брандмауэра недоступны в пользовательском режиме.

Для начала работы с Брандмауэром необходимо:

· выбрать режим работы программы;
· настроить список авторизованных приложений.

После перезагрузки операционной системы, если не выбрано иначе, Брандмауэр начнет работу в режиме обучения. Вне зависимости от режима работы автоматически начнется регистрация событий.


Фильтр приложений

Фильтрация на уровне приложений позволяет контролировать доступ конкретных программ и процессов к сетевым ресурсам. Вы можете задавать правила как для пользовательских, так и для системных приложений.

Чтобы подробнее ознакомиться с какой-либо настройкой, задаваемой в этом разделе,  щелкните по соответствующему фрагменту окна на рисунке.  Чтобы получить справку о параметрах, задаваемых в каком-либо другом разделе,  щелкните по ссылке на этот раздел на рисунке.

Чтобы подробнее ознакомиться с какой-либо настройкой, задаваемой в этом разделе,
щелкните по соответствующему фрагменту окна на рисунке.
Чтобы получить справку о параметрах, задаваемых в каком-либо другом разделе,
щелкните по ссылке на этот раздел на рисунке.

На странице Настройки фильтра приложений (раздел Приложения) вы можете формировать наборы правил фильтрации, создавая новые, редактируя существующие или удаляя ненужные правила. Приложение однозначно идентифицируется полным путем к исполняемому файлу. Для указания ядра операционной системы Microsoft Windows (процесс system, для которого нет соответствующего исполняемого файла) используется имя SYSTEM.

Если файл приложения, для которого было создано правило, изменился (например, было установлено обновление), то Брандмауэр предложит подтвердить, что приложение может обращаться к сетевым ресурсам.

Формирование набора правил

Для формирования набора правил выполните одно из следующий действий:

· чтобы создать набор правил для новой программы, нажмите кнопку Создать;
· чтобы отредактировать существующий набор правил, выберите его в списке и нажмите кнопку Изменить;
· чтобы добавить копию существующего набора правил, нажмите кнопку Копировать. Копия добавляется под выбранным набором;
· чтобы удалить все правила для программы, выберите соответствующий набор в списке и нажмите кнопку Удалить.

Для каждой программы может быть не более одного набора правил фильтрации.


Правила для приложений

В окне Создание нового набора правил (или Редактирование набора правил) отображается тип правила для конкретного приложения или процесса, а также список правил, если выбран тип правила Особый. Вы можете изменять тип правила, формировать список, добавляя новые или редактируя существующие правила фильтрации, а также изменяя порядок их выполнения. Правила применяются последовательно, согласно очередности в списке.

Вы можете создать правило при помощи окна настроек Брандмауэра. При работе в режиме обучения, вы можете инициировать создание правила непосредственно из окна оповещения о попытке несанкционированного подключения.

Чтобы подробнее ознакомиться с какой-либо настройкой, задаваемой в этом разделе,  щелкните по соответствующему фрагменту окна на рисунке.

Чтобы подробнее ознакомиться с какой-либо настройкой, задаваемой в этом разделе,
щелкните по соответствующему фрагменту окна на рисунке.

Для каждого правила в списке предоставляется следующая краткая информация:

Параметр

Описание

Включено

Состояние правила.

Действие

Указывает на действие, выполняемое Брандмауэром при попытке программы подключиться к сети Интернет:

· Блокировать пакеты – блокировать попытку подключения;
· Разрешать пакеты – разрешить подключение.

Имя правила

Название правила.

Тип соединения

Указывает на инициатора подключения:

· Входящее – правило применяется, если инициируется подключение из сети к программе на вашем компьютере;
· Исходящее – правило применяется, если подключение инициирует программа на вашем компьютере;
· Любое – правило применяется вне зависимости от того, кто является инициатором подключения.

Описание

Пользовательское описание правила.

Редактирование правил

1. Если на странице Настройки фильтра приложений вы выбрали создание или редактирование набора правил, в открывшемся окне задайте программу или процесс, для которых будет применяться набор правил. Для этого выполните одно из следующих действий:
· чтобы задать набор правил для программы, нажмите кнопку Обзор Кнопка Обзор и выберите исполняемый файл программы;
· чтобы задать набор правил для процесса, нажмите стрелку на кнопке Обзор Кнопка Обзор , выберите Запущенное приложение и укажите процесс;
2. Выберите тип правила:
· Разрешать - все соединения приложения будут разрешены;
· Запрещать - все соединения приложения запрещены;
· Особый - в этом режиме вы можете создать набор правил, разрешающих или запрещающих те или иные соединения приложения.
3. Если вы выбрали тип правила Особый, создайте набор правил для приложения используя следующие опции:
· чтобы добавить новое правило, нажмите кнопку Создать. Правило добавляется в конец списка;
· чтобы отредактировать выбранное правило, нажмите кнопку Изменить;
· чтобы добавить копию выбранного правила, нажмите кнопку Копировать. Копия добавляется после выбранного правила;
· чтобы удалить выбранное правило, нажмите кнопку Удалить.
4. Если вы выбрали создание нового или редактирование существующего правила, настройте его параметры в отобразившемся окне.
5. По окончании редактирования списка нажмите кнопку ОК для сохранения внесенных изменений или на кнопку Отмена для отказа от изменений.


Настройка параметров правила

Правила фильтрации регулируют сетевое взаимодействие программы с конкретными хостами сети.

Чтобы подробнее ознакомиться с какой-либо настройкой, задаваемой в этом разделе, щелкните по соответствующему фрагменту окна на рисунке.

Чтобы подробнее ознакомиться с какой-либо настройкой, задаваемой в этом разделе, щелкните по соответствующему фрагменту окна на рисунке.

Создание правила

1. Задайте следующие параметры правила:

Параметр

Описание

Общее

Имя правила

Имя создаваемого/редактируемого правила.

Описание

Краткое описание правила.

Состояние

Состояние правила:

· Активно – правило применяется;
· Неактивно – правило временно не применяется.

Тип соединения

Инициатор подключения:

· Входящее – правило применяется, если инициируется подключение из сети к программе на вашем компьютере;
· Исходящее – правило применяется, если подключение инициирует программа на вашем компьютере;
· Любое – правило применяется вне зависимости от того, кто является инициатором подключения.

Действие

Указывает на действие, выполняемое Брандмауэром при попытке программы подключиться к сети Интернет:

· Блокировать пакеты – блокировать попытку подключения;
· Разрешать пакеты – разрешить подключение.

Настройки правила

Протокол

Протоколы сетевого и транспортного уровня, по которым осуществляется подключение.

Поддерживаются следующие протоколы сетевого уровня:

· IPv4;
· IPv6;
· IP all - протокол IP любой версии.

Поддерживаются следующие протоколы транспортного уровня:

· TCP;
· UDP;
· TCP & UDP - протокол TCP или UDP.

Входящий/Исходящий адрес

IP-адрес удаленного хоста, участвующего в подключении. Вы можете указывать как конкретный адрес (Равен), так и диапазон адресов (В диапазоне), а также маску конкретной подсети (Маска) или маски всех подсетей, в которых ваш компьютер имеет сетевой адрес (MY_NETWORK).

Чтобы задать правило для всех хостов, выберите вариант Любой.

Входящий/Исходящий порт

Порт, по которому осуществляется подключение. Вы можете указывать как конкретный порт (Равен), так и диапазон портов (В диапазоне).

Чтобы задать правило для всех портов, выберите вариант Любой.

2. По окончании редактирования нажмите кнопку ОК для сохранения внесенных изменений или на кнопку Отмена для отказа от изменений.


Родительские процессы

Чтобы разрешить или запретить процессам и приложениям запускать другие приложения, в разделе Родительские процессы задайте необходимые правила.

Чтобы подробнее ознакомиться с какой-либо настройкой, задаваемой в этом разделе,  щелкните по соответствующему фрагменту окна на рисунке.  Чтобы получить справку о параметрах, задаваемых в каком-либо другом разделе,  щелкните по ссылке на этот раздел на рисунке.

Чтобы подробнее ознакомиться с какой-либо настройкой, задаваемой в этом разделе,
щелкните по соответствующему фрагменту окна на рисунке.
Чтобы получить справку о параметрах, задаваемых в каком-либо другом разделе,
щелкните по ссылке на этот раздел на рисунке.

Создание правил для родительских процессов

1. Выберите родительский процесс:
· чтобы задать правило для программы, нажмите кнопку Создать и выберите исполняемый файл программы;
· чтобы задать правило для процесса, нажмите стрелку на кнопке Создать, выберите Запущенное приложение и укажите процесс.
2. Установите необходимое действие:
· Блокировать, чтобы запретить приложению запускать процессы;
· Разрешить, чтобы разрешить приложению запускать процессы.

По умолчанию добавляемый родительский процесс блокируется.


Фильтр пакетов

Фильтрация на уровне пакетов позволяет контролировать доступ к сети вне зависимости от программ, инициирующих подключение. Правила применяются ко всем сетевым пакетам определенного типа, которые передаются через один из сетевых интерфейсов вашего компьютера.

Данный вид фильтрации предоставляет вам общие механизмы контроля, в отличие от фильтра приложений.

Брандмауэр поставляется со следующими предустановленными наборами правил:

· Allow all – все пакеты пропускаются;
· Deny all – все пакеты блокируются;
· Default rule – правила, описывающие наиболее часто встречающиеся конфигурации сети и распространенные атаки (используется по умолчанию для всех новых интерфейсов).

Для удобства использования и быстрого переключения между режимами фильтрации вы можете задать дополнительные наборы правил.

Чтобы подробнее ознакомиться с какой-либо настройкой, задаваемой в этом разделе,  щелкните по соответствующему фрагменту окна на рисунке.  Чтобы получить справку о параметрах, задаваемых в каком-либо другом разделе,  щелкните по ссылке на этот раздел на рисунке.

Чтобы подробнее ознакомиться с какой-либо настройкой, задаваемой в этом разделе,
щелкните по соответствующему фрагменту окна на рисунке.
Чтобы получить справку о параметрах, задаваемых в каком-либо другом разделе,
щелкните по ссылке на этот раздел на рисунке.

Набор правил для интерфейса

Чтобы задать параметры работы пакетного фильтра, в окне настроек Брандмауэра выберите раздел Пакетный фильтр. На этой странице вы можете:

· формировать наборы правил фильтрации, создавая новые, редактируя существующие или удаляя ненужные правила;
· установить правила по умолчанию;
· задать дополнительные параметры фильтрации.

Формирование набора правил

Для формирования набора правил выполните одно из следующий действий:

· чтобы создать набор правил для новой программы, нажмите кнопку Создать;
· чтобы отредактировать существующий набор правил, выберите его в списке и нажмите кнопку Изменить;
· чтобы добавить копию существующего набора правил, нажмите кнопку Копировать. Копия добавляется под выбранным набором;
· чтобы удалить выбранный набор правил, нажмите кнопку Удалить.

Правила по умолчанию

Чтобы установить набор правил, применяемых по умолчанию для всех новых подключенных сетевых интерфейсов, выберите набор правил в списке и нажмите кнопку По умолчанию.

Дополнительные настройки

Чтобы задать общие настройки фильтрации пакетов, на странице Настройки пакетного фильтра установите следующие флажки:

Флажок

Описание

Включить динамическую фильтрацию пакетов

Установите этот флажок, чтобы учитывать при фильтрации состояние TCP-соединения и пропускать только те пакеты, содержимое которых соответствует текущему состоянию. В таком случае все пакеты, передаваемые в рамках соединения, но не соответствующие спецификации протокола, блокируются. Этот механизм позволяет лучше защитить ваш компьютер от DoS-атак (отказ в обслуживании), сканирования ресурсов, внедрения данных и других злонамеренных операций.

Также рекомендуется устанавливать этот флажок при использовании протоколов со сложными алгоритмами передачи данных (FTP, SIP и т.п.).

Снимите этот флажок, чтобы фильтровать пакеты без учета TCP-соединений.

Обрабатывать фрагментированные IP пакеты

Установите этот флажок, чтобы корректно обрабатывать передачу больших объемов данных. Размер максимального пакета (MTU - Maximum Transmission Unit) для разных сетей может варьироваться, поэтому часть IP-пакетов при передаче может быть разбита на несколько фрагментов. При использовании данной опции ко всем фрагментарным пакетам применяется одно и то же действие, предусмотренное правилами фильтрации для головного (первого) пакета.

Снимите этот флажок, чтобы обрабатывать все пакеты по отдельности.


Набор правил

В окне Редактирование набора правил отображается список правил фильтрации пакетов, входящих в конкретный набор. Вы можете формировать список, добавляя новые или редактируя существующие правила фильтрации, а также изменяя порядок их выполнения. Правила применяются последовательно, согласно очередности в списке.

Чтобы подробнее ознакомиться с какой-либо настройкой, задаваемой в этом разделе,  щелкните по соответствующему фрагменту окна на рисунке.

Чтобы подробнее ознакомиться с какой-либо настройкой, задаваемой в этом разделе,
щелкните по соответствующему фрагменту окна на рисунке.

Для каждого правила в списке предоставляется следующая краткая информация:

Параметр

Описание

Включено

Состояние правила.

Действие

Указывает на действие, выполняемое Брандмауэром при обработке пакета:

· Блокировать пакеты – блокировать пакет;
· Разрешать пакеты – передать пакет.

Имя правила

Имя правила.

Направление

Отправитель пакета:

· Направление правила – правило применяется, если принимается пакет из сети;
· Направление правила – правило применяется, если пакет отправляется с вашего компьютера;
· Направление правила – правило применяется вне зависимости от того, кто является отправителем пакета.

Журналирование

Режим регистрации событий. Указывает на то, какая информация должна быть занесена в отчет:

· Только заголовки – заносить в отчет только заголовки пакетов;
· Весь пакет – заносить в отчет пакеты целиком;
· Выключено - не сохранять информацию о пакете.

Описание

Краткое описание правила.

Редактирование набора правил

1. Если на странице Настройки пакетного фильтра вы выбрали создание или редактирование набора правил, в открывшемся окне задайте название набора правил.
2. Создайте правила фильтрации, используя следующие опции:
· чтобы добавить новое правило, нажмите кнопку Создать. Правило добавляется в начало списка;
· чтобы отредактировать выбранное правило, нажмите кнопку Изменить;
· чтобы добавить копию выбранного правила, нажмите кнопку Копировать. Копия добавляется перед выбранным правилом;
· чтобы удалить выбранное правило, нажмите кнопку Удалить.
3. Если вы выбрали создание нового или редактирование существующего правила, настройте его параметры.
4. Используйте стрелочки справа от списка, чтобы определить порядок выполнения правил. Правила выполняются последовательно, согласно очередности в списке.
5. По окончании редактирования списка нажмите кнопку ОК для сохранения внесенных изменений или на кнопку Отмена для отказа от изменений.


Создание правила фильтрации

Добавление или редактирование правила фильтрации

1. В окне создания или редактирования набора правил для пакетного фильтра нажмите кнопку Создать или кнопку Изменить. Откроется окно создания или редактирования правила пакетной фильтрации.
Чтобы подробнее ознакомиться с какой-либо настройкой, задаваемой в этом разделе, щелкните по соответствующему фрагменту окна на рисунке.  Чтобы получить справку о параметрах, задаваемых в каком-либо другом разделе, щелкните по ссылке на этот раздел на рисунке.

Чтобы подробнее ознакомиться с какой-либо настройкой, задаваемой в этом разделе, щелкните по соответствующему фрагменту окна на рисунке.
Чтобы получить справку о параметрах, задаваемых в каком-либо другом разделе, щелкните по ссылке на этот раздел на рисунке.

2. Задайте следующие параметры правила:

Параметр

Описание

Общее

Имя правила

Имя правила.

Описание

Краткое описание правила.

Состояние

Состояние правила:

· Активно – правило применяется;
· Неактивно – правило временно не применяется.

Направление

Отправитель пакета:

· Входящее – правило применяется, если принимается пакет из сети;
· Исходящее – правило применяется, если пакет отправляется с вашего компьютера;
· Любое – правило применяется вне зависимости от того, кто является отправителем пакета.

Действие

Указывает на действие, выполняемое Брандмауэром при обработке пакета:

· Блокировать пакеты – блокировать пакет;
· Разрешать пакеты – передать пакет.

Журналирование

Режим регистрации событий. Указывает на то, какая информация должна быть занесена в отчет:

· Только заголовки – заносить в отчет только заголовки пакетов;
· Весь пакет – заносить в отчет пакеты целиком;
· Выключено – не сохранять информацию о пакете.

Сетевой протокол

Протокол

Выберите один из следующих протоколов:

· IPv4 - Internet Protocol версии 4
· IPv6 - Internet Protocol версии 6
· IP all - Internet Protocol любой версии
· ARP - Address Resolution Protocol
· EAPoL-802.1x - Extensible Authentication Protocol over LAN (стандарт IEEE 802.1X)
· PPPoE Discovery
· PPPoE Session

Чтобы применить правило ко всем протоколам, выберите Не задан.

Локальный IP адрес

(Доступен только для протоколов IPv4, IPv6 или IP all) Выберите метод сравнения и задайте IP-адрес вашего компьютера.

Удаленный IP адрес

(Доступен только для протоколов IPv4 или IPv6) Выберите метод сравнения и задайте IP-адрес удаленного хоста.

Изменить Кнопка Изменить

(Доступен только для протокола IP all) Нажмите, чтобы открыть окно конфигурации протоколов.

Пакетные правила Dr.Web Firewall

Укажите следующие параметры:

· Локальный IPv4 адрес – метод сравнения и IP-адрес удаленного хоста в соответствии с протоколом Internet Protocol версии 4;
· Удаленный IPv4 адрес – метод сравнения и IP-адрес удаленного хоста в соответствии с протоколом Internet Protocol версии 4;
· Локальный IPv6 адрес – метод сравнения и IP-адрес удаленного хоста в соответствии с протоколом Internet Protocol версии 6;
· Удаленный IPv6 адрес – метод сравнения и задайте IP-адрес удаленного хоста в соответствии с протоколом Internet Protocol версии 6.

Транспортный протокол

Протокол

Выберите один из следующих протоколов:

· TCP
· UDP
· ICMPv4 - доступен только для сетевого протокола IPv4
· ICMPv6 - доступен только для сетевого протокола IPv6
· IGMP - доступен только для сетевого протокола IPv4
· GRE - доступен только для сетевого протокола IPv4
· SIPP-ESP

Чтобы применить правило ко всем протоколам, выберите Не задан.

Для протоколов ARP и EAPoL-802.1x выбор протокола транспортного уровня недоступен (Не задан).

Настройки MAC

Нажмите для настройки параметров фильтрации на уровне MAC-адресов.

Пакетные правила Dr.Web Firewall

Укажите следующие параметры:

· Локальный MAC – MАС-адрес локального сетевого интерфейса;
· Удаленный MAC – MАС-адрес удаленного хоста.
3. По окончании редактирования нажмите кнопку ОК для сохранения внесенных изменений или на кнопку Отмена для отказа от изменений.

Общий доступ к подключению Интернета

В случае возникновения проблем с общим доступом к подключению Интернета (т.е. блокируется доступ в Интернет с компьютеров, подключённых к узловому), настройте на узловом компьютере правило для пакетного фильтра, разрешающее все пакеты из подсети, согласно вашим локальным настройкам. Пример правила

Если IP-адреса узлового и подключенного компьютеров 192.168.1.1 и 192.168.1.2 соответственно, то правило должно выглядеть следующим образом:


Интерфейсы

На странице настроек сетевых интерфейсов (Настройки сетевых интерфейсов) вы можете указать, какой набор правил фильтрации применять для пакетов, передающихся через определенный сетевой интерфейс.

Чтобы подробнее ознакомиться с какой-либо настройкой, задаваемой в этом разделе,  щелкните по соответствующему фрагменту окна на рисунке.  Чтобы получить справку о параметрах, задаваемых в каком-либо другом разделе,  щелкните по ссылке на этот раздел на рисунке.

Чтобы подробнее ознакомиться с какой-либо настройкой, задаваемой в этом разделе,
щелкните по соответствующему фрагменту окна на рисунке.
Чтобы получить справку о параметрах, задаваемых в каком-либо другом разделе,
щелкните по ссылке на этот раздел на рисунке.

Набор правил для интерфейса

1. Чтобы задать набор правил фильтрации пакетов, передающихся через определенный интерфейс, в окне настроек Брандмауэра выберите раздел Интерфейсы.
2. Найдите в списке интересующий вас интерфейс и сопоставьте ему соответствующий набор правил. Если подходящий набор правил отсутствует в списке, создайте его.
3. Чтобы сохранить настройки, нажмите кнопку OK.


Дополнительные настройки

Режим работы задает реакцию Брандмауэра на сетевые подключения на уровне приложений.

На странице Дополнительные настройки вы можете задать режим работы Брандмауэра, а также общие настройки фильтрации для всех приложений.

Чтобы подробнее ознакомиться с какой-либо настройкой, задаваемой в этом разделе,  щелкните по соответствующему фрагменту окна на рисунке.  Чтобы получить справку о параметрах, задаваемых в каком-либо другом разделе,  щелкните по ссылке на этот раздел на рисунке.

Чтобы подробнее ознакомиться с какой-либо настройкой, задаваемой в этом разделе,
щелкните по соответствующему фрагменту окна на рисунке.
Чтобы получить справку о параметрах, задаваемых в каком-либо другом разделе,
щелкните по ссылке на этот раздел на рисунке.

Выбор режима работы

1. В окне настроек Брандмауэра выберите раздел Дополнительно.
2. Выберите один из следующих режимов работы:
· Разрешать неизвестные соединения – режим, при котором всем неизвестным приложениям предоставляется доступ к сетевым ресурсам;
· Режим обучения (создавать правила для известных приложений автоматически) – режим обучения, при котором правила для известных приложений добавляются автоматически (используется по умолчанию);
· Интерактивный режим – режим обучения, при котором пользователю предоставляется полный контроль над реакцией Брандмауэра;
· Блокировать неизвестные соединения – режим, при котором все неизвестные подключения автоматически блокируются.
3. Нажмите кнопку OK.

Интерактивный режим

В этом режиме вам предоставляется полный контроль над реакцией Брандмауэра на обнаружение неизвестного подключения, и таким образом производится обучение программы в процессе вашей работы за компьютером.

При обнаружении попытки со стороны операционной системы или пользовательского приложения получить доступ к сетевым ресурсам Брандмауэр проверяет, заданы ли для этих программ правила фильтрации. Если правила отсутствуют, то выводится соответствующее предупреждение, где вам предлагается выбрать либо временное решение, либо создать правило, по которому в дальнейшем подобные подключения будут обрабатываться.

Этот режим используется по умолчанию.

Режим обучения

В этом режиме правила для известных приложений добавляются автоматически. Для других приложений Брандмауэр предоставляет вам возможность вручную запрещать или разрешать неизвестное соединение, а также создавать для него правило.

При обнаружении попытки со стороны операционной системы или пользовательского приложения получить доступ к сетевым ресурсам Брандмауэр проверяет, заданы ли для этих программ правила фильтрации. Если правила отсутствуют, то выводится соответствующее предупреждение, где вам предлагается выбрать либо временное решение, либо создать правило, по которому в дальнейшем подобные подключения будут обрабатываться.

Режим блокировки неизвестных подключений

В этом режиме все неизвестные подключения к сетевым ресурсам, включая Интернет, автоматически блокируются.

При обнаружении попытки со стороны операционной системы или пользовательского приложения получить доступ к сетевым ресурсам Брандмауэр проверяет, заданы ли для этих программ правила фильтрации. Если правила фильтрации отсутствуют, то Брандмауэр автоматически блокирует доступ к сети и не выводит никаких сообщений. Если правила фильтрации для данного подключения заданы, то выполняются указанные в них действия.

Режим разрешения неизвестных подключений

В этом режиме доступ к сетевым ресурсам, включая Интернет, предоставляется всем неизвестным приложениям, для которых не заданы правила фильтрации. При обнаружении попытки подключения Брандмауэр не выводит никаких сообщений.

Дополнительные настройки

Чтобы задать общие настройки фильтрации для всех приложений, установите следующий флажок:

Флажок

Описание

Разрешать локальные соединения

Установите этот флажок, чтобы разрешить всем приложениям беспрепятственно устанавливать соединения на вашем компьютере. К таким подключениям правила применяться не будут.

Снимите этот флажок, чтобы применять правила фильтрации вне зависимости от того, происходит ли соединение по сети или в рамках вашего компьютера.


База известных приложений

Вы можете принять участие в пополнении базы известных приложений для Брандмауэра.

Установите флажок Отправлять в «Доктор Веб» сведения о созданных правилах, чтобы разрешить Брандмауэру автоматически отправлять сведения о созданных вами правилах.

Нажмите на ссылку Политика конфиденциальности «Доктор Веб», чтобы ознакомиться с политикой конфиденциальности на сайте компании «Доктор Веб».

Чтобы подробнее ознакомиться с какой-либо настройкой, задаваемой в этом разделе,  щелкните по соответствующему фрагменту окна на рисунке.  Чтобы получить справку о параметрах, задаваемых в каком-либо другом разделе,  щелкните по ссылке на этот раздел на рисунке.

Чтобы подробнее ознакомиться с какой-либо настройкой, задаваемой в этом разделе,
щелкните по соответствующему фрагменту окна на рисунке.
Чтобы получить справку о параметрах, задаваемых в каком-либо другом разделе,
щелкните по ссылке на этот раздел на рисунке.


Восстановление исходных настроек

На странице восстановления стандартных настроек (Восстановление исходных настроек) вы можете восстановить настройки работы вашего межсетевого экрана, рекомендуемые Брандмауэром.

Чтобы подробнее ознакомиться с какой-либо настройкой, задаваемой в этом разделе,  щелкните по соответствующему фрагменту окна на рисунке.  Чтобы получить справку о параметрах, задаваемых в каком-либо другом разделе,  щелкните по ссылке на этот раздел на рисунке.

Чтобы подробнее ознакомиться с какой-либо настройкой, задаваемой в этом разделе,
щелкните по соответствующему фрагменту окна на рисунке.
Чтобы получить справку о параметрах, задаваемых в каком-либо другом разделе,
щелкните по ссылке на этот раздел на рисунке.

Восстановление настроек

1. Чтобы восстановить стандартные параметры работы программы, в окне настроек Брандмауэра выберите раздел Сброс настроек.
2. Выполните любое из следующих действий:
· чтобы восстановить стандартные настройки фильтра приложений, в разделе Настройки фильтра приложений нажмите кнопку Восстановить;
· чтобы восстановить стандартные настройки пакетного фильтра, в разделе Настройки пакетного фильтра нажмите кнопку Восстановить;
· чтобы восстановить дополнительные настройки и стандартный режим работы Брандмауэра, в разделе Дополнительные настройки нажмите кнопку Восстановить.
3. Нажмите кнопку OK.


Регистрация событий

Все события, обработанные Брандмауэром, регистрируются в следующих журналах:

· Журнал приложений, хранящий информацию о попытках подключения к сети со стороны приложений и примененных правилах фильтрации.
· Журнал пакетного фильтра, хранящий информацию об обработанных Брандмауэром пакетах, примененных правилах фильтрации и интерфейсах, через которые эти пакеты были переданы. Уровень детализации зависит от настроек конкретных правил пакетной фильтрации.

В окне Активные приложения также отображается список приложений, подключенных к сети в данный момент.

Просмотр журналов

1. Чтобы просмотреть журналы, откройте контекстное меню значка SpIDer Agent Значок SpIDer Agent .
2. Выберите в списке компонентов Брандмауэр.
3. В открывшемся меню выберите пункт Статистика.


Активные приложения

Список активных приложений отображает информацию о приложениях, подключенных к сети в данный момент.

Чтобы подробнее ознакомиться с какой-либо настройкой, задаваемой в этом разделе,  щелкните по соответствующему фрагменту окна на рисунке.  Чтобы получить справку о параметрах, задаваемых в каком-либо другом разделе,  щелкните по ссылке на этот раздел на рисунке.

Чтобы подробнее ознакомиться с какой-либо настройкой, задаваемой в этом разделе,
щелкните по соответствующему фрагменту окна на рисунке.
Чтобы получить справку о параметрах, задаваемых в каком-либо другом разделе,
щелкните по ссылке на этот раздел на рисунке.

Столбец | Описание
Приложение | Краткое описание приложения (если доступно в операционной системе).
ИД Процесса | Идентификатор процесса.
Путь | Полный путь к исполняемому файлу приложения, подключенного в данный момент к сети.

Используйте информацию об идентификаторе процесса, соответствующего запущенной программе, чтобы при необходимости прекратить его выполнение вручную.


Журнал приложений

Журнал приложений хранит информацию о попытках подключения к сети, совершенных установленными на вашем компьютере программами.

Чтобы подробнее ознакомиться с какой-либо настройкой, задаваемой в этом разделе,  щелкните по соответствующему фрагменту окна на рисунке.  Чтобы получить справку о параметрах, задаваемых в каком-либо другом разделе,  щелкните по ссылке на этот раздел на рисунке.

Чтобы подробнее ознакомиться с какой-либо настройкой, задаваемой в этом разделе,
щелкните по соответствующему фрагменту окна на рисунке.
Чтобы получить справку о параметрах, задаваемых в каком-либо другом разделе,
щелкните по ссылке на этот раздел на рисунке.

Столбец

Описание

Время

Дата и время попытки подключения.

Приложение

Полный путь к исполняемому файлу приложения, совершавшего попытку подключения, его имя и идентификатор процесса (PID).

Имя правила

Название правила, согласно которому попытка была обработана.

Направление

Инициатор подключения:

· Входящее – правило применяется, если инициируется подключение из сети к программе на вашем компьютере;
· Исходящее – правило применяется, если подключение инициирует программа на вашем компьютере;
· Любое – правило применяется вне зависимости от того, кто является инициатором подключения.

Действие

Указывает на действие, выполненное Брандмауэром при попытке подключения:

· Заблокирован – попытка подключения была заблокирована;
· Разрешен – подключение было разрешено.

Целевой адрес

Протокол, адрес удаленного хоста и порт, по которым осуществлялось подключение.

Вы можете сохранить информацию в отчете или очистить журнал.

Сохранение журнала

Чтобы сохранить информацию о попытках приложений подключиться к сети, нажмите кнопку Сохранить и укажите имя файла.

Очистка журнала

Чтобы удалить из журнала устаревшую информацию о попытках приложений подключиться к сети, нажмите кнопку Очистить.


Журнал пакетного фильтра

Журнал пакетного фильтра хранит информацию о пакетах, переданных через установленные на вашем компьютере сетевые интерфейсы, если для этих пакетов указан режим регистрации событий Только заголовки или Весь пакет. Если для пакета был выбран режим Выключено, информация о нем отражаться не будет.

Чтобы подробнее ознакомиться с какой-либо настройкой, задаваемой в этом разделе,  щелкните по соответствующему фрагменту окна на рисунке.  Чтобы получить справку о параметрах, задаваемых в каком-либо другом разделе,  щелкните по ссылке на этот раздел на рисунке.

Чтобы подробнее ознакомиться с какой-либо настройкой, задаваемой в этом разделе,
щелкните по соответствующему фрагменту окна на рисунке.
Чтобы получить справку о параметрах, задаваемых в каком-либо другом разделе,
щелкните по ссылке на этот раздел на рисунке.

Столбец

Описание

Время

Дата и время обработки пакета.

Направление

Отправитель пакета:

· Пакет пропущен – пакет был принят из сети;
· Пакет пропущен – пакет был отправлен с вашего компьютера;
· Пакет заблокирован – пакет, идущий из сети, был заблокирован;
· Пакет заблокирован – пакет, отправленный с вашего компьютера, был заблокирован.

Имя правила

Название правила, согласно которому пакет был обработан.

Подключение

Сетевой интерфейс, через который был передан пакет.

Содержимое

Информация о содержимом пакета. Подробность детализации зависит от настроек правил пакетной фильтрации (параметр Режим отчета).

Вы можете сохранить информацию в отчете или очистить журнал.

Сохранение журнала

Чтобы сохранить информацию о пакетах, обработанных Брандмауэром, нажмите кнопку Сохранить и укажите имя файла.

Очистка журнала

Чтобы удалить из журнала устаревшую информацию о пакетах, обработанных Брандмауэром, нажмите кнопку Очистить.


Модуль обновления

Для обнаружения вредоносных объектов антивирусы компании «Доктор Веб» используют специальные вирусные базы Dr.Web, в которых содержится информация обо всех известных вредоносных программах. Так как каждый день появляются новые вирусные угрозы, то эти базы требуют периодического обновления. Такое обновление позволяет обнаруживать ранее неизвестные вирусы, блокировать их распространение, а в ряде случаев – излечивать ранее неизлечимые зараженные файлы.

Время от времени совершенствуются антивирусные алгоритмы, реализованные в виде исполняемых файлов и программных библиотек. Благодаря опыту эксплуатации антивирусов Dr.Web исправляются обнаруженные в программах ошибки, обновляется система помощи и документация.

Для поддержания актуальности вирусных баз и программных алгоритмов компанией «Доктор Веб» реализована система распространения обновлений через сеть Интернет. Модуль обновления позволяет вам в течение срока действия лицензии загружать и устанавливать дополнения к вирусным базам и обновленные программные модули.

Примечание

Для использования Модуля обновления необходимо иметь доступ в сеть Интернет или, при соответствующих настройках, зеркалам обновлений.

Модуль обновления недоступен в пользовательском режиме.

При запуске обновления через планировщик Windows допускается использование системной учетной записи.

Процедура обновления

При запуске Модуль обновления проверяет наличие ключевого файла в каталоге установки и при его отсутствии пытается получить ключевой файл через сеть Интернет на сервере «Доктор Веб». При отсутствии ключевого файла обновление Dr.Web невозможно.

При наличии ключевого файла Модуль обновления проверяет, не является ли имеющийся у вас ключевой файл заблокированным на сайте компании «Доктор Веб» (блокировка файла производится в случае его дискредитации, то есть выявления фактов его незаконного распространения). В случае блокировки пользователю выдается соответствующее сообщение, обновление не производится, а компоненты программы могут быть заблокированы.

В случае блокировки вашего ключевого файла свяжитесь с дилером, у которого вы приобрели Dr.Web.

После успешной проверки ключевого файла происходит само обновление. Модуль обновления автоматически загружает все обновленные файлы, соответствующие вашей версии Dr.Web, а если условия вашей подписки разрешают это, загружают новую версию Dr.Web (в случае ее выхода).

При обновлении исполняемых файлов и библиотек может потребоваться перезагрузка компьютера. Пользователь извещается об этом при помощи информационного окна.

См. также:

· Получение ключевого файла
· Запуск модуля обновления
· Ключевые файлы


Запуск Модуля обновления

Примечание

Для использования Модуля обновления необходимо иметь доступ в сеть Интернет или к зеркалам обновлений.

Обновление Dr.Web должно производиться под учетной записью, имеющей права Администратора.

Модуль обновления может быть запущен как автоматически (по расписанию), так и по запросу.

Вы можете запустить обновление одним из следующих способов:

· из командной строки;
· с помощью модуля управления SpIDer Agent;
· из окна Сканера Dr.Web.

Запуск обновления из командной строки

1. Перейдите в каталог установки Dr.Web (обычно, C:\Program Files\DrWeb – для 32-разрядных операционных систем и C:\Program Files (x86)\DrWeb – для 64-разрядных операционных систем) и запустите drwebupw.exe. Откроется диалоговое окно, в котором вы сможете настроить параметры и запустить обновление:

Модуль обновления Dr.Web

2. Чтобы настроить параметры обновления, нажмите кнопку Настройки.
3. Чтобы фиксировать в отчете детальную информацию о ходе обновления, установите флажок Вести подробный отчет. Отчет Модуля обновления записывается в файл drwebupw.log, который находится в каталоге %USERPROFILE%\DoctorWeb (в Windows 7, C:\Users\<имя пользователя>\DoctorWeb).
4. Чтобы запустить процесс обновления, нажмите кнопку Обновить сейчас. Для завершения работы без проведения обновления закройте окно.

Запуск обновления с помощью SpIDer Agent

1. В контекстном меню значка SpIDer Agent Значок SpIDer Agent выберите пункт Обновление. Откроется диалоговое окно, в котором вы сможете настроить параметры и запустить обновление:

Модуль обновления Dr.Web

2. Чтобы настроить параметры обновления, нажмите кнопку Настройки.
3. Чтобы фиксировать в отчете детальную информацию о ходе обновления, установите флажок Вести подробный отчет. Отчет Модуля обновления записывается в файл drwebupw.log, который находится в каталоге %USERPROFILE%\DoctorWeb (в Windows 7 – C:\Users\<имя пользователя>\DoctorWeb).
4. Чтобы запустить процесс обновления, нажмите кнопку Обновить сейчас. Для завершения работы без проведения обновления закройте окно.

Запуск обновления из Сканера Dr.Web

1. В окне Сканера Dr.Web выполните одно из следующих действий:
· в меню Файл выберите пункт Обновить;
· нажмите клавишу F8.

Откроется окно Модуля обновления и немедленно начнется обновление. Настройки Модуля обновления недоступны при таком варианте запуска обновлений.

Модуль обновления Dr.Web

2. Дождитесь окончания обновления. Чтобы остановить процесс загрузки файлов, нажмите кнопку Прервать.
3. Если из-за ошибки соединения обновление не может быть завершено, в окне выдается сообщение об этом. В этом случае нажмите на кнопку Закрыть, удостоверьтесь в наличии соединения с сетью Интернет или зеркалом обновлений (в зависимости от настроек) и повторно запустите обновление. Вы можете получить дополнительную информацию из отчета Модуля обновления, который записывается в файл drwebupw.log в каталоге %USERPROFILE%\DoctorWeb (в Windows 7, C:\Users\<имя пользователя>\DoctorWeb).

Примечание

При запуске по расписанию обновление проводится в «невидимом» режиме, отчет Модуля обновления записывается в файл drwebupw.log в каталоге установки.


Настройки Модуля обновления

Настройки программы по умолчанию являются оптимальными для большинства применений, их не следует изменять без необходимости.

Настройка параметров обновления

1. Запустите Модуль обновления из командной строки или из контекстного меню значка SpIDer Agent Значок SpIDer Agent .
2. В диалоговом окне нажмите кнопку Настройки. Откроется окно настроек, содержащее следующие разделы:
· раздел Общие, в котором задаются основные параметры обновления;
· раздел Параметры доступа к сети, в котором задается тип подключения, используемого для проведения обновления.
3. Внесите необходимые изменения. Для получения информации о настройках, расположенных в разделе, нажмите кнопку Справка Справка.
4. По окончании редактирования настроек нажмите кнопку ОК для сохранения внесенных изменений или кнопку Отмена для отказа от них.


Раздел Общие

В этом разделе задаются общие параметры работы модуля, а также адрес альтернативного сервера обновлений («зеркала») и режим загрузки обновлений.

Чтобы подробнее ознакомиться с какой-либо настройкой, задаваемой в этом разделе,  щелкните по соответствующему фрагменту окна на рисунке.  Чтобы получить справку о параметрах, задаваемых в каком-либо другом разделе,  щелкните по ссылке на этот раздел на рисунке.

Чтобы подробнее ознакомиться с какой-либо настройкой, задаваемой в этом разделе,
щелкните по соответствующему фрагменту окна на рисунке.
Чтобы получить справку о параметрах, задаваемых в каком-либо другом разделе,
щелкните по ссылке на этот раздел на рисунке.

Настройка

Описание

Путь к обновлениям

Модуль обновления может получать обновления как по сети Интернет с серверов «Доктор Веб» (рекомендуется), так и из других источников.

При использование зеркала обновлений укажите папку, откуда вы хотите загружать обновления вирусных баз Dr.Web и модулей Dr.Web.

Режим обновления

Вы можете выбрать один из вариантов загрузки обновлений:

· Обновлять все (рекомендуется), при котором загружаются обновления как для вирусных баз Dr.Web, так и для антивирусного ядра и других программных компонентов Dr.Web;
· Обновлять только вирусные базы, при котором загружаются только обновления вирусных баз Dr.Web и антивирусного ядра; другие компоненты Dr.Web не обновляются.

Внешний вид

Этот флажок регулирует отображение уведомлений об успешном обновлении компонентов и вирусных баз. При необходимости снимите этот флажок для запрета уведомлений.


Раздел Прокси

В этом разделе задаются параметры сетевого подключение, которое используется для загрузки обновлений.

Чтобы подробнее ознакомиться с какой-либо настройкой, задаваемой в этом разделе,  щелкните по соответствующему фрагменту окна на рисунке.  Чтобы получить справку о параметрах, задаваемых в каком-либо другом разделе,  щелкните по ссылке на этот раздел на рисунке.

Чтобы подробнее ознакомиться с какой-либо настройкой, задаваемой в этом разделе,
щелкните по соответствующему фрагменту окна на рисунке.
Чтобы получить справку о параметрах, задаваемых в каком-либо другом разделе,
щелкните по ссылке на этот раздел на рисунке.

В группе Тип подключения укажите способ доступа к серверу обновлений:

· если для доступа прокси-сервер не используется, выберите вариант Прямое подключение;
· если вы хотите использовать для загрузки обновлений текущие настройки подключения, выберите вариант Настройки Internet Explorer;
· если для загрузки обновлений должны использоваться настройки, отличные от текущих, выберите вариант Пользовательские настройки и укажите Адрес и порт необходимого прокси-сервера HTTP. Если на указанном прокси-сервере требуется авторизация, введите соответствующие данные в поля Имя пользователя прокси-сервера и Пароль.

Примечание

При запуске обновления по расписанию используется прямое подключение к сети Интернет, т.е. настройки Internet Explorer не могут быть использованы. Если требуется соединение через прокси-сервер, укажите необходимые параметры напрямую в настройках обновления по расписанию.


Расписание автоматического обновления

Примечание

При запуске по расписанию обновление проводится в «невидимом» режиме, отчет Модуля обновления записывается в файл drwebupw.log в каталоге установки Dr.Web.

Настройки запуска обновлений по умолчанию являются оптимальными для большинства применений, их не следует изменять без необходимости.

При установке Dr.Web в системном расписании (компонент Назначенные задания на Панели управления Windows) автоматически создается задание на обновление вирусных баз Dr.Web и компонентов Dr.Web. Также создается задание на проведение антивирусной проверки, но по умолчанию оно выключено.

Примечание

Если в состав устанавленных компонентов входит Брандмауэр, то после установки Dr.Web и первой перезагрузки служба системного расписания (Планировщик) будет заблокирована Брандмауэром. Компонент Назначенные задания будет функционировать только после повторной перезагрузки, т. к. необходимое правило уже будет создано к этому моменту.

Вы можете создавать собственные задания на обновление и антивирусное сканирование, а также удалять и редактировать задания средствами операционной системы.

Изменение параметров автоматического обновления

1. Откройте контекстное меню значка SpIDer Agent Значок SpIDer Agent .
2. В подменю Инструменты выберите пункт Планировщик. Откроется стандартное окно редактирования назначенного задания операционной системы, содержащее следующие вкладки:
· вкладка Задание, на которой указывается полное имя исполняемого файла и параметры командной строки задания. Флаг Разрешено предписывает выполнять настроенное задание (при снятом флаге задание сохраняется в папке, но не выполняется).;
· вкладка Расписание, на которой задается расписание, в соответствии с которым задание будет автоматически запускаться;
· вкладка Параметры, на которой указываются такие дополнительные параметры выполнения задания, как завершение работы компьютера по завершении обновления, особенности выполнения при работе от батареи и т.д. Не рекомендуется на этой вкладке устанавливать значение опции Выполнять не дольше чем больше 4 часов.

По умолчанию задание на автоматическое обновления называется Задание обновления Dr.Web.

3. Задайте настройки автоматического обновления.
4. По окончании редактирования настроек нажмите кнопку OK для сохранения всех внесенных изменений или кнопку Отмена для отказа от них.

Примечание

Описание настройки параметров автоматического обновления приведено для Windows XP. В Windows Vista/7 открывается стандартный планировщик заданий Windows, в котором задание настраивается аналогично.


Процедура получения ключевого файла

Модуль автоматического обновления после старта проверяет наличие ключевого файла (лицензионного или демонстрационного). При его отсутствии модуль предлагает получить его через Интернет при помощи процедуры регистрации пользователя.

Вы также можете запустить процедуру получения ключевого файла вручную. Для этого воспользуйтесь одной из следующих опций:

· в контекстном меню значка SpIDer Agent Значок SpIDer Agent в области уведомлений Windows выберите Зарегистрировать лицензию;
· в окне Менеджера лицензий нажмите кнопку Получить лицензионный ключ и в выпадающем списке выберите через сеть Интернет.

Для получения лицензионного ключевого файла вам потребуется серийный номер, выданный вам при приобретении Dr.Web. При отсутствии такого серийного номера вы можете получить только демонстрационный ключевой файл для ознакомления с работой программы в течение 30 дней.

После запуска процедуры откроется окно выбора типа ключевого файла. На любом шаге процедуры вы можете:

· нажать кнопку Далее для перехода к следующему шагу процедуры;
· нажать кнопку Назад для возвращения к предыдущему шагу процедуры;
· нажать кнопку Отмена для прекращения работы модуля обновления.


Тип ключевого файла

На первом шаге процедуры получения ключевого файла вам будет предложено выбрать тип ключевого файла:

· если у вас имеется регистрационный серийный номер, выданный вам при приобретении антивируса, нажмите кнопку Получить лицензионный ключевой файл. Откроется окно ввода серийного номера;
· если вы планируете только ознакомиться с функциями Dr.Web, нажмите кнопку Получить демонстрационный ключевой файл. Откроется окно ввода регистрационных данных.

Процедура получения ключевого файла


Лицензионный ключевой файл

Ввод серийного номера

Введите серийный номер в поле ввода и нажмите кнопку Далее.

При продлении существующей лицензии, сразу же откроется окно получения ключевого файла.

Если вы регистрируете новую лицензию, то откроется окно ввода данных о предыдущих регистрациях, а затем – окна ввода и подтверждения регистрационных данных.

Процедура получения ключевого файла


Ввод данных о предыдущих регистрациях

Если вы уже являлись пользователем Антивирусный продукт Dr.Web®, то вы можете продлить действие приобретенной лицензии на 150 дополнительных дней. Для этого укажите серийный номер либо лицензионный ключевой файл предыдущей регистрации.

Нажмите кнопку Далее. Откроется окно ввода регистрационных данных.


Ввод регистрационных данных

Для получения ключевого файла введите персональные сведения (имя, фамилию, выберите в раскрывающемся списке страну, введите город и адрес электронной почты). Все перечисленные поля являются обязательными.

Если вы хотите получать по электронной почте новости о продукте, установите соответствующий флажок.

Нажмите кнопку Далее. Откроется окно подтверждения регистрационных данных.

Процедура получения ключевого файла


Подтверждение регистрационных данных

Проверьте правильность ввода данных в этом окне. Если все данные введены верно, нажмите кнопку Далее, откроется окно получения ключевого файла.

Если необходимо внести какие-либо правки в регистрационные данные, нажмите кнопку Назад, чтобы исправить неверно введенные сведения.

Процедура получения ключевого файла


Получение ключевого файла

Процесс получения ключевого файла сопровождается выводом сообщений в поле Статус.

Если получение ключевого файла завершилось успешно, в поле Статус выводится соответствующее сообщение и указывается путь размещения полученного ключевого файла.

Нажмите на кнопку Готово, чтобы перейти к обновлению вирусных баз и других файлов пакета. Данная процедура, как правило, не требует вмешательства пользователя.

Если получение ключевого файла завершилось неудачно, в поле Статус выводится сообщение об ошибке и выводится окно Модуля обновления, в котором вы можете исправить настройки подключения к сети Интернет и доступа к серверу обновления.


Приложение A. Ключи командной строки

Ключи командной строки используются для задания параметров программам, которые могут быть запущены путем открытия на выполнение исполняемого файла. Это относится к сканерам (сканеру, консольному сканеру) и к Модулю автоматического обновления. При этом ключи могут задавать параметры, отсутствующие в конфигурационном файле, а для тех параметров, которые в нем заданы, имеют более высокий приоритет.

Ключи начинаются с символа «/» и, как и остальные параметры командной строки, разделяются пробелами.


Ключи командной строки для Сканера

/? – вывести на экран краткую справку о работе с программой и начать сканирование.

/@<имя_файла> или /@+<имя_файла> предписывает произвести проверку объектов, которые перечислены в указанном файле. Каждый объект задается в отдельной строке файла-списка. Это может быть либо полный путь с указанием имени файла, либо строка ?boot, означающая проверку загрузочных секторов, а для GUI-версии сканера также имена файлов с маской и имена каталогов. Файл-список может быть подготовлен с помощью любого текстового редактора вручную, а также автоматически прикладными программами, использующими сканер для проверки конкретных файлов. После окончания проверки сканер удаляет файл-список, если использована форма ключа без символа «+».

/AL – проверять все файлы на заданном устройстве или в заданном каталоге независимо от расширения или внутреннего формата.

/AR – проверять файлы, находящиеся внутри архивов. В настоящее время обеспечивается проверка (без лечения) архивов, созданных архиваторами ARJ, ZIP, PKZIP, ALZIP, RAR, LHA, GZIP, TAR, BZIP2, 7-ZIP, ACE и др., а также MS CAB-архивов – Windows Cabinet Files и ISO-образов оптических дисков (CD и DVD). В указанном виде (/AR) ключ задает информирование пользователя в случае обнаружения архива, содержащего зараженные или подозрительные файлы. Если ключ дополняется модификатором D, M или R, производятся иные действия: /ARD – удалять; /ARM – перемещать (по умолчанию – в подкаталог infected.!!!); /ARR – переименовывать (по умолчанию первая буква расширения заменяется на символ «#»). Ключ может завершаться модификатором N, в таком случае не будет распечатываться имя программы-архиватора после имени архивного файла.

/CU – действия над инфицированными файлами и загрузочными секторами дисков. Без дополнительных параметров D, M или R производится лечение излечимых объектов и удаление неизлечимых файлов (если другое не задано параметром /IC). Иные действия выполняются только над инфицированными файлами: /CUD – удалять; /CUM – перемещать (по умолчанию – в подкаталог infected.!!!); /CUR – переименовывать (по умолчанию первая буква расширения заменяется на символ «#»).

/DA – тестировать компьютер один раз в сутки. Дата следующей проверки записывается в файл конфигурации, поэтому он должен быть доступен для создания и последующей перезаписи.

/EX – проверять файлы с расширениями, хранящимися в конфигурационном файле, по умолчанию или при недоступности конфигурационного файла это расширения EXE, COM, DLL, SYS, VXD, OV?, BAT, BIN, DRV, PRG, BOO, SCR, CMD, 386, FON, DO?, XL?, WIZ, RTF, CL*, HT*, VB*, JS*, INF, PP?, OBJ, LIB, PIF, AR?, ZIP, R??, GZ, Z, TGZ, TAR, TAZ, CAB, HLP, MD?, INI, MBR, IMG, CSC, CPL, MBP, SH, SHB, SHS, SHT*, MSG, CHM, XML, PRC, ASP, LSP, MSO, OBD, THE*, EML, NWS, SWF, MPP, TBB.

Примечание

В случае если элемент списка проверяемых объектов содержит явное указание расширения файла, хотя бы и с применением специальных символов * и ?, будут проверены все файлы, заданные в данном элементе списка, а не только подходящие под список расширений.

/FAST предписывает произвести быструю проверку системы.

/FULL предписывает произвести полную проверку всех жестких дисков и сменных носителей (включая загрузочные секторы).

/GO – пакетный режим работы программы. Все вопросы, подразумевающие ожидание ответа от пользователя, пропускаются; решения, требующие выбора, принимаются автоматически. Этот режим полезно использовать для автоматической проверки файлов, например, при ежедневной или еженедельной проверке жесткого диска.

/HA – производить эвристический анализ файлов и поиск в них неизвестных вирусов.

/ICR, /ICD или /ICM – действия с зараженными файлами, вылечить которые невозможно: /ICR – переименовывать, /ICD – удалять, /ICM – перемещать.

/INI:<путь> – использовать альтернативный конфигурационный файл с указанным именем или путем.

/LITE предписывает произвести стартовую проверку системы, при которой проверяются оперативная память, загрузочные секторы всех дисков и объекты автозапуска.

/LNG:<имя_файла> или /LNG – использовать альтернативный файл языковых ресурсов (dwl-файл) с указанным именем или путем, а если путь не указан – встроенный (английский) язык.

/ML – проверять файлы, имеющие формат сообщений E-Mail (UUENCODE, XXENCODE, BINHEX и MIME). В указанном виде (/ML) ключ задает информирование пользователя в случае обнаружения зараженного или подозрительного объекта в почтовом архиве. Если ключ дополняется модификатором D, M или R, производятся иные действия: /MLD – удалять; /MLM – перемещать (по умолчанию – в подкаталог infected.!!!); /MLR – переименовывать (по умолчанию первая буква расширения заменяется на символ «#»). Ключ может завершаться модификатором N, в таком случае не будет выводиться сообщение "Архив mail".

/MW – действия со всеми видами нежелательных программ. В указанном виде (/MW) ключ задает информирование пользователя. Если ключ дополняется модификатором D, M, R или I, производятся иные действия: /MWD – удалять; /MWM – перемещать (по умолчанию – в подкаталог infected.!!!); /MWR – переименовывать (по умолчанию первая буква расширения заменяется на символ «#»); /MWI – игнорировать. Действия с отдельными видами нежелательных программ определяются с помощью ключей /ADW, /DLS, /JOK, /RSK, /HCK.

/NI – не использовать параметры, записанные в конфигурационном файле программы drweb32.ini.

/NR – не создавать файл отчета.

/NS – запретить возможность прерывания проверки компьютера. После указания этого параметра пользователь не сможет прервать работу программы нажатием клавиши [Esc].

/OK – выводить полный список сканируемых объектов, сопровождая незараженные пометкой Ok.

/PF – запрашивать подтверждение на проверку следующей дискеты.

/PR – выводить запрос подтверждения перед действием.

/QU – сканер выполняет проверку указанных в командной строке объектов (файлов, дисков, каталогов), после чего автоматически завершается (только для GUI-версии сканера).

/RP<имя_файла> или /RP+<имя_файла> – записать отчет о работе программы в файл, имя которого указано в ключе. При отсутствии имени записать в файл по умолчанию. При наличии символа «+» файл дописывается, при отсутствии – создается заново.

/SCP:<n> задает приоритет выполнения сканирования. <n> может принимать значения от 1 до 50 включительно.

/SD – проверять подкаталоги.

/SHELL – для GUI-версии сканера. Отменяет показ заставки, отключает проверку памяти и файлов автозагрузки. Также не загружаются для проверки ранее сохраненные списки путей к проверяемым по умолчанию файлам и каталогам. Этот режим позволяет использовать GUI-версию сканера вместо консольной для проверки только тех объектов, которые перечислены в параметрах командной строки.

/SL – осуществлять переход по символическим ссылкам во время проверки (только для консольного Сканера).

/SO – включить звуковое сопровождение.

/SPR, /SPD или /SPM – действия с подозрительными файлами: /SPR – переименовывать, /SPD – удалять, /SPM – перемещать.

/SS – по окончании работы сохранить режимы, заданные при текущем запуске программы, в конфигурационном файле.

/ST задает скрытый режим работы GUI-версии сканера. Программа работает, не открывая никаких окон и самостоятельно завершаясь. Но если в процессе сканирования были обнаружены вирусные объекты, по завершении работы будет открыто обычное окно сканера. Такой режим работы сканера предполагает, что список проверяемых объектов задается в командной строке.

/TB – выполнять проверку загрузочных секторов и главных загрузочных секторов (MBR) жесткого диска.

/TM – выполнять поиск вирусов в оперативной памяти (включая системную область Windows, только для сканеров для Windows).

/TS – выполнять поиск вирусов в файлах автозапуска (по папке Автозагрузка, системным ini-файлам, реестру Windows). Используется только для сканеров для Windows.

/UPN – при проверке исполняемых файлов, упакованных специальными программами-упаковщиками, не выводить в файл отчета названия программ, использованных для упаковки.

/WA – не завершать работу программы до нажатия на любую клавишу, если обнаружены вирусы или подозрительные объекты (только для консольных сканеров).

Некоторые параметры допускают задание в конце символа «-». В такой "отрицательной" форме параметр означает отмену соответствующего режима. Такая возможность может быть полезна в случае, если этот режим включен по умолчанию или по выполненным ранее установкам в конфигурационном файле. Список параметров командной строки, допускающих "отрицательную" форму: /ADW, /AR, /CU, /DLS, /FAST, /FULL, /HA, /HCK, /IC, /JOK, /ML, /MW, /OK, /PF, /PR, /RSK, /SD, /SL, /SO, /SP, /SS, /TB, /TM, /TS, /WA.

Для ключей /CU, /IC и /SP «отрицательная» форма отменяет выполнение любых действий, указанных в описании этих параметров. Это означает, что в отчете будет фиксироваться информация о зараженных и подозрительных объектах, но никаких действий над этими объектами выполняться не будет.

Для ключей /INI и /RP «отрицательная» форма записывается в виде /NI и /NR соответственно.

Для ключей /AL и /EX не предусмотрена «отрицательная» форма, однако задание одного из них отменяет действие другого.

Если в командной строке встречаются несколько взаимоисключающих ключей, то действует последний из них.


Ключи для Консольного Сканера DWScancl

/AR – проверять архивы. По умолчанию опция включена.

/AC – проверять контейнеры. По умолчанию опция включена.

/AFS – использовать прямой слеш при указании вложенности внутри архива. По умолчанию опция отключена.

/ARC:<число> – максимальный уровень сжатия. Если Консольный сканер определяет, что коэффициент сжатия архива превышает указанный, распаковка и проверка не производится. По умолчанию – без ограничений.

/ARL:<число> – максимальный уровень вложенности проверяемого архива. По умолчанию – без ограничений.

/ARS:<число> – максимальный размер проверяемого архива, в килобайтах. По умолчанию – без ограничений.

/ART:<число> – порог проверки уровня сжатия (минимальный размер файла внутри архива, начиная с которого будет производиться проверка коэффициента сжатия), в килобайтах. По умолчанию – без ограничений.

/ARX:<число> – максимальный размер проверяемых объектов в архивах, в килобайтах. По умолчанию – без ограничений.

/BI – вывести информацию о вирусных базах. По умолчанию опция включена.

/DR – рекурсивно сканировать директории (проверять поддиректории). По умолчанию опция включена.

/E:<число> – использовать указанное количество движков.

/FL:<имя_файла> – сканировать пути, указанные в файле.

/FM:<маска> – сканировать файлы по маске. По умолчанию сканируются все файлы.

/FR:<регулярное_выражение> – сканировать файлы по регулярному выражению. По умолчанию сканируются все файлы.

/H или /? – вывести на экран краткую справку о работе с программой.

/HA – производить эвристический анализ файлов и поиск в них неизвестных вирусов. По умолчанию опция включена.

/KEY:<ключевой_файл> – указать путь к ключевому файлу. Параметр необходим в том случае, если ключевой файл находится не в той же директории, что и Консольный сканер. По умолчанию используется drweb32.key или другой подходящий из директории C:\Program Files\DrWeb\.

/LN – сканировать файлы, на которые указывают ярлыки. По умолчанию опция отключена.

/LS – сканировать под учетной записью LocalSystem. По умолчанию опция отключена.

/MA – проверять почтовые файлы. По умолчанию опция включена.

/MC:<число> – установить максимальное число попыток вылечить файл. По умолчанию – без ограничений.

/NB – не создавать резервные копии вылеченных/удалённых файлов. По умолчанию опция отключена.

/NI[:X] – уровень использования ресурсов системы, в процентах. Определяет количество памяти используемой для сканирования и системный приоритет задачи сканирования. По умолчанию – без ограничений.

/NT – сканировать NTFS-потоки. По умолчанию опция включена.

/OK – выводить полный список сканируемых объектов, сопровождая незараженные пометкой Ok. По умолчанию опция отключена.

/P:<приоритет> – приоритет запущенной задачи сканирования в общей очереди задач на сканирование:

0 – низший.

L – низкий.

N – обычный. Приоритет по умолчанию.

H – высший.

M – максимальный.

/PAL:<число> – уровень вложенности упаковщиков. По умолчанию – 1000.

/RA:<имя файла> – дописать отчет о работе программы в указанный файл. По умолчанию – отчет не создается.

/RP:<имя файла> – записать отчет о работе программы в указанный файл. По умолчанию – отчет не создается.

/RPC:<число> – таймаут соединения c Scanning Engine, в секундах. По умолчанию – 30 секунд.

/RPCD – использовать динамический идентификатор RPC.

/RPCE – использовать динамический целевой адрес RPC.

/RPCE:<целевой_адрес> – использовать указанный целевой адрес RPC.

/RPCH:<имя_хоста> – использовать указанное имя хоста для вызовов RPC.

/RPCP:<протокол> – использовать указанный протокол RPC. Возможно использование протоколов: lpc, np, tcp.

/QL – вывести список всех файлов, помещённых в карантин на всех дисках.

/QL:<имя_логического_диска> – вывести список всех файлов, помещённых в каранатин на указанном логическом диске.

/QR[:[d][:p]] – удалить файлы с указанного диска <d> (имя_логического_диска), находящие в карантине дольше <p> (количество) дней. Если <d> и <p> не указаны, то будут удалены все файлы, находящиеся в карантине, со всех логических дисков.

/QNA – выводить пути в двойных кавычках.

/REP – сканировать по символьным ссылкам. По умолчанию опция отключена.

/SCC – выводить содержимое составных объектов. По умолчанию опция отключена.

/SCN – выводить название контейнера. По умолчанию опция отключена.

/SPN – выводить название упаковщика. По умолчанию опция отключена.

/SLS – выводить логи на экран. По умолчанию опция включена.

/SPS – отображать процесс проведения сканирования. По умолчанию опция включена.

/SST – выводить время сканирования файла. По умолчанию опция отключена.

/TB – выполнять проверку загрузочных секторов и главных загрузочных секторов (MBR) жесткого диска. По умолчанию опция отключена.

/TM – выполнять поиск вирусов в оперативной памяти (включая системную область Windows). По умолчанию опция отключена.

/TS – выполнять поиск вирусов в файлах автозапуска (по папке Автозагрузка, системным ini-файлам, реестру Windows). По умолчанию опция отключена.

/TR – сканировать системные точки восстановления. По умолчанию опция отключена.

/W:<число> – максимальное время сканирования, в секундах. По умолчанию – без ограничений.

/WCL – вывод, совместимый с drwebwcl.

/X:S[:R] – по окончании сканирования перевести машину в указанный режим: выключение/перезагрузка/ждущий режим/спящий режим.

Задание действий с различными объектами (C – вылечить, Q – переместить в карантин, D – удалить, I – игнорировать, R – информировать. По умолчанию для всех – информировать):

· /AAD:<действие> – действия для рекламных программ (возможные действия: DQIR)
· /AAR:<действие> – действия с инфицированными архивами (возможные действия: DQIR)
· /ACN:<действие> – действия с инфицированными контейнерами (возможные действия: DQIR)
· /ADL:<действие> – действия с программами дозвона (возможные действия: DQIR)
· /AHT:<действие> – действия с программами взлома (возможные действия: DQIR)
· /AIC:<действие> – действия с неизлечимыми файлами (возможные действия: DQR)
· /AIN:<действие> – действия с инфицированными файлами (возможные действия: CDQR)
· /AJK:<действие> – действия с программами-шутками (возможные действия: DQIR)
· /AML:<действие> – действия с инфицированными почтовыми файлами (возможные действия: QIR)
· /ARW:<действие> – действия с потенциально опасными файлами (возможные действия: DQIR)
· /ASU:<действие> – действия с подозрительными файлами (возможные действия: DQIR)

Некоторые ключи могут иметь модификаторы, с помощью которых режим явно включается либо отключается. Например:

/AC- режим явно отключается,
/AC, /AC+ режим явно включается.

Такая возможность может быть полезна в случае, если режим включен/отключен по умолчанию или по выполненным ранее установкам в конфигурационном файле. Список ключей, допускающих применение модификаторов: /AR, /AC, /AFS, /BI, /DR, /HA, /LN, /LS, /MA, /NB, /NT, /OK, /QNA, /REP, /SCC, /SCN, /SPN, /SLS, /SPS, /SST, /TB, /TM, /TS, /TR, /WCL.

Для ключа /FL модификатор "-" означает: проверить пути, перечисленные в указанном файле, и удалить этот файл.

Для ключей /ARC, /ARL, /ARS, /ART, /ARX, /NI[:X], /PAL, /RPC, /W, принимающих в качестве значения параметра <число>, "0" означает, что параметр используется без ограничений.

Пример использования ключей при запуске Консольного сканера DWScancl:

[<путь_к_программе>]dwscancl /AR- /AIN:C /AIC:Q C:\

проверить все файлы, за исключением архивов, на диске C, инфицированные файлы лечить, неизлечимые поместить в Карантин.


Ключи для Модуля обновления

При запуске Модуля обновления из Планировщика заданий Windows или в режиме командной строки вы можете ввести следующие ключи командной строки:

/DBG – вести подробный отчет.

/DIR:<каталог> – переназначение каталога, в который устанавливаются файлы обновления; по умолчанию это каталог, из которого модуль обновления был запущен.

/INI:<путь> – использовать альтернативный конфигурационный файл с указанным именем или путем.

/GO – пакетный режим работы, без диалоговых остановок.

/LNG:<имя_файла> – имя файла языковых ресурсов; если не указано, использовать английский язык.

/NI – не использовать параметры, записанные в конфигурационном файле программы drweb32.ini.

/NR – не создавать файл отчета.

/PASS:<пароль пользователя http-сервера> – пароль пользователя сервера обновлений.

/PPASS:<пароль пользователя прокси> – пароль пользователя прокси-сервера.

/PUSER:<имя пользователя прокси> – имя пользователя прокси-сервера.

/PURL:<адрес прокси> – адрес прокси-сервера.

/QU – принудительно закрывать модуль обновления после окончания сеанса обновления независимо от того, успешно оно прошло или нет. Успешность обновления можно проверить по коду возврата программы drwebupw.exe (например, из bat-файла по значению переменной errorlevel: 0 – успешно, другие значения – неуспешно).

/REG – запуск Модуля обновления в режиме регистрации и получения регистрационного ключа.

/RP<имя_файла> или /RP+<имя_файла> – записать отчет о работе программы в файл, имя которого указано в ключе. При отсутствии имени записать в файл по умолчанию. При наличии символа «+» файл дописывается, при отсутствии – создается заново.

/SETTINGS – отобразить окно настроек модуля автоматического обновления.

/SO – включить звуковое сопровождение (только при возникновении ошибки).

/ST – запускать модуль обновления в невидимом окне (stealth mode).

/UA – загрузка всех файлов, заявленных в списке обновления, независимо от используемой системы и установленных компонентов. Режим предназначен для получения полной локальной копии серверной области обновления Dr.Web; этот режим нельзя использовать для обновления антивируса, установленного на компьютере.

/UPM:<режим прокси> – режим использования прокси-сервера; может принимать следующие значения:

· direct – не использовать прокси-сервер;
· ieproxy – использовать системные настройки;
· userproxy – использовать настройки, задаваемые пользователем (в разделе Прокси настроек Модуля обновления или ключами /PURL /PUSER /PPASS).

/URL:<url сервера обновления> – допускаются только UNC-пути.

/URM:<режим> – режим перезагрузки после обновления; может принимать следующие значения:

· prompt – по окончании сеанса обновления в случае необходимости перезагрузки выдавать запрос
· noprompt – в случае необходимости перезагружаться без выдачи запроса
· force – перезагружать принудительно всегда (независимо от того, требуется это для обновления или нет)
· disable – запретить перезагрузку

/UPD – обычное обновление; применяется в паре с ключом /REG: в режиме регистрации дополнительно запустить и собственно сеанс обновления.

/USER:<имя пользователя http-сервера> – имя пользователя сервера обновлений.

/UVB – обновлять только вирусные базы и ядро drweb32.dll (отменяет действие ключа /UA , если он задан).

Ключ /SO допускает задание в конце символа «-». В такой «отрицательной» форме ключ означает отмену соответствующего режима. Такая возможность может быть полезна в случае, если этот режим включен по выполненным ранее установкам в конфигурационном файле.

Для ключей /INI и /RP «отрицательная» форма записывается в виде /NI и /NR соответственно.

Если в командной строке встречаются несколько взаимоисключающих ключей, то действует последний из них.


Приложение Б. Техническая поддержка

Страница службы технической поддержки компании «Доктор Веб» находится по адресу http://support.drweb.com/.

При возникновении проблем с установкой или работой продуктов компании, прежде чем обращаться за помощью в отдел технической поддержки, настоятельно рекомендуется попробовать найти решение одним из следующих способов:

· Ознакомиться с последними версиями описаний и руководств по адресу http://solutions.drweb.com/
· Прочитать раздел часто задаваемых вопросов по адресу http://support.drweb.com/faq/
· Посетить форумы Dr.Web по адресу http://forum.drweb.com/

Если после этого вам не удалось решить проблему, то вы можете заполнить веб-форму вопроса в соответствующей секции раздела http://support.drweb.com/.

Найти ближайшее к вам представительство «Доктор Веб» и всю контактную информацию, необходимую пользователю, вы можете по адресу http://company.drweb.com/contacts/moscow.


.topic 2
Здесь указывается дата и время последнего обновления вирусных баз Dr.Web
.topic 3
Здесь указывается количество записей, содержащихся в вирусных базах Dr.Web
.topic 1
F1 – вызвать справку
F3 – открыть главное окно Cканера Dr.Web на вкладке Проверка
F4 – открыть главное окно Cканера Dr.Web на вкладке Статистика
F5 – открыть окно задания пути и маска проверки
F7 – запустить быструю проверку (сканирование оперативной памяти и объектов автозапуска)
F8 – запустить процесс обновления
F9 – открыть окно настроек Cканера Dr.Web
F10 – перевести фокус на меню текущего окна
Ctrl+F5 – запустить сканирование
Ctrl+F6 – остановить сканирование
Ctrl+F2 – очистить отчет Cканера Dr.Web
Alt+X – завершить работу Cканера Dr.Web
.topic 1002
Нажмите, чтобы получить лицензионный или демонстрационный ключевой файл сети Интернет с помощью процедуры регистрации. Также вы можете установить имеющийся ключевой файл
.topic 2004
Получать уведомления веб-антивируса SpIDer Gate
.topic 2003
Получать  уведомления почтового сторожа SpIDer Mail
.topic 2005
Получать  уведомления модуля Родительского контроля
.topic 2006
Получать уведомления об обновлении вирусных баз
.topic 1001
Информация о текущей лицензии, включая серийный номер, имя владельца, срок действия и расположение ключевого файла. Вы можете выбрать другую лицензию в выпадающем списке, расположенном выше
.topic 286
Введите новый пароль для доступа к настройкам Родительского контроля
.topic 285
Введите пароль для доступа к настройкам Родительского контроля